Automatically turn 3G/Mobile Data on when MMS is received


Last Updated:

  1. mcbecker56

    mcbecker56 Member

    Hi,

    I just downloaded Tasker about an hour ago and was looking how to set up a profile in which 3G/Mobile Data is automatically turned on when a MMS is received and then automatically turn back off.

    I'm just a beginner but I was thinking there could potentially be 2 issues. The first being; On my particular phone, I have to turn off Wi-Fi then connect to 3G in order to download a picture message. So, say I was currently connected to Wi-Fi and received a MMS. Could the profile be triggered to turn off Wi-Fi, connect to 3G/Mobile Data, turn 3G/Mobile Data back off after a specified amount of time, then reconnect to Wi-Fi? Loaded question I know, but that is the best way I could describe it.

    The second issue I thought might come up is what if I was already connected to 3G/Mobile Data? Would that interfere with the Tasker action? Would it Think it connected when I received a MMS and then automatically shut off despite that fact it was originally connected?

    Any help would be greatly appreciated. Thanks a lot in advance.

    Advertisement
  2. userloser

    userloser Active Member

    1. yes, you can.
    2. no, tasker isn't like the nurse who woke the patient so that he could take his sleeping pills. if you are connected, the task will do nothing.
    3. you could test easily what hapens yourself.
    electricpete likes this.
  3. SUroot

    SUroot Well-Known Member Developer

    I've been asked about this profile before and it doesn't really work. You need mobile data on to receive the mms to trigger the profile to turn on the mobile data to receive the mms. You can't use a circular reference. Tasker would need to see into the future for that.

    If mobile data is off or MMS is not configured, you may receive it as an SMS with a link or even a download button. You'd think then that receiving one of these SMS could be the trigger, however you already have the download button before it turns on mobile data so it still doesn't automatically download. It takes a while to turn on mobile data too.

    On another more positive note, the solution is simple and doesn't even need tasker.

    You simply need a second APN. Duplicate what you already have but change apn type to "mms". If you've done it right, you cannot select this new apn with a radio button.

    Tge problem before was you had a default apn. The default apn usually has internet AND mms settings but it only connects when mobile data is on.

    You'll want to strip out the internet stuff from the duplicate. You only need from MMSC downwards, unless you need a password.

    You can test yourself by sending an mms to yourself whilst on wifi

    Hope this helps. It *should* work
  4. tatootie67

    tatootie67 Well-Known Member

    I got this profile to work and I use it all the time. I do the same thing for my voice mail because for one reason or another Verizon visual voice mail needs the mobile data to work.
    I simply enable my data when a voice mail or mms comes in. I set a 1minute timer, than have it toggle back to off.

    The incoming mms triggers the task to enable the data. It usually will download by itself without me having to click the download button.
    I don't know if it makes a difference but I use battery defender to disrupt my data off with screen off though.
    electricpete likes this.
  5. SUroot

    SUroot Well-Known Member Developer

    Oh that's good news then, however its not the best solution for the op
  6. electricpete

    electricpete Well-Known Member

    Great info. It goes to show, you never know until you try.
  7. SUroot

    SUroot Well-Known Member Developer

    Of course I suppose it must be tried on every phone. I assumed that since it didn't work on some, it wouldn't work on any
  8. mcbecker56

    mcbecker56 Member

    Thanks everyone. I ended up creating it. I have it so when a MMS comes in it will turn my wifi off if it is on, turn mobile data on for 2 min, then turn mobile data off, then wifi back on if I'm at home. I also created a widget to toggle between the two just in case. Once again, thanks for all the replies.
  9. SUroot

    SUroot Well-Known Member Developer

    I really do think you should also test the solution I posted. This doesn't need to be a tasker profile. Its just a config error on your phone
  10. tatootie67

    tatootie67 Well-Known Member

    I would like to try this but I'm too new at this yo fully implement your suggestion. Would you be able to give me a step by step example?
  11. SUroot

    SUroot Well-Known Member Developer

    In android settings (ICS+)

    More settings > Mobile Networks > Access point names

    Go into whichever has the selected radio button next to it and write down all the settings then press back

    Press Menu > new APN and fill in all teh fields you wrte down from MMSC field onwards.

    The setting that is called "Apn type" you must set as MMS.

    Android uses this to allow MMS conenctions whilst the other default APN is not connected.

    Some Carriers know this and set up the phones with 2 APN. Others do not.

    Then you can test it. Just send yourself an MMS whilst on wifi. You cans end and receive without having to lose your wifi connection, which is better if you are streaming a video or downloading a file because the tasker profile will interupt that stream / download.
  12. tatootie67

    tatootie67 Well-Known Member

    Before I try this, my apn type right now (the existing one) is listed as
    Default. Mms. Dun. Stdhipri. Supl

    Since it has mms listed in there does that mean I should not set up another one?
    Also, what about the apn name. Is this important? And would I be changing the radio button to the new one I create?
  13. SUroot

    SUroot Well-Known Member Developer

    take MMS out. APN name call it whatever so you can recognise it. If you can backup your apn forst, it may be a good idea. There are apn backup apps.
  14. tatootie67

    tatootie67 Well-Known Member

    So once I take mms out, what should my radio button be set on. This new one without the mms or the old one. I don't understand which apn will be used and for what.
  15. SUroot

    SUroot Well-Known Member Developer

    You remove mms from the existing apn's apn type. You then create a new apn with the details I said and add the apn type of mms.

    The mms only apn will not be selectable. The select radio button will actually be missing.

    So the existing apn will be used for everything except mms (hence removing mms from apn type). The new one will be used for mms. Its all very straight forward


    The two apns can be identical if you like. You just need to ensure one ONLY has MMS in the type field and the other DOESN'T have MMS in the type field
    XplosiV likes this.
  16. tatootie67

    tatootie67 Well-Known Member

    I did as you said and it has a radio button next to this new one I made. Any idea what I did wrong?
  17. SUroot

    SUroot Well-Known Member Developer

    Ahh "mms" must be lower case. I didn't know that. There should be no punctuation whatsoever. Literally just 3 letters in apn type:


    mms
  18. tatootie67

    tatootie67 Well-Known Member

    So I need to get rid of that entire string and replace it with mms only? What about the mmsc part? I have a long string of characters in there too and it has mms at the beginning and at the end if the string.


    I think I'm going to give up on this. I'm really confused because I have 2 apns already. They both are identical except one under - bearer - is LTE and the other is something else. They both have radio Buttons and when you click on them to try and edit them, all the information is grayed out. Like every single line.
    I think there is more to this than meets the eye.
  19. SUroot

    SUroot Well-Known Member Developer

    You're simply over thinking it. There's less to it than you think meets the eye.

    Basically take your main one that has:

    Default. Mms. Dun. Stdhipri. Supl

    as the apn type. Write everything in that apn down on a peace of paper.

    Create a new apn and put in it everything that you wrote down on the paper, except the apn type, where you should only put:

    mms

    Thats it, it really is that simple. I can't explain it any simpler than that. You need one that is identical to the default one, except the type is mms only. So YOU will then have 3 apns....
  20. tatootie67

    tatootie67 Well-Known Member

    What about the setting for mmsc. In my other 2 apns there is a string of information, and mms is in there too.
    What's confusing me is you told me to delete the mms mention in my main apn, but it's all grayed out!
  21. SUroot

    SUroot Well-Known Member Developer

    On other phones you can edit this. If you cannot edit out the mms from the "apn type" then the work around would be longer.

    1. Duplicate the main apn, and leave "mms" out of the "apn type" field. Select this apn with the radio button. This now becomes your main apn

    2. Duplicate the main apn again and only have "mms" in the "apn type" field

    3. If you can delete the original main apn, do so. If not, simply selecting the 1st duplicate instead should be sufficient
  22. tatootie67

    tatootie67 Well-Known Member

    This totally is not working. My phone crashed and rebooted itself. When it came back on, I had no Internet at all.

    There must be another setting that has to be entered. I followed your instructions to the letter. Maybe it's Verizon itself, no idea.

    Anyways, thank you for all your patience and to the op, sorry I hijacked your thread.
  23. SUroot

    SUroot Well-Known Member Developer

    Ah its probably Verizon then. I thought youd be from the US when you said it was greyed out
  24. tatootie67

    tatootie67 Well-Known Member

    I am in the us.
  25. SUroot

    SUroot Well-Known Member Developer

    Yeah, US carriers (especially verizon) seem to lock a lot of a phones functionality down, probably in a bid to stop you using the phone elsewhere. Shame for the consumer really.

    Sorry I can't help :(

Share This Page