[Avail 2] Root available?


Last Updated: 2013-11-20 17:16:08
  1. misternad

    misternad Active Member

    Has anyone figured out how to root this yet? Been digging through other jellybean methods and haven't had any success.

    Comes with a slew of preinstalled crap that I've forcefully disabled or removed. (Facebook being the first to go.)

    I've tried all current methods and none of them have been successful.

    Update.zip and clear, failed.
    jcase method, failed.
    avail method, failed.
    motochopper, failed.
    cwm, not willing to attempt, almost certainly brick.
    adb restore methods (by Bin4ry), failed.

    Phone contains both a system recovery (accessed by powering off, then holding Volume-Up and Menu, pressing power.) and FTM mode. (Power off, hold Volume-Down and press power)

    Advertisement
  2. micallan_17

    micallan_17 Well-Known Member Contributor

    i doubt the current methods of rooting will work for this phone, i would be interested in finding out if it has an FTM mode and if it comes with a bootloader
  3. misternad

    misternad Active Member

    I'm a tech-head anything with a powersupply, however phones and this mobile world are outside my experience.

    FTM?

    I'm willing to go about putzing around with the phone but I have no idea where to start. :(
  4. micallan_17

    micallan_17 Well-Known Member Contributor

    FTM mode:
    1. Turn Phone off
    2. Press and hold Volume down button then Press and hold Power button till a screen will come out and say "FTM"
    niteridet likes this.
  5. misternad

    misternad Active Member

    You mean the boot menu for restoration / data clearing? Yes, it's there.

    (Though I accessed it holding Volume Up + Menu, then pressing power button)
  6. out of ideas

    out of ideas Well-Known Member

    No thats the system recovery, it's different.

    you can try boot up holding different button combos and tell us what you find.
  7. misternad

    misternad Active Member

    FTM's there as well it seems. Volume Down + Power.

    EDIT:
    Not that I know if/how that helps, anyway.
  8. micallan_17

    micallan_17 Well-Known Member Contributor

    Well having FTM mode means that if by some reason a ROM soft bricks the phone, this can help in returning the phone to it factory state, it saves you from using the recovery menu if for some reason you loose the recovery software.
  9. misternad

    misternad Active Member

    So since I don't really care too terribly much if I end up bricking it- Anyone have any ideas how I might approach rooting it? (ie; ideas to try?)
  10. micallan_17

    micallan_17 Well-Known Member Contributor

    maybe we need to wait on some of the Developers here to get one of those devices with them for them to start rooting, the device is fairly new so your are just one of the few people that have it. i would want one too but i dont live in the US, so it makes it harder for me to get my hands on one. but try this dialer code *983*7668# (this provided a temporary root on the Avail) and see if anything pops up on your screen
  11. misternad

    misternad Active Member

    If I remember reading correctly, enter the code, don't press 'send' and see if anything happens?

    In either case, with 1 or 2 hash's at the end, nothing happens. :(
  12. micallan_17

    micallan_17 Well-Known Member Contributor

    yeah so that means we cannot use the same root method,, is there any developer interested in looking at this thing?
  13. out of ideas

    out of ideas Well-Known Member

    Not sure how jelly bean handles the rooting process, and I think this might only be for gingerbread, but it might be worth a shot flashing stayboogys update.zip from the merit/avail1

    http://androidforums.com/merit-all-things-root/676258-root-update-zip-root.html

    try it and see what happens I suppose.

    the codes were closed on the merit, so they wont work on 2.3.5 plus, and someone was trying to jcase method but keeps getting permission denied on the mkdir commands.

    So if you dont mind being the first astronaut I would try it :)

    good luck
  14. misternad

    misternad Active Member

    I put that .zip in /sdcard (which is ln'd to /storage/sdcard0) and no matter what option is chosen in the recovery menu, it ignores it completely.

    Are the updates indeed supposed to be .zip files with JellyBean?

    There is however an option that allows installing an update from ADB, upon selecting the option it states:
    [HIGH]Now send the package you want to apply to the device with "adb sideload <filename>"...[/HIGH]

    EDIT:
    Menu is laid out as such: [
  15. micallan_17

    micallan_17 Well-Known Member Contributor

    So lets try to come up with ways on how we can root this phone, first what is it that developers look for when they are trying to find a root method for new devices?
    any developer is welcomed to answer :)
  16. Motorhead1991

    Motorhead1991 Well-Known Member

  17. micallan_17

    micallan_17 Well-Known Member Contributor

    would you have any ideas as to where to begin looking for a root?, i mean lets try to think as someone who is trying to root a new device
  18. misternad

    misternad Active Member

    I've tried all methods offered in the batch file, none work. :(

    Phone's so-far retaining it's non-bricked status though, so that's a plus.
  19. out of ideas

    out of ideas Well-Known Member

    ok heres one for the ZTE blade G with jelly bean out of serbia. might be a good place to start

    Root ZTE Blade G v5 - 4.1.2 Jelly Bean | Root Srbija

    thats the page in serbian(try google translate to see what its about)
    and the XDA link to it
    http://forum.xda-developers.com/showthread.php?t=2375465

    does the avail2 come with the drivers installed already or not?

    heres one for a ZTE avid 4G on ICS. ignore the CWM part cuz that will probably brick you.

    How to Root and Install Custom recovery on ZTE Avid 4G - Guide : DroidKube

    seems you adb and fastboot stuff

    and a link for ZTE force $G LTE root

    ZTE Force 4g LTE - Android Forums at AndroidCentral.com

    These would be worth looking into for different people, i would give them a more thorough look, but im beyond swamped with stuff right now, and im about to leave to go watch comets. so goodluck. anyone on the dev tip can feel free to check these out too.
  20. micallan_17

    micallan_17 Well-Known Member Contributor

    I taught i was the only one who was going to watch comets tonight haha, hope you have fun, thanks for the link too
  21. misternad

    misternad Active Member

    Yes, it comes with drivers, though getting it to be seen by ADB was initially a pain.

    The Croatian website you linked was basically about CWM and I didn't find much (if anything) other than a .zip containing batch files related to CWM.

    Unless I'm missing something, anyway. As per bricking-advice, I'm staying away from all things CWM for now.
  22. micallan_17

    micallan_17 Well-Known Member Contributor

    This Thread over at XDA says it has work with many Qualcomm based devices, the Avail 2 runs on a Qualcomm processor so this might be worth a try. but please to read everything on the original post before trying anything, hope it works :)

    http://forum.xda-developers.com/showthread.php?p=40747604
  23. misternad

    misternad Active Member

    Read and attempted but I get a "Bus Error" while it's trying to root the device.

    [HIGH][*] Waiting for device...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    [*] Device found.
    [*] Pushing exploit...
    4056 KB/s (1283460 bytes in 0.309s)
    [*] Pushing root tools...
    3812 KB/s (366952 bytes in 0.094s)
    4736 KB/s (1867568 bytes in 0.385s)
    4143 KB/s (1578585 bytes in 0.372s)
    pkg: /data/local/tmp/Superuser.apk
    Success
    [*] Rooting phone...
    [+] This may take a few minutes.
    Bus error
    [*] Cleaning up...
    [*] Exploit complete. Press enter to reboot and exit.
    Press any key to continue . . .[/HIGH]

    EDIT:
    I've now tried with 5 or 6 different versions of ADB that I have floating around, one of which comes with the adt-bundle. (Presumed to be the latest version)
  24. out of ideas

    out of ideas Well-Known Member

    does superuser or the binary install on your phone?
  25. misternad

    misternad Active Member

    Superuser was already installed (removed and tried fresh, successfully installs), but as far as I can tell it seems everything's pushing over properly. I'll run the appropriate batched-commands manually to see if it takes that way and find out exactly where the bus error is occurring.

    Edit:
    Yes, everything's moving over correctly, where it's dying, specifically, is when running /data/local/tmp/pwn.

    I've googled about a bit but haven't found anything specific as to why I'm getting a Bus Error.

    [HIGH]shell@android:/ $ /data/local/tmp/pwn
    /data/local/tmp/pwn
    [+] This may take a few minutes.
    [1] + Stopped (signal) /data/local/tmp/pwn
    [2] - Bus error /data/local/tmp/pwn
    shell@android:/ $[/HIGH]

Share This Page