1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[Avail] How To Root/UnRoot (Full Guide) (Update 3/5)

Last Updated:

  1. anthony062991

    anthony062991 Well-Known Member

    I am not resposible if anything happens to your phone!
    Do at your own risk!

    Things you need:

    Make sure USB Debugging and Unknown Sources is Checked!!

    adb basic files from here:
    adb.zip - 4shared.com - online file sharing and storage - download
    unzip files to
    (Administrator will be whatever your computers name is)
    (this is for windows 7 only)

    Now on the computer:
    Go to START
    in the search area and type cmd.exe and click it
    type in adb devices and you should see:

    Then continue on to the rest..

    http://download.cunninglogic.com/su (right click save file as) su.txt file and save to your adb directory

    Make sure USB Debugging and Unknown Sources is Checked!!

    Follow these steps exactly! Re-read if needed!

    adb shell rm -r /data/local/logs (if this command gives you an error, do not worry, it is precautionary. Go to next step)

    adb shell mkdir /data/local/logs

    adb shell ln -s /data/local.prop /data/local/logs/loglast1.tar.gz

    Dial *983*7668# on your phone. This does a few things, it mounts /system as writable on boot, and creates the loglast1.tar.gz.
    Wait about 10 seconds, then continue.

    I guess some people are running into an issue when tryping in the code:
    Originally Posted by rockyj [​IMG]
    Hello when i enter the number *983*7668# into my phone I get the message "Connection problem or invalid MMI code." This is after the initial messages... Is this a problem or is this known to happen? Help would be GREATLY appreciated! Thanks!

    type it in and if you get that error msg then ignore it and move onto the next step anyways!

    adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop"

    adb reboot

    Once the phone reboots, continue:

    Some people are having issues wit getting su into system/xbin
    Here is a couple of ways to get it working:

    Download SU and put it to your adb directory:
    su - 4shared.com - online file sharing and storage - download

    adb push su /system/xbin/


    you can manually put the su file into /system/xbin/ with Es File Explorer from the market.

    adb shell chown 0.0 /system/xbin/su

    adb shell chmod 06755 /system/xbin/su

    adb shell rm -r /data/local/logs

    adb shell rm /data/local.prop

    adb shell rm /data/property/persist.sys.ztelog.enable

    adb shell rm -r /data/local/rwsystag

    Head into the Market and grab the superuser app!



    This is what your adb commands look like:

    If you get something else in your adb commands just keep trying until the command goes through!

    I can say I have tried and tested and it took a few times to get everything working properly , but it does work!
    Here is a screen shot of my phone:

    I take no credit for any of this!
    Thanks to this reference guide:
    [Exclusive] Developer Codes Left In Retail ZTE Avail (AT&T) Offer Quick And Easy Root Access

    How To UnRoot

    Please use T card upgrading tool to unroot!
    This will give you complete stock!
    It is really easy:

    If you decide you want to Re-Root again please head back to the top of this post!

    NeoDraven likes this.
  2. Bownz

    Bownz Member

    Thank you! I shall try this ASAp.
  3. Bownz

    Bownz Member

    WORKED! Thank you :) This should be added to the all things root :)
  4. anthony062991

    anthony062991 Well-Known Member

    Thanks for reporting back. I would have posted this in the root section but im so new to this forum I cant do it yet!
  5. Bownz

    Bownz Member

    Heads up at the end, When Unrooting, Dont drag the whole stockapps folder in and click replace. It will delete something important momentarily, and make the phone unusable. GREAT.
  6. anthony062991

    anthony062991 Well-Known Member

    Sorry, its for people who forgot to back up one and or several of there apps. i just put the whole system/app folder there. Maybe I will update all att apps. one at a time so people dont get confused with the whole folder.
  7. Bownz

    Bownz Member

    Yeahp -.- Kinda have a bricked phone now...Unfortunately it wasnt in debugging mode, so i can't fix it now.
  8. anthony062991

    anthony062991 Well-Known Member

    Sorry, it is vary important that USB Debugging and unknown sources are always on while rooted.
  9. mrodgers

    mrodgers Active Member

    I'm new to Android (and smartphones) and have some questions with rooting...

    First off, with your statement here, do you mean USB Debugging... must be turned on at all times after you root or just when you root? I just want to be clear on that. If the former, what happens if you should accidentally turn USB Debugging... off?

    You posted the other thread on apps that can safely be removed. The biggest downfall to my phone is currently Facebook, Twitter, and a few other large stock apps that I will never use and are hogging up space. Do you actually delete the files or will it give you an option to uninstall the apps after root?

    There are a few stock apps that I do want to keep, but they are taking up space on the internal memory. Along with that, it seems that my most used of my downloaded apps (Winamp, iHeart Radio, a MS Office app, and other large apps) installed on the internal memory and I can not move them to the SD card. Will I be able to move the stock apps that I want to keep to SD and will I be able to move some of the downloaded apps I mentioned to the SD and still have functionality with them and the phone? I don't have the understanding on why many of the apps install to the internal memory and can't be moved with the phone in stock form.

    I am now stuck at about 5mb available on the internal memory, but I really want to keep all the apps I've downloaded and can't move to the SD card because I will use them every day (just installed the Office app for viewing and editing Excel files today hoping it would allow to move to SD and the 15mb it is took up all the rest of my free space on internal memory.) I'm scared about the rooting thing, but desperately need the space on the internal memory back as there are yet more apps that I really want but can't get because of lack of space.

    I know absolutely nothing about the custom ROMs I keep seeing info about and don't want to do anything like that right now, but I really just want to be able to get stuff off the internal memory and stored onto the SD card.
  10. anthony062991

    anthony062991 Well-Known Member

    USB Debugging is intended for development purposes only. It pulls data between your pc and phone and phone to pc. Some rooted apps are required for you to enable usb debugging like gingerbreak for example. You need to enable this for the app to run commands to the phone to unroot the device. It is fine if usb debugging is turned off, but some rooted apps may not work properly and or can cause your phone to be bricked. Here is how to enable it: Press HOME > MENU, and then tap Settings > Applications > Development and make sure there is a check.

    You will have to manually delete the apps one by one once rooted.

    The stock apps that come with the phone can not be moved to the SD card at all. EDIT: You can delete maps, gmail, and youtube. Reinstall from the market. Then you can download an app called Titanium Backup . This will allow any apps you downloaded to force them to install to the SDcard once your phone is rooted. At this moment I have 89.39MB freed up in the internal storage.

    There is no custom ROMs out for this device at the moment. If you want to move apps to your SDcard. My advice for you is to just root your phone. Just folow the steps above and you should be fine.
  11. mrodgers

    mrodgers Active Member

    I dial the number, next step, then reboot the phone. At this step...

    adb push su /system/xbin/su

    I get an error saying, cannot stat 'su': No such file or directory

    I downloaded the su file and put it in the adb folder. Any reason why? Can I start over?

    According to the app "Root Access Basic", I have root access. What does the "SU" file do as I couldn't go on from that point above?
  12. anthony062991

    anthony062991 Well-Known Member

    1a. You need the su file for superuser app in the market. Superusers is an app required for root users to manage system and rooted apps to work properly. You can Start from the top and redo the commands until everything works. It gave me errors my first few times. I kept retrying and it finally went through.

    1b. adb push su /system/xbin/
    try going to the next step if it goes through.

    1c. you can manually put the su file into /system/xbin/ with Es File Explorer if it lets you and just try moving on to the next step.

    If 1a doesn't work you can try 1b. If that does't work try 1c. One of these steps should get you in the right direction.
  13. mannyr7

    mannyr7 New Member

    SUCCESS!!! I had a lot of difficulty with this also. Here was my workaround:

    1. Download Explorer v1.0 from Speed Software (this allows you to view and edit the root file system, including hidden files, which the default and many 3rd party file managers refused to show)

    2. Move the the su file previously downloaded to your PC, to your phone's external micro SD card via SD adapter inserted into your PC.

    3. Pull the micro SD out of your PC and put back into your phone.

    4. Open Explorer app. If necessary, create directory /system/xbin/
    Then, copy and paste the su file to that directory.
  14. anthony062991

    anthony062991 Well-Known Member

    Sorry for the problem guys. I just updated in the op with a download link and a little better instructions for that su file.
  15. westcottcody

    westcottcody New Member

    Ok so I downloaded adp, but I have no idea how to use it. How do input commands? How do I even bring up the command prompts? Help would be greatly appreciated...
  16. anthony062991

    anthony062991 Well-Known Member

    I updated the op with basic adb files and how to use it with windows 7
  17. Wuverul

    Wuverul Member

    When I try using "adb push" it says SU doesn't exist. ES file manager wont let me put it in, nor will Explorer by Speed Software. Says that it can't send it to a read only directory. What am I doing wrong? This is my first time rooting a device, first android phone (had it for a few months).

    EDIT: Nevermind, got it figured out. Forgot to reboot after entering the number.
  18. Thrive

    Thrive Member

    Hi! First post.

    I was wondering if you may have a guide to doing this on Linux? I'm running OpenSUSE. Thanks in advance for the reply!
  19. wps2650

    wps2650 Member

    Is it unlock or not?
  20. Thrive

    Thrive Member

    Probably not. This is my first smartphone, and I haven't done anything but play with the apps in the market so far.
  21. anthony062991

    anthony062991 Well-Known Member

    It should be similar to what I have. I have windows 7 and ubuntu installed on two different laptops. You need to have android sdk installed in your pc. Download all the files from here and put it into your tools folder from the sdk. Then cd ./path/to/adnroid/sdk/tools/ mine looks like this: cd ~/android-sdk-linux_x86/platform-tools . Then try to type ./adb devies and you should see your device listed. You should be able to run the commands to root from there. I hope this helps.
  22. anthony062991

    anthony062991 Well-Known Member

    Sorry, but rooting does not unlock the device.
  23. rockyj

    rockyj New Member

    Hello when i enter the number *983*7668# into my phone I get the message "Connection problem or invalid MMI code." This is after the initial messages... Is this a problem or is this known to happen? Help would be GREATLY appreciated! Thanks!
  24. anthony062991

    anthony062991 Well-Known Member

    I am not sure about this problem. Maybe try taking out your battery and put it back in. Then start from the top again.

    If that does not work then try a master reset from the settings. This will delete everything and your phone will come back on like it is brand new. Then try from the top. Other wise I have no idea? I hope this helps.
  25. LuckyHermit

    LuckyHermit New Member

    I have the same exact problem. "Connection problem or invalid MMI code." I have reset my phone to factory condition twice, and I still get this error. I really really want to root this phone to get the crapware off and free up some space. I really hope somebody knows how to get around this error code.

    If anybody having this issue figures it out please post on here.

Share This Page