[Avail] How To Root/UnRoot (Full Guide) (Update 3/5)

Last Updated:

  1. anthony062991

    anthony062991 Well-Known Member

    What happens when you move on from there? Do you get any other errors? Try dong the rest of the steps and see if root works?

  2. LuckyHermit

    LuckyHermit New Member

    Ha! Smart man! I kept getting the error message and just assumed it was failing. I checked to see if it is rooted and it is! I'm happy now. Thanks for the help!
  3. chrismbrunner

    chrismbrunner Well-Known Member

    Don't hit send. It should work fine entering just the code. And it doesn't seem to be a permanent root. If you wipe data, you have to do it again.
  4. crshocks

    crshocks Active Member

    this is so sad but i don't see my device listed when i first getting into CMD. what am i doing wrong?
  5. crshocks

    crshocks Active Member

    I got it! thanks so much for the guide!
  6. fluid

    fluid Member

    Okay, I am not sure what the deal is here, but I have tried several things before I finally resorted to posting here.

    I got this phone yesterday, I would like to root it for the purpose of getting Avast! Antitheft (and several other things I would like to run at boot without being able to be cancelled or skipped).

    Anyway, I followed the directions in this thread to a tee.

    When I try and use ADB to list devices, I get the following results:

    I have tried both your ADB.zip file, and downloading the actual android platform sdk (which is what I used in the quoted text above). Both versions of ADB to not see a phone attached to the machine. I cannot seem to get the platform sdk USB drivers to install as the phone is not listed in the computers device manager.

    What am I missing here? Thanks much!
  7. fluid

    fluid Member

    Solved my problem by forcing reinstall of the drivers from the device. Thanks anyway though! Looking forward to getting this done. :)
  8. Kma4444

    Kma4444 Member

    Hey Fluid, how did you reinstall the drivers? I am a newb to this and go to the point where I was going to push the SU to the phone and didn't have the SU in the right place on my computer. I then had to go and move the SU and when I tried to do that step I got an error code. I then tried to start over and now ADB shows no devices, so obviously I lost something that it needs to see the phone.

    Any guidance would be appreciated.
  9. Kma4444

    Kma4444 Member

    And also in doing what I have done so far, I have rendered the phone mute. Not a sound will it make so I killed a driver of some kind I suppose.
  10. fluid

    fluid Member

    Well, when I say I forced the drivers to reinstall that may not have been the correct wording. I uninstalled the drivers from my machine in Add/Remove Programs (Programs and Features in Windows 7). They are listed as ZTE Handset USB Driver.

    After that reconnect the phone and it should work fine. I also had to install the Android SDK instead of using the ADB.zip file above. Even still, the ADB.zip version does not see my phone, but the Google Android SDK version does.

    Here is output from both:

    I just posted that to prove that it doesn't work quite right with my phone/computer for whatever reason. I don't really care to be honest, I just think its odd. Maybe Anthony can fill us in on that. Wow that is weird, my name is Anthony too. I feel like I am talking to myself. lol.

    I have run into this before with my phone, and read a lot of posts from people elsewhere saying the same thing (on rooted and non-rooted phones of different makes). I have even seen issues like this arise on non-android phones believe it or not. Best solution I have ever found for this is to just remove the battery, wait a minute, and pop it back in and reboot.

    When I rooted this ZTE handset, it also went mute (including telephone calls which sucked the first time I got one).

    Also ensure that the phone is not in "silent mode" (it probably is not, but check anyway).

    When you do get to a point that you are going to try again, FOLLOW THE INSTRUCTIONS IN THIS THREAD AND ANY OTHER THREAD LIKE IT TO A TEE. Doing this stuff voids your phones warranty FLAT-OUT, and you definitely don't want to monkey around with a new phone that has no warranty.

    Needless to say, I am rooted, and running Anthony's one.one. I like the Go Launcher, but I am not sure I like it more than adw.launcher...guess I am a minimalist. Gonna give it some time, maybe purchase the Go Launcher EX and see if that helps me get into it more.

    FREAKING THANK YOU ANTHONY. You have made this phone a LOT better, not that it was bad to begin with... it just got a lot better because of your work. I cannot wait for one.two :)
  11. Kma4444

    Kma4444 Member

    Thanks Fluid, I did manage to get it all working again, though I'm sure my method was a tad, well, barbaric. I did a T card reboot and just returned the phone to factory defaults. Not a big deal other than losing a few apps and such. I've only had the thing a couple weeks so it wasn't a huge deal. At least now I have an SD card setup that I can drop in and reset it if I screw up again.

    I'm sure most of my problems are because I am completely new to doing this. Some of the minutia that is completely obvious to folks who have done these before are lost on me. Just want to get it all figured out and working without making the phone rubbish.

    I like the challenge just wish some of it was more clear to me. I'll get there.

    Thanks again
  12. Kma4444

    Kma4444 Member

    Well, I got it rooted, not too much trouble. Funny thing, when I got to the reboot step, when it turned back on it was again mute. Like you said yours was, no speaker, no sounds at all. Root check says I'm rooted but sound is gone. I tried leaving the battery out for a while and maybe I will try that some more.

    I'd hate to have to unroot it again since it seems to be alright other than being useless as a phone. Pretty funny really.

    Thanks again
  13. Kma4444

    Kma4444 Member

    OK, so happy to say, it now speaks again. Here's a confession from a rookie, noob, new B!!! I stopped after I pushed the su command. I thought the rest of the directions were in case the push command didn't work. After I looked at it a few times and looked at how the command list should look, it was obvious. So any other beginners out there, the command list continues after the push line. Not very bright on my part to be honest. The sound came back on reboot after doing the rest of the root sequence.

    Now to figure out how to get rid of the AT&T stuff I don't want.

    Thanks for your patience in watching me fumble around. Told you I'd get it, now I'm like graduated from 1st grade, I'm educated!!!!
  14. fluid

    fluid Member

    if you can afford to replace the phone if you manage to murder it then i would push for the next step. it isn't hard, but just like everyone else suggesting you modify something, i am not responsible if it bricks your phone, or kills your pets.

    the thread that i have found in this forum that lists everything that is "safe" to remove is here:


    i personally suggest changing the recovery rom with clockwork mod, and that thread can be found here:


    stick the clockwork mod zip, and the stock recovery zip on the root of the sdcard for convenience of having both, but i dont ever see myself leaving clockwork mod now that it is installed and working :D

    there is 1 custom mod out for this phone once you get it rooted, and honestly from what i can tell MOST of the things I am mentioning (if not all of them) were done by the same person. this mod overclocks the phone a bit as needed to make things a bit more responsive, and removes all of the "bloat" that comes on these phones. it changes the stock launcher out for GO Launcher EX, and gets rid of a lot of stock functionality (that is all replaced by the apps mentioned in the thread, just get them when you get the install done)

    the only thing im missing out of it is the calendar, but i will buy the one mentioned in the thread, its under $3, and looks freaking amazing :D


    currently the only download for that mod i could find is one.one, even though the thread says it is one.two. i believe that one.two will come soon (i hope) :)

    again, these phones are really inexpensive, and pretty good to learn the ins-and-outs of droids (and linux for that matter if you get into terminal use at all), so if you can afford to replace the phone, do not be afraid to try things. :D
    Kma4444 likes this.
  15. Kma4444

    Kma4444 Member

    I really appreciate the help and suggestions. I already did the clockwork recovery, that went fine and using Titanium Backup I have been able to remove a lot of the useless AT&T stuff. I got this phone to use with Straight Talk and picked it because it was cheap enough that if it didn't work out or I rendered it useless, I could give it the old float check and if it sank, I was alright with that.

    I will look into the mod and give it a try, sounds like the goods!

    Thanks again and hopefully I at least gave you guys a little something to laugh about.
  16. Motorhead1991

    Motorhead1991 Well-Known Member

    I was able to root my avail by just dialing thr write mount dev code then updating the binary on superuser. It worked for some reason...
  17. Karroon

    Karroon New Member

    Got it to work, had to get cmd to run as administrator, and Win 7 likes to hide it
  18. Natetd26

    Natetd26 New Member

    When I get to this part:

    adb shell "echo \"ro.kernel.qemu=1\" > /data/local.prop"

    it says permission denied!! Any help I would be very greatful!!
  19. Thrive

    Thrive Member

    So, I got Android SDK installed, with Eclipse and such. Got adb running. I didn't see the Avail SDK package, so I just downloaded everything they had. Went to search for my phone and got:

    Code (Text):
    1. ~/SDK/android-sdk-linux/platform-tools$ ./adb devices
    2. List of devices attached
    3. ????????????    no permissions
    No idea where to go from here. Working on Ubuntu 11.10 now, BTW. Decided I needed a dual-boot.
  20. anthony062991

    anthony062991 Well-Known Member

    Look at this guide. It will tell you how to fix that issue. It is really easy. I tried with both ubuntu and mint and both works great.
    [GUIDE] Lazyman's installation guide to ADB on Ubuntu 10.10 - Now with Ubuntu 11.10 ! - xda-developers

    You do not need Linux in order to use these commands. You can use windows and it will work just fine.
    Thrive likes this.
  21. rkalajian

    rkalajian New Member

    I'm having an issue trying to root this damn phone, and was wondering if anyone knew the solution. When I dial *983*7668# and wait, nothing happens. If I click the send button I then get the "Connection problem or invalid MMI code" message. Either way, I can't continue on with the process. I get "cannot create /data/local.prop: permission denied"
  22. anthony062991

    anthony062991 Well-Known Member

    Have you tried to reboot or just pull out the battery and start from the top again? If that doesn't work try using the T-Card Upgrading tool I posted in the other thread. Update the device and then try rooting again.
  23. rkalajian

    rkalajian New Member

    Damn. The T-Card upgrade did the trick. I was able to start the process over again, and am rooted!
  24. Thrive

    Thrive Member

    So, I don't think my phone's showing up properly. lsusb gives me:

    Code (Text):
    1. # lsusb
    2. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    3. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    4. Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    5. Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    6. Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    7. Bus 002 Device 002: ID 0461:4de7 Primax Electronics, Ltd
    8. Bus 001 Device 015: ID 19d2:1354 ONDA Communication S.p.A.
    I imagine that the one at the bottom is the phone, because it's the only one that goes away when I unplug the phone from the USB port. So I wrote my 99-android.rules as such:

    Code (Text):
    1. SUBSYSTEM=="usb", ATTRS{idVendor}==19d2:1354, SYMLINK+="android_adb", MODE="0666" GROUP="plugdev"
    2. TEST=="/var/run/ConsoleKit/database", \
    3. RUN+="udev-acl --action=$env{action} --device=$env{DEVNAME}"
    Restarted udev as per the instructions, and my output for ./adb devices is still:

    Code (Text):
    1. # ./adb devices
    2. List of devices attached
    3. ????????????    no permissions
    Wat do? I'm about to smash this goddamn thing against a wall.
  25. anthony062991

    anthony062991 Well-Known Member

    Yes it is the last one there.
    Try this:
    ./adb kill-server
    sudo ./adb start-server
    ./adb devices

Share This Page