[Avail] How to unlock your AT&T Avail to any mobile carrier


  1. NeoDraven

    NeoDraven Well-Known Member

    ZTE-Z990 Avail HowTo's - ZTE Blade / Libra - Blade.MoDaCo.com - MoDaCo

    I found and followed this guide to unlock my Avail. It worked; I tested it with a T-Mobile SIM Card, and successfully placed a call.

    I then set up my phone with a new T-Mobile SIM card that I purchased, called T-Mobile to get the data settings, and now everything works perfectly.

    No more AT&T. Happy, happy day!

    As a heads-up, this process will essentially put you back at a stock ROM. No Kernel1.0, no Clockwork Mod Recovery, and you will need to reroot the phone.

    Take your time after entering the *983*7668# dev code for the temporary root unlock. I kept getting an error message when I tried that step, because I was going too fast. Make sure to wait at least 10 seconds before trying to do the create /data/local.prop step of anthony's rooting method.



    Advertisement
    availabuser likes this.
  2. waltinhb5

    waltinhb5 New Member

    First post but no computer/cell newbie. Can't get the above method to work. Does anyone know where you can get the 16 digit unlock code for this phone? I have looked all over the internet and can't find it. I have emailed ZTE and am awaiting their response. Thanks.
  3. availabuser

    availabuser New Member

    Thanks for this post, NeoDraven.

    I talked to AT&T a couple of months ago and they told me I needed to own the Avail for 6 months before giving out the SIM Network Unlock Pin. I called back a few days ago since it was almost exactly 6 months and this time they told me that AT&T and the manufacturer have an exclusive agreement and the Avail can only be used on the AT&T network.

    So instead of arguing with the help desk flunkie I dove into the link you provided and with a little alteration I was able to get my Avail unlocked and working on another carrier. I'm tempted to call AT&T back to get another agent to see if I could actually get the SIM Network Unlock Pin but what a bunch of garbage to potentially not give out the code to the owner who is free and clear of obligation to them.
  4. Russ71

    Russ71 Well-Known Member

    The carriers are control freaks. Tell them all their bloat ware is gone. That always grinds their gears.
  5. kingmt

    kingmt Well-Known Member

    Once you root all you have to do is change the APN.
  6. cwwilson721

    cwwilson721 Well-Known Member

    Actually, "rooting" only gives you access to "protected" files and folders in the phone. Think of it as access to your cars motor. You can swap out any parts you want (within reason), like putting a Chevy 350 in your Ford Focus. It's still a Ford (that will probably flip over the first time you hit the gas).

    "Unlocking" gives you the choice to use a different carriers SIM card in your phone. Think of this as changing from a Ford to a Chevy. But you still have the manufacturer's engine in there that it came with (Ford motor in the Ford, Chevy in the Chevy)

    You can unlock without rooting, and you can root without unlocking.

    Rooting alone won't let you use the T-Mobile sim in the phone. It won't connect to T-Mobile's network. Changing APN's will do nothing with just root. But you can change ROMs and edit system files/etc

    If unlocked, the T-Mobile sim will work. But you can't change ROMs or change system files with just unlocking.

    Did what I say make sense?
  7. kingmt

    kingmt Well-Known Member

    Not really. My phone isn't locked to a carrier. I just assume to you need root to get past it. I know you need the correct APN for the SIM & network you want to use. My phones these can be changed without root.
  8. Chadtheguru

    Chadtheguru Member

    What happens if I don't back up my NVram first?
  9. Chadtheguru

    Chadtheguru Member

    I think I'm okay. I had a good CWM6 backup. I just restored it and everything seems to work correctly.
  10. micallan_17

    micallan_17 Well-Known Member Contributor

    This actually works for the Tracfone ZTE Merit and it was hard to do but it is possible, in the end you get to unlock the merit and convert the it to an Avail from the firmware up. you get FTM mode also by just holding the -volume and power key at book [​IMG]

    [​IMG]
  11. ctx1001

    ctx1001 New Member

    Hey micallan_17, I have followed your other threads about the ZTE Merit touchscreen issue. So I have read about your Z990g efforts. I am trying to duplicate your success of converting a merit to and avail. I think I have been able to get the merit into DFU mode here is a pic of my device manager:

    anonfiles,com /file /0721febf59762769cbc01c18dfce3889
    (change the , to . and remove the spaces from the above)

    I have also changed my rom to the stock avail, so android 2.3.4 with att splash screen. This didn't get me FTM access using Vol Down + Power. I dont think I changed the firmware. How/where did you get the necessary ZTE avail files to flash? Also how did you get flash program to say you are in download mode? When I do it says: P736T_TFV1.0.0B08 on COM20

    anonfiles,com /file /1a7beeed1727d0e65fa87741aed5448e
    (change the , to . and remove the spaces from the above)
    (needed to do this to get around the limit, lol)

    I'll also PM you incase there is something you can share with me.

    Attached Files:

  12. micallan_17

    micallan_17 Well-Known Member Contributor

    hey ii will try to get the files and provide you with the links to the files k, just give a day or too
    ctx1001 likes this.
  13. ctx1001

    ctx1001 New Member

    Hey micallan_17 if you are looking for a place to drop files you can use anonfiles.com they offer anonymous upload and download with unlimited bandwidth. Thats where I drop files that are under 500mb.

    Thanks for all info and help!! :)
  14. micallan_17

    micallan_17 Well-Known Member Contributor

    The problems isn't where to upload the files as they are already online, the issue is getting you the right links to the files, it's been a while since we did this, i am currently not at home until this coming Sunday. i will try to find the links for you :)

    Cheers
  15. ctx1001

    ctx1001 New Member

    Thats fine, no rush whenever you have some time. This is just a experiment for me and I understand it been a couple month since you cracked this nut.
  16. micallan_17

    micallan_17 Well-Known Member Contributor

    ok the flasher files and image extractor i used are located here(thanks to MoDaCo developer Enthusiast for the flasher tool) (as for the image extractor i have no idea who to give credits to but thanks to who ever did it) you will need to do download the files from this page (thanks to Android Area 51 Developer Phydeux for the files)

    Unzip this file (Avail_T-card.zip).

    Inside the 'Avail_T-card.zip" folder is ANOTHER folder called "image" (make a copy of the image.bin file to somewhere else in your PC, you will need it later on)

    Copy the "image" folder to your sdcard (NOT inside any other folder!)
    take out the battery of your merit and and put it back in, now here is the hard part (getting the phone in DFU Mode (not the one that shows P736T_TFV1.0.0B08 on COM20 but the one that shows "Phone is in Download Mode"). This is how i got mine to the DFU mode:
    "turn off the phone off and I start by pressing and holding the Home, Volume + and Power Key, that will bring me to the Update from T-flash card SCREEN, after reaching verifying 100% it says "verify fail reboot" the screen goes black instead of rebooting. it was at this point when out of curiosity I connected the phone to the pc and it installed some drivers and I checked device manager and there it was, "ZTE Handset Diagnostic Interface (DFU) (COM36)""

    if that happens to yours you are on the clear now the flashing part is the other hard part, remember i asked you to make a copy of the image.bin file that is in the image folder? well now it's when you will need it, use the "image extractor" (straight forward GUI) to extract the image.bin file to the folder "files" within the flasher folder (v880_conversion_recovery). now fire up the flasher program and follow this guide here but don't use any of the files on that link use the files you extracted from the image.bin as the files on that guide are for the ZTE Blade V880. if all goes well and the phone flashes you got yourself a ZTE Z990 from the base firmware not just the stock android rom. usually after flashing it gets stuck on FTM mode to get it to boot, remove battery, put it back in connect usb cable or charger wait for the charging green battery to appear, now press power it should boot now. as always follow at your own risk and please do report back if anything or questions. happy flashing.

    more info(with images can be found here)
  17. Shuudoushi

    Shuudoushi New Member

    I'm having issues getting the phone into DFU mode... I get the black screen and everything, but when I plug the phone into my computer, it just finishes rebooting. I can get this http://puu.sh/5HtEC.png by opening the "USB switch test" menu (*983*87274#), but that's it... (btw, that gives me P736T_TFV1.0.0B08)

Share This Page