[Avail] [OBSOLETE] ClockWorkMod Recovery for Non-Rooted Phones [temporary]

Last Updated:

  1. stayboogy

    stayboogy Well-Known Member

    algree and cell2011 like this.
  2. cell2011

    cell2011 Well-Known Member

    This is great for people that dont like adb commands to get rooted. I did this and backup and restore and then flash the real stock rom and now rooted on one two three. Couldnt be easier. Took less than 5 mins
  3. valueforvalue

    valueforvalue Well-Known Member

    Very nice stayboogy glad to see you are making good progress.
    stayboogy likes this.
  4. stayboogy

    stayboogy Well-Known Member

    i wish i had figured this out before i rooted actually. it would have been nice to have a full stock nandroid of the merit without root.

    and no one seems to be using this and posting their non-root nandroid like i have asked...

    i may have to try to unroot my extra one and do this. idk if that will work or not though
  5. valueforvalue

    valueforvalue Well-Known Member

    Un rooting might be a bit risky... I'm not sure or at best difficult. When I buy my backup merit I will be sure to use this method!
    stayboogy likes this.
  6. algree

    algree Member

    Thanks a Million. I unbox'd a new merit ST. bootup while pluged into pc put your zip on root of sd card and then follow'd your instructions and made A CWM backup I'm uploading it to my GDrive and I will post a link when Its done.

    PS: I used 7z to compress it 50%

    and again THANKS I also downloaded your stock but rooted CWM rom I have'nt Tried to load it yet I'll let you Know how I made out

    Here is a link to GDrive (Stock ZTE Merit_clockworkmod.7z)
    stayboogy likes this.
  7. stayboogy

    stayboogy Well-Known Member

    great!!! if you have trouble with the stock rooted backup let me know. i'm in the process of uploading the same thing just made with the most recent M 1.03 recovery.img.

    i anxiously await your upload--thank you so much for this :D
  8. gr1mlock

    gr1mlock Member

    I rooted my avail in june with the tcard downgrade and the dialer codes so when my wife wanted a smartphone I talked her into the Avail as well (thinking the root would be cake). After 10+ failed tcard flashes, I even tried to manually root her Avail but I couldn't get it to keep root after a reboot. I gave up and told her I couldn't root it but she wasn't mad...

    Forward to this week and I see this thread pop up and immediately this popped into my head:

    can I flash this CWM to her non rooted phone and then use CWM to restore one of my nandroid backups? AND, would that then transfer the root to her phone as well? (without losing it during reboots)?

    The main reason I even want to spend any more time on her phone is that the limited app space has already come up a few times.

  9. stayboogy

    stayboogy Well-Known Member

    yes, you can use this to put cwm recovery on your wife's phone and then restore a nandroid from your phone that is rooted onto her's and then she will be rooted too. easy as pie

    *backup her contacts and anything else she wants to keep first though as they will be erased*

    in order to install cwm on an un-rooted device it first factory resets the device and then immediately installs the update.zip--blame zte for this because there is no way around it using this method; and this is the only way to get cwm on an un-rooted phone

    and root won't disappear after reboot (not with this--as long as your device is fully rooted). it totally replaces the whole filesystem on the phone--it's not a temporary thing...

    just use the update.zip for your phone [A 1.00]
  10. gr1mlock

    gr1mlock Member

    Nice! Thanks for the quick reply stayboogy :)

    Now to see if I can pry it out of her hands for a bit!
  11. stayboogy

    stayboogy Well-Known Member

    no prob. let me know how it goes.

    the avail stock recovery may actually have an option that says "install update.zip" in the menu, which would not do a factory reset by default like it has to be done on the merit. i've never flashed the stock avail to my merit to see it's menu actually.

    but, it's always good to backup contacts before doing something like this anyway, cause when you restore you're going to lose everything that's on there now
  12. gr1mlock

    gr1mlock Member

    I installed the upright CWM on my phone. I still had the upside down CWM version and it kinda bugged me too.

    Next was her phone but she had gone to bed with an alarm set so I snuck in and grabbed it all ninja like :D

    The stock recovery does have the option to install update.zip from the sd card so I ran it on her's and up popped CWM! :)

    I immediately made a nandroid backup in CWM (stock/unrooted) and then backed up her entire sd card to my computer. I put my 2nd nandroid backup on her sd card (I tweaked in stages and created nandroids along the way).

    Here's where it gets weird: I turn the phone off and boot into recovery (menu and vol+) to wipe the phone/data/cache/etc and what pop's back up? The stock android recovery menu. After testing it a few times the CWM recovery says it installs and runs normally, but upon reboot the stock recovery is back :confused:

    I ran the update.zip file again from the sd card and up popped CWM again. I then used it to restore my nandroid backup from the card and then wiped everything to be sure. After a lengthy boot I could tell the restore worked because the bootanimation and sound were gone.

    After it settled down for a few mins I set up her google account. Root checker stated that root access was not available. I'm curious as to why the root didn't make it over?

    Anywho, I looked around and noticed that my build number had dropped from b19 to b14 so I tried the dial codes. I was able to get root and disable QID :)

    Everything is fine on the root end so far, su rights are getting granted and root checker says yes. I was able to remove bloat and speed it up so she's happy!

    If there's anything I should check or verify please list it because I will definitely be hearing about any problems with it. When I handed it back to her all I told her was "I rooted it, cleared up a ton of app space and sped up sd card reads/writes by almost 20 times". She asked what that would help and I had her open the gallery app and she about flipped :D

    Thanks again
  13. stayboogy

    stayboogy Well-Known Member

    i'm not quite sure how that can happen...

    but, even when you have cwm recovery on the phone, it will backup the stock recovery every time. don't ask me how that happens, but it does. all my nandroids have a recovery.img in them that is 6144KB which is the size of the stock recovery.img--and they are made using cwm recovery and even after restore cwm is still on the phone which is only 4654KB.

    it could be that cwm runs from the cache when you use the update.zip method on an unrooted phone, and since you are in recovery already it can't flash it right away and instead does it upon next boot--and since you wiped the cache and everything that is why stock recovery come back up. of course this is a stretch and is just my attempt at trying to reason how that is possible in the first place.

    either way, i'm glad you got it rooted.

    as far as not having root after restoring a nandroid of your rooted phone--that doesn't make any sense. people have used my stock rooted nandroid to root their phones that were unrooted and it stuck on their's...

    unless att did something to the phone to prevent rooting in B19, which i'm not sure what they could've done, it should have been just fine.

    weird is definitely what this all is. but again, either way you got it done and now it's rooted so, glad for you and glad there's testimony my update.zip works :p
  14. valueforvalue

    valueforvalue Well-Known Member

    I am pretty sure the reason for the odd behavior being seen here is explained here.

    " There is also another important file you
    should know about. In /system/
    recovery.img there is a full copy of
    everything that is loaded on mtd1. This
    file is automatically flashed onto mtd1
    every time you shut down. That means
    two things: 1. Any changes you make
    directly to /dev/mtd/mtd1 get blown
    away on reboot and 2. If you want to
    change /dev/mtd/mtd1 you're probably
    better off just sticking the image in /
    system/recovery.img and rebooting.
    When creating your own custom
    update.zip files (especially when adapting
    the stock images), you can get tripped up
    if you forget to replace /system/
    recovery.img and it ends up overwriting /
    dev/mtd/mtd1 unbeknownst to you.
    Watch out."

    This is an excerpt from an article found here. http://android-dls.com/wiki/index.php?title=HOWTO:_Unpack,_Edit,_and_Re-Pack_Boot_Images

    It's not a big problem, I'm sure with this information stayboogy will be able to fix this in a snap. If he feels it is even necessary.
  15. stayboogy

    stayboogy Well-Known Member

    but that information isn't true (all the time anyway). there is no recovery.img file in that location or any other location on our phones. i've looked up and down and left and right because i've read that same thing in other places...

    and it doesn't get flashed every boot because i've rebooted my phone dozens upon dozens of times since installing cwm and it's still there.

    unless there's a way to make that file invisible to root su access, i don't think that information is correct.

    another reason i don't believe that thread is because the way they have given directions for unpacking and repacking .img files is bunk and doesn't work like it's supposed to. believe me, that tutorial is what got me into actually 'building' cwm for our phone because unpacking and repacking didn't work for the upside down image.

    so i'm not really sure what happened with your phone unless it's what i mentioned above about being in the cache until it was properly flashed at reboot.

    what matters is that it worked in the end LOL
  16. valueforvalue

    valueforvalue Well-Known Member

    I see stayboogy is already on top of it. Hmmm if that is incorrect I am unsure. The method for repack in that thread does work though because I have done it and the images boot perfectly. It's just that the tools for doing so in that thread suck. I was able to find a better set of tools which I thought I posted a link to. And they work flawlessly. But it doesn't matter your method works perfect, and unpacking and repacking from what I have seen serves no purpose unless you want to change the images in the recovery LOL.
  17. stayboogy

    stayboogy Well-Known Member

    yeah, i'm not sure how you got them unpacked and repacked and they still booted. that wasn't happening here lol

    it's for the best though that it didn't work for me; i've gotten more enjoyment out of playing in the sdk:D
  18. valueforvalue

    valueforvalue Well-Known Member

    Did you try the tools in the link I posted?

    Note:after some checking I have found that you are correct there is no recovery.img in system or anywhere that I can find. So I decided to scour the init.rc to see if it flashes any file on start up, didn't find that either. So I guess that simply doesn't apply to our phones. I did find an interesting setting relating to CIQ which after running red pill it said CIQ was not found or disabled on my phone after looking on the init.rc I believe it finally lol.
  19. gr1mlock

    gr1mlock Member

    ok, any idea why the update.zip starts CWM but doesn't overwrite the recovery partition?

    for now I'm leaving the update.zip on the sd card since I won't be flashing her phone much (if at all)

  20. stayboogy

    stayboogy Well-Known Member

    i'm not sure.

    if you want it on there permanently, then you will have to flash it like normal.

    this was built so people without root could make a backup of their phones with cwm recovery. and if they wanted to restore they could be doing the procedure again and then restore

    and, if someone wanted to root their merit, they could just use this to backup their un-rooted system, then immediately restore my rooted system backup.

    to be honest i didn't realize that this wasn't permanent--reason being is that every time i tested it i was actually backing up and restoring various nandroids, some with cwm recovery, some without. so thanks for the info. i'll add it above
  21. stayboogy

    stayboogy Well-Known Member

    unneeded post.

  22. out of ideas

    out of ideas Well-Known Member

    Is this link still working for the stock recovery?
  23. valueforvalue

    valueforvalue Well-Known Member

    Stayboogy have a look at this http://pastebin.com/RbQRMYAh

    It is your update-script from the update.zip after you look through it I bet you will be able to figure out why the recovery flash is not perminant.
  24. stayboogy

    stayboogy Well-Known Member

    but see the thing is i didn't build the updater-script

    cyanogen sdk does this automatically

    but i see your point. it doesn't actually flash recovery.img

    and you know, when it was built i was curious why it had every other file but the actual recovery.img in it.

    maybe i'll see about fixing that, only thing is, i'm not good with building update.zip files.
  25. valueforvalue

    valueforvalue Well-Known Member

    I didn't figure you wrote the script, it would be a very slow process writing that line by line. I've never tried to make an update.zip so I don't know how difficult it is and I don't have a computer to work on it with. I suppose you can edit the script and rezip the update.zip and just resign the zip file with zip signer app?

Share This Page