[Avail] Wi-Fi has stopped working--obtaining ip address loop


  1. stayboogy

    stayboogy Well-Known Member

    i am stuck in a "obtaining IP address" loop

    was working just fine until i did a rom dump earlier (and i did enable and disable the wifi before i did this)

    i have done a battery pull

    disable and enable wifi

    disable 3g and tried again

    forgotten all wifi settings and tried again

    have done a master reset even

    router reset too

    no luck

    anyone got any ideas of how to fix this???

    really pissing me off right now... and straight talk is no help, they have no technical support worth a penny. already been through all their steps which are all the ones above.

    there is no usa number for zte technical support that works

    please help me

    Advertisement
  2. Motorhead1991

    Motorhead1991 Well-Known Member

    Set up a static IP (go into settings>Wireless and network>Wi-Fi settings>hit menu>advanced). It worked with my ZTE after a little trial and error.
  3. stayboogy

    stayboogy Well-Known Member

    the only problem with this is that i'm not always using a connection where i can use a proper static ip...

    what if i want to use an open connection???

    seems like Google needs to fix this issue because it's a standard problem with every android machine...

    and aside from that, there is no reason i should have to use static ip because it was connecting just fine without it just before rooting and right after rooting. up until yesterday after doing a rom dump.

    so ridiculous...
  4. gr1mlock

    gr1mlock Member

    • log into the router handling the DHCP requests
    • change the DHCP client lease time setting to 2880 minutes (2 days - or anything other than the default 1 day lease)
    • save the changes then reboot the router
    • reboot all dhcp clients

    My ZTE Avail went from disconnecting almost every minute to ZERO connection issues with this tweak!

    :smokingsomb:
  5. stayboogy

    stayboogy Well-Known Member

    that doesn't work for me at all. same issue exists regardless of the dhcp setting in the router.

    but that doesn't do me any good for open networks or other people's networks when i'm not at my home location...

    this is a ridiculous android bug!!!!!!!!
  6. Motorhead1991

    Motorhead1991 Well-Known Member

    Oddly enough, I never had a Wi-Fi problem until I got to a restricted network. I used to use the network at a local bookstore without issue, but as soon as I got home, my ZTE wouldn't connect.

Share This Page