Awake time vs. Up time?


Last Updated:

  1. mw383

    mw383 Active Member This Topic's Starter

    Joined:
    Dec 5, 2008
    Messages:
    28
    Likes Received:
    0
    my awake time is usually at 100% right now for example it's at 94:10:14 and counting. my up time is also at the 94 hour mark.

    i read here that awake time should be a fraction of up time and consequently kills the battery. which after all night charging is down a bar (10%) within 10 minutes or so.

    i heard this is related in some way to mms/sms messaging? is this true?

    i installed taskiller and use it frequently, but it doesn't seem to remedy the situation.

    should i wait for a fix/update from htc? try something like chompsms? any other suggestions?

    thanks in advance
     

    Advertisement
  2. jimbobmcginty

    jimbobmcginty Well-Known Member

    Joined:
    Oct 7, 2009
    Messages:
    55
    Likes Received:
    2
    I saw the same >90% awake time as you, also had hot battery constantly. I removed the messaging widget (this displays messages on one of the home screens - not the messages link).

    After removing this widget, and the link, my awake time is now <10% .
    Battery life is remarkably improved ;)

    Replace the Messages link with chompSMS link so you don't accidentally start Messages.
     
  3. Ziani

    Ziani Well-Known Member

    Joined:
    Sep 20, 2009
    Messages:
    836
    Likes Received:
    92
    How do you check awake time?
     
  4. jimbobmcginty

    jimbobmcginty Well-Known Member

    Joined:
    Oct 7, 2009
    Messages:
    55
    Likes Received:
    2
    Home- > [menu] -> Settings ->(scroll to bottom) About Phone -> Status -> (scroll to bottom) Awake time
     
  5. MartinS

    MartinS Well-Known Member

    Joined:
    Aug 23, 2009
    Messages:
    2,111
    Likes Received:
    197
    11% on mine.
     
  6. markie-m8

    markie-m8 Well-Known Member

    Joined:
    Sep 16, 2009
    Messages:
    109
    Likes Received:
    0
    Just checked mine and I'm running 100% to the second, thought my battery has been poor the last couple of days. I've just turned off Google maps latitude thing thats been running a while to see if that's my battery killa.
     
  7. mw383

    mw383 Active Member This Topic's Starter

    Joined:
    Dec 5, 2008
    Messages:
    28
    Likes Received:
    0
    will try chomp

    thanks jimbo
     
  8. mw383

    mw383 Active Member This Topic's Starter

    Joined:
    Dec 5, 2008
    Messages:
    28
    Likes Received:
    0
    jimbo

    installed chompsms but still show 92-100% awake time

    how do i fix this? what did you mean about removing the message link and how can i do this?

    thanks in advance
     
  9. penguin-power

    penguin-power Member

    Joined:
    Oct 21, 2009
    Messages:
    5
    Likes Received:
    0
    see at bottom of my post:
    http://androidforums.com/htc-hero/12115-better-battery-life-htc-hero.html
     
  10. malibuflavor

    malibuflavor Member

    Joined:
    Oct 18, 2009
    Messages:
    8
    Likes Received:
    0
    Mw383, This is what I did and saw a difference. First I installed a 3rd party SMS program. I liked the Handcent one as there are a lot of features. But it should not matter. Next I turned off the phones default messaging services so that I was not getting double notified. To do this I just went to in to All Programs<Messages<hit the menu button<settings and turned off Auto-retrieve and the Notification check marks. After all that I turned my phone off to reset the timers on the uptime and awake time. Then I tested it. I turned my phone on, sent a text message to myself, and then went to view the awake time. I went to Menu < Settings < About Phone < Status < Awake Time. Now since you just turned on your phone it should match your uptime. Take note of what your awake time is. Keep the phone on that screen and hit your end button to turn your screen off. Wait a minute and then hit the end button to turn the screen back on. Your awake time should now not match your uptime. It should be within seconds of the time that you recorded aka turned the screen off. I hope this helped.
     
  11. gixxerman

    gixxerman Member

    Joined:
    Oct 21, 2009
    Messages:
    6
    Likes Received:
    0
    This is a dumb question, but how do I put Hero to sleep? Am I doing this when i hit the hangup / power button.
     
  12. malibuflavor

    malibuflavor Member

    Joined:
    Oct 18, 2009
    Messages:
    8
    Likes Received:
    0
    Not a dumb question at all. Yes that is how you do it.;)
     
  13. jimeller

    jimeller Well-Known Member

    Joined:
    Aug 6, 2009
    Messages:
    409
    Likes Received:
    23
    I was interested in trying this, so I followed Malibuflavors post to a tee, yet I'm still seeing 100% awake time, despite having 23% and using the stock sms app before I started! What gives?
     
  14. mw383

    mw383 Active Member This Topic's Starter

    Joined:
    Dec 5, 2008
    Messages:
    28
    Likes Received:
    0
    just did your steps malibu. so far it seems to have worked.

    i hope htc/sprint/google comes up with a fix for this either in 1.6/2.0 or standalone that terminates the messaging app upon ending/sleeping since this seems to be the largest drain on battery outside the usual suspects (wifi, BT, etc).

    i kind of like to keep the essential apps/capabilities stock

    thanks for your help
     
  15. leeladisky

    leeladisky Active Member

    Joined:
    Oct 15, 2009
    Messages:
    31
    Likes Received:
    0
    Tried the tips - nothing worked.....battery still sucks.

    Lee
     
  16. Ziani

    Ziani Well-Known Member

    Joined:
    Sep 20, 2009
    Messages:
    836
    Likes Received:
    92
    Thanks Jimbobmcginty...mine is 30% :(
     
  17. jimbobmcginty

    jimbobmcginty Well-Known Member

    Joined:
    Oct 7, 2009
    Messages:
    55
    Likes Received:
    2
    Perhaps what I forgot to say was....

    Start Messages, and the edit the settings to disable notifications.

    Go to Home -> [menu] -> Settings -> Applications -> manage applications -> Messages -> Clear defaults

    This stops your phone from using Messages for any default purpose (SMS/MMS).

    Now after this, never ever use Messages, never start it, never have a widget, never have a shortcut to it (so you don't accidentally start it) on any of your seven home screens. If you do it will keep the phone awake until you reboot it.

    Reboot your phone. Enjoy low awake / high sleep :)

    Put a link to chompSMS on your home screen for easy access too.
     
  18. Ziani

    Ziani Well-Known Member

    Joined:
    Sep 20, 2009
    Messages:
    836
    Likes Received:
    92
    I am now totally confused. I had not really looked into this
     
  19. jimbobmcginty

    jimbobmcginty Well-Known Member

    Joined:
    Oct 7, 2009
    Messages:
    55
    Likes Received:
    2
     
  20. Ziani

    Ziani Well-Known Member

    Joined:
    Sep 20, 2009
    Messages:
    836
    Likes Received:
    92
    @ Jimbo....ahh think I get the picture now. You need a bloody degree to sort this phone out...love it :D

    I thought when the phone was asleep it was in a deep sleep but of course did nor really think that it had to be sleeping with one eye open for messages, phone calls etc.

    From what I gather then the main culprit is messages so will try ChompSMS. Does that do MMS as well?
     
  21. jimeller

    jimeller Well-Known Member

    Joined:
    Aug 6, 2009
    Messages:
    409
    Likes Received:
    23
    Well before I tried this operation my awake time was 23% and that was when I was using the stock sms app. Having installed handcent and doing the above tweaks, I can't seem to be able to make the phone sleep. Awake is still at 100%.

    Not sure what I can try now....

    There is something enabling messages when I receive a text despite all the notifications turned off etc. I've even tried installing handcent and configuring back to before I tried this 'fix'.
     
  22. vinnie21000

    vinnie21000 New Member

    Joined:
    Mar 10, 2010
    Messages:
    3
    Likes Received:
    0
    This worked for me on the incredible! Thanks
     

Share This Page

Loading...