Back to stock, unroot?


  1. Jeni_James

    Jeni_James Well-Known Member

    I've got some info that might b of use to you guys if u ever need to return ur Venture to VM for any reasons.

    Here goes:


    1. download this Romdump
    2. download & flash Stock Rom
    3. Since ur new to this ALSO download this: Recovery Flasher Utility (RFU)
    4. download & install this aswell: ES File Manager
    5. move the 'recovery.img' file from Romdump to ur SD card
    6. open RFU, follow the steps to flash the stock 'recovery.img', reboot - ur phone is ALMOST unrooted
    7. Open ES File Manager, navigate to 'system/app' remove SuperSU & whatever else u think doesnt need to be there by long pressing then delete
    8. Still in ES, go to 'settings', scroll down to 'root settings' & uncheck all of them
    9. Unroot successful! now remove the stuff u dont want on it & ur good to go :)

    Thanks to LeslieAnn to for the stock rom & LeaderRider for the 'recovery.img'

    Hope this helps you guys

    Advertisement
  2. johnnysacco

    johnnysacco New Member

    Could you re post stock recovery please. Links dead for ROM dump. Thanks.
  3. Dracable

    Dracable Well-Known Member Contributor

    ktalley and johnnysacco like this.
  4. ktalley

    ktalley Member

    I'm having trouble getting this stock recovery to flash. First, I tried the Recovery Flasher Utility (as prescribed), but it immediately said that a valid recovery was not found on sdcard (it's the only file on the card in root dir). I went ahead and tried it, and it said it flashed, but nothing on a recovery reboot other than angry andy. Tried flashing it using flash_image binary via adb, same result. I then used flash_image and flashed the CWM recovery image again, and now it's back to CWM and things appear to be okay. This is a spare phone that's hardly been used, and I'd like to get a few bucks from it while it has value, so thought I'd get everything back to stock/unroot/etc. before selling it.

    Anyone have any ideas on why my flash of stock recovery is not working? I am using the SendSpace link from Dracable's post -- I downloaded it twice and did a binary compare just to make sure that my download wasn't flaky. Since other people have used this (I'm assuming), I'm guessing that the original posted file couldn't be bad, right?

    Ideas?! Thanks as always for the great help here in the forums!!

    (FWIW, I have already flashed back to LeslieAnn's stock ROM -- that went fine...)

    Kevin
  5. Dracable

    Dracable Well-Known Member Contributor

    try flashing it with fastboot instead of adb. with the phone powered off and unplugged from the PC AND power, hold the back button and power on the phone. it should boot to just a blank, black screen. once u r on the black screen, plug your phone into the pc. open up a command prompt and navigate to your recovery.img file. run the following command without the quotes... "fastboot flash recovery recovery.img". after it says it finished successfully, pull the battery and try to reboot into recovery. good luck!
    ktalley and divinebovine like this.
  6. ktalley

    ktalley Member

    Thanks, Dracable -- but same result after the fastboot flash (yellow exclamation point in the triangle next to Mr. Android). I am stumped. Knock on wood, but this may be the first time in my years of flashing/etc. that something simply flat out wouldn't work for me. Strange...

    And once again, afterwards I flashed CWM recovery (6.0.1.2) also using the fastboot method, and it worked like a charm.

    Oh well -- thanks for trying!
  7. roadkill42

    roadkill42 Well-Known Member

    have u tried the flash utilty on google play store several people had succes with it even me .had to cas my pc went down any ways just a thought:)
  8. Dracable

    Dracable Well-Known Member Contributor

    maybe for some reason the file got corrupted. let me find my copy and reupload it for u, and u can give it a shot again.

    and roadkill, if adb/fastboot wouldnt work, there should b no reason the flasher utility would work, just fyi. ;-)
  9. ktalley

    ktalley Member

    Are you talking about the Recovery Flasher Utility mentioned at the top of this thread? If so, yes I tried it -- however, it said that my "recovery.img" was not a valid recovery image (although it let me flash it anyway).

    Dracable -- any possible way that file could be hosed on SendSpace? I know -- not likely, but grasping at straws here....lol..... :)

    Anyway, the phone is now on stock ROM and has been unrooted. So the lingering CWM recovery is not the end of the world if I have to sell it that way (heck, the new owner may want it on there anyway if they plan to flash...).

    Thanks all!
  10. roadkill42

    roadkill42 Well-Known Member

    were here to help each other
  11. Dracable

    Dracable Well-Known Member Contributor

    *post removed. linked to incorrect file.*
  12. ktalley

    ktalley Member

  13. Dracable

    Dracable Well-Known Member Contributor

    oh lol. my bad.. must have been a duplicate renamed to recovery.img. lol. just a sec. ive got it somewhere...
  14. Dracable

    Dracable Well-Known Member Contributor

  15. ktalley

    ktalley Member

    Well, I did a binary compare, and this file is identical to the one I've been trying to flash. So it looks like I'm just outta luck on this one! But I REALLY appreciate all of your help, Dracable (and others)! Thanks for trying!

    Cheers,
    Kevin
  16. Dracable

    Dracable Well-Known Member Contributor

    did u try flashing it while the phone was rooted, or did u unroot before trying to flash? if u unrooted first, i would try to root again and then flash it. another thing u might wanna try for shits & giggles is to flash my drandroid lite rom and then try to flash the stock recovery again and see if it works. if it DOES work with my rom installed, then i should know how to help u get it back to the stock rom with stock recovery. :)
  17. Dracable

    Dracable Well-Known Member Contributor

    oh, also, i think i remembered something that was odd about our stock recovery.... try flashing it again. when u get to the screen with the Andy logo, try hitting the home button. see if it brings up the recovery menu. there was somethin i vaguely remember about the options being invisible until u hit the home or back button or somethin like that. givee it a shot!
  18. divinebovine

    divinebovine Well-Known Member Contributor

    That doesn't make sense to me. When you boot from the recovery partition it doesn't load any of the main OS so it shouldn't matter if it's rooted or what ROM is on it. How did you arrive at that idea?

    (Not busting your balls here, just wondering if there's something for me to learn.)
  19. Dracable

    Dracable Well-Known Member Contributor

    actually, ya. good catch divine. when i was talking about rooting, i was thinking about adb and how it might make a difference since he was within the OS while flashing, but i had him try fastboot too which is outside the OS, so scratch that. it was just a thought. and as far as the rom goes, what i was trying to arrive at was to run it thru dsixdas kitchen, and add the stock recovery to flash with the rom (would that be possible to do while in cwm considering u r IN recovery while trying to flash another recovery?). it sounds to me like it might b data corruption, and some people have had better luck when flashing a rom after it runs thru kitchen (which im guessing has something to do with the updater-script conversion, but im not 100% on that. just a guess). i was just trying to suggest a different method of flashing it to see if it solved the error. but ya, thanks for the correction. that was an oversight on my part. i was at work and preoccupied at the time :p
  20. ktalley

    ktalley Member

    Well, I'll be hornswaggled! The extra press of Home indeed makes the menu show up. Crazy! Thanks, Dracable! However, I can't figure out how to select anything. Vol up/down moves the menu selector, but I can't get any button to select anything (i.e. power). Is there a different key/key-combo that I should be using to select??

    Thanks again!!
  21. Curtis1973

    Curtis1973 Well-Known Member Contributor

    Dont worry about it. Just get the device in running shape and vm will take it back anyway. I never bother returning to stock unrooted. By the time those bozos get the phone..the deal will already be done lol.
    ktalley likes this.
  22. divinebovine

    divinebovine Well-Known Member Contributor

    Did you try the Enter key?
    ktalley likes this.
  23. Dracable

    Dracable Well-Known Member Contributor

    ya, its the enter key to select. i KNEW i remembered something that kinda threw me off about the stock recovery when i first had it :p lol
    ktalley likes this.
  24. ktalley

    ktalley Member

    Enter key is the winner (I thought I tried that the first time, but perhaps I was pressing the Del key instead -- that's what happens when I don't have my reading glasses handy...lol...).

    You guys rock -- the phone is back to stock everything (& unrooted) and looks brand new back in the box. Should be easy to sell...

    Thanks EVERYONE (especially Drac for providing the recovery.img download)!

    Cheers!
    Kevin
  25. roadkill42

    roadkill42 Well-Known Member

    yes he is the man

Share This Page