Bad batterySupport


Last Updated:

  1. Bozz5384

    Bozz5384 Well-Known Member This Topic's Starter

    Joined:
    Jun 19, 2011
    Messages:
    223
    Likes Received:
    11
    Just wanting to see if anyone has experienced this...

    I went to use my spare battery yesterday for the first time in about a month, and it was TOTALLY dead. When I try and turn the phone on the bottom buttons would just light up a couple times and shut off.

    Put it on the charger and left it for a couple hours and still does the same thing.

    Bad battery? Has anyone experienced this?
     

    Advertisement
  2. tube517

    tube517 Well-Known Member Contributor

    Joined:
    Jun 7, 2010
    Messages:
    3,211
    Likes Received:
    1,454
    Put it (the battery only) in the freezer for a few minutes. Try it again.
     
  3. Bozz5384

    Bozz5384 Well-Known Member This Topic's Starter

    Joined:
    Jun 19, 2011
    Messages:
    223
    Likes Received:
    11
    Thanks for the suggestion... .Hopefully you meant 24 hours when you said "a few minutes"... :D

    Put it in there last night and forgot about it.

    ooops.
     
  4. yehaww

    yehaww Active Member

    Joined:
    Jun 30, 2011
    Messages:
    26
    Likes Received:
    0
    I had that happen once too. The phone just shut down on it's own one time. It wouldn't restart, the button lights would just flash. I tried everything. In frustration, I finally just smacked the phone on the table, pretty hard, hit the power button and it rebooted.
     

Share This Page

Loading...