Bad performance since update.Support


Last Updated:

  1. jacoolh

    jacoolh Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    8
    Likes Received:
    1
    Bad performance has plaqued my phone since I updated it with 2.2. It's like it has the desire software on the legends hardware. Gets very sluggish after 1 hour of being turned on.

    Not that much running either. Anyone else had problems?
     

    Advertisement
  2. appapapa

    appapapa Member

    Joined:
    Nov 25, 2010
    Messages:
    8
    Likes Received:
    0
    I noticed that my HTC Legend was often using 100% CPU usage after the update which turned out to be the Android System using all the resources so an app killer didn't solve the problem. I had to backup and perform a factory reset to solve this issue. You could try using a CPU monitor app to see if there is any offending app. Also, you could check the Services by doing Menu -> Settings -> Applications -> Running Services. Perhaps there is something there causing the issue.
     
  3. Rufayl

    Rufayl New Member

    Joined:
    Nov 30, 2010
    Messages:
    2
    Likes Received:
    0
    I have the same issue.I am using vodafone legend and still unable to fix the issue.
    Do i have to reset the factory settings?
    can i somehow reinstall the latest update on the sd card?since i believe that low internal memory may be the issue!
     
  4. pctools

    pctools New Member

    Joined:
    Dec 6, 2010
    Messages:
    2
    Likes Received:
    0
    where you guys getting the 2.2? is not available in the market. 2.2 not stable? Can Legend support 2.3?
     
  5. appapapa

    appapapa Member

    Joined:
    Nov 25, 2010
    Messages:
    8
    Likes Received:
    0
    Your phone should tell you an update is available.
    If not select: Settings -> About Phone -> System software check - then press "Check now".

    Also, I have found that the sluggish performance is down to CPU usage. If you install some software to monitor your CPU usage (like Usage Timeline) you might see that it is quite high or consistently at 100% usage. To fix this you need to turn USB Debug on. I have no idea why but it works!

    To set USB Debugging on go to
    Settings -> Applications -> Developement and Press USB debugging
     
  6. pose

    pose Member

    Joined:
    May 30, 2010
    Messages:
    22
    Likes Received:
    0
    I have the same problem on my Vodafone Legend. After I unlock the screen, the phone takes a full minute to be usable, and even then is a bit sluggish. I did a factory reset, didn't help.

    I'll try appapapa's solution and get back to you.
     
  7. pose

    pose Member

    Joined:
    May 30, 2010
    Messages:
    22
    Likes Received:
    0
    I installed CPU monitor app to verify that the phone was running at 100% CPU usage around half the time when it was lying idle, even after several hours. Disabling JuiceDefender and Plotter fixed the issue. Ironic.
     
  8. RusskiyParen

    RusskiyParen Active Member

    Joined:
    Dec 22, 2010
    Messages:
    28
    Likes Received:
    4
    guys, there is an answer to all the lagging for HTC Legend, all u have to do is

    1. Turn off your phone, Remove SIM card
    2. Turn your phone ON without a SIM card
    3. Turn it off again
    4.Insert SIM
    5 Turn it on...

    after my phone is running very quick and very nice.
     
  9. goshtin

    goshtin Member

    Joined:
    Jan 8, 2011
    Messages:
    6
    Likes Received:
    0
    the trick with removing and replacing the sim card worked oddly enough
    did that fix last? because I really hope it's a permanent fix
     
  10. pzelnip

    pzelnip New Member

    Joined:
    Mar 18, 2011
    Messages:
    2
    Likes Received:
    0
    Sim card trick *sorta* worked, it was still 100% utilization upon restarting but now for the moment seems to be leveling off.

    This morning was getting 100% utilization while idle. Was finding the sync icon was appearing a LOT, so I turned of automatic syncing, but that didn't seem to do much (still getting a lot of sync notifications appearing).

    USB Debugging had no effect whatsoever.

    2.2 with the Legend on Virgin Mobile.
     
  11. feedtheflame

    feedtheflame Member

    Joined:
    Nov 21, 2010
    Messages:
    7
    Likes Received:
    0
    im also struggling with it being sluggish. and i dont know if this has anything to do with it, but im also suddenly not receiving texts from a friend. Ill try the sim card thing..and the usb debugging...
     

Share This Page

Loading...