Bam!... WiFi quit working, no changes made to phoneSupport


Last Updated:

  1. csoga

    csoga Active Member This Topic's Starter

    Joined:
    May 12, 2010
    Messages:
    40
    Likes Received:
    0
    12 hours ago, if asked how my D1 was doing, I would have said "perfect, never been better!"

    It's rooted, CM6 w/ stock kernel, SetCPU @ 800 screen-on/250 asleep, ADW Launcher, no themes, few widgets... suits me fine, very stable, good batt life. I manually turn my radios on and off as needed with the (wonderful!) Power Control widget in CM6. Also using Tasker to automate GPS radio upon opening a nav/map app.

    and WiFi was working fine yesterday, turned it on this morning... nothing. I used it just yesterday afternoon, when I saw an update notification for 4 apps... turned on WiFi, went to Market and did "download all", came back to the phone later and turned WiFi off. updated Apps were:

    Gmail 2.3
    ROM Manager premium
    LEDs Hack
    Gentle Alarm

    I've searched here, and tried all suggestions found:

    first, airplane mode on/back off, several times
    then, reboots, incl. a battery out one for 5 min while power-cycling both APs
    checked and re-checked all the Settings I can find on the phone
    fixed permissions using Rom Mgr
    Used CacheMate to clear cache (I know, I know... grasping at straws:D)

    Both my laptops can still see both of the APs in my house, and I have no neighbors to "step on my signal".

    The phone WiFi radio works... I turned on Wireless Tether, and this laptop connected to it and browsed over 3G just fine.

    In the list of networks I've connected to, on the WiFi Settings screen, both my APs are listed as "Not in range". In Advanced, I set Sleep Policy to "never" (and have considered putting in a Static IP, just to experiment?).

    Fortunately, just a few days ago I did total backup... Titanium, nandroid, then copied the entire SD card to the "DROID stuff" folder on my laptop. If I have to, I guess I could start from scratch, but dammit!... I sure don't want to have to. So, finally, my question:

    Any suggestions? :)
     

    Advertisement
  2. Shadowtech

    Shadowtech Well-Known Member

    Joined:
    Dec 29, 2009
    Messages:
    434
    Likes Received:
    36
    Stupid question, but have you tried uninstalling those 4 apps you updated? (aside from gmail)

    Also, try long-pressing on your listed APs and have the phone forget them. Then rescan and see if it picks them back up. If your laptop can access tether, I would assume your WiFi is working properly. Maybe something happened on your AP that the phone didn't like, have you tried rebooting that?
     
  3. csoga

    csoga Active Member This Topic's Starter

    Joined:
    May 12, 2010
    Messages:
    40
    Likes Received:
    0
    Well, turns out, restoring from a nandroid backup was more painless than I would have thought.

    Un-installing the updated apps didn't fix the wifi. Then, I was super-busy for a few days and didn't have time to mess with it.

    But yesterday, apps and data all stayed intact thru the restore, and my Wifi is now fixed. Shadowtech, thanks for the reply.
     
  4. csoga

    csoga Active Member This Topic's Starter

    Joined:
    May 12, 2010
    Messages:
    40
    Likes Received:
    0
    ...except I only ~thought~ my "data stayed intact"... I lost all texts, call logs, Settings changes, and other stuff I had done in the several days since the backup... even app updates! (notably the PITA Street View 1.6.0.6 update)

    And unfortunately, working WiFi only lasted three days. It quit again yesterday, and this time I immediately did a nandroid and TiBu full backup.

    I don't know what's causing this, but I've gotta find out. I don't have the time nor inclination to fiddle with this phone all the time, doing backups and restores several times a week, losing important data in the process, etc. etc.

    I just want the thing to work... right.
     

Share This Page

Loading...