Bank of America App not working after update to 4.1.83Support


Last Updated:

  1. itsallgood

    itsallgood Well-Known Member

    I tried uninstalling and reinstalling app. No luck. I use a US Bank app too, and it works with no problems. Anyone else having problems?

    Advertisement
  2. jessie1290

    jessie1290 Active Member

    BOA not working for me either as far as getting to my account info. It will take me as far as the place I enter my password, but won't log me in after I enter it. The other part, finding a nearby bank location does seem to work. I also reinstalled with no luck.
  3. Brattix

    Brattix Member

    Yup, not working here either. I enter my password, then get a blank white screen.
  4. dervari

    dervari Well-Known Member

    I can't get any financial software to work...

    BOA
    Amex
    Chase
    Discover

    They are all hanging and then FC.
  5. MosIncredible

    MosIncredible Well-Known Member

    Mine wasn't working before the update so I wouldn't pin this on 4.1.83. Plus there are some reviews for the BoA app saying others are having the same problem.
  6. kilasix9

    kilasix9 Well-Known Member

    I believe the app stopped working for several users not just us with the Atrix and update. I say this because if you read the comments on the Market, several people are reporting the same issue. I'm having the same issues you all mentioned.

    I'm hoping they will come up with an update to fix this soon.
  7. FaderMonkey

    FaderMonkey Member

    Yeah, I don't know if it's related to the update, but the BOA app was fine for me before the update and now I'm having the same problem as everyone else after the update. After I log in I just get a white screen.
  8. joeatrix

    joeatrix New Member

    could be the update, I got the same problem.
    but with my CHASE App, before update is fine, after update... can't logging?????

    Wat Happend here....how many more app that have same problem?
    Is there anyway we could roll back... cuz android without app is useless!
  9. Brattix

    Brattix Member

    Same here - I used the BofA app heavily prior to the update without a single issue like we have now. Have not been able to use it since the update. My only other banking app appears to be unaffected.
  10. rmarc71

    rmarc71 New Member

    I was able to fix the app by doing the following (seems the trust store got screwed up with the new release):

    Grab all the certs from the bank of america cert chain (I used openssl, you could probably use something else):

    openssl s_client -connect www.bankofamerica.com:443 -showcerts

    Grab each of the trust certs (3 total) and put them in files ending in .crt
    IE: cert1.crt, cert2.crt, cert3.crt (you could also create a pkcs12 out of 'em if you are inclined to do so).

    This is likely the problem with other apps noted in this thread.
    Place the files into internal storage download directory. Then go to Settings -> Location & Security -> Creential storage -> Install from internal phone storage.

    Use: Certificate Manager and you should see your 3 available certs. Add them and then reboot the phone.
  11. mikespry

    mikespry New Member


    this didnt work for me for some reason, but when i did a brute force approach of getting all verisign certs, I was all set.

    I just tried this on my phone and got both Bank of America and American Express apps to work again.

    I ended up exporting all Verisign and GT certificates in .crt format using my Firefox browser, copying them to my Dropbox account (emailing them should be fine too) and installing them one by one on the phone. You need to reboot your phone after installing the certificates...

    You can also figure out which certificates you need by clicking on the padlock or company name in the browser's URL bar
  12. rotty022

    rotty022 New Member

    i guess i wait until the developers fix this issue. unless someone can provide a step by step procedure to update. anyway to delete all the certs on the phone and to allow them to be reinstalled?
  13. itsallgood

    itsallgood Well-Known Member

  14. log1c

    log1c Well-Known Member

    oic, so chase, bofa, discover are using old certificates while our phones are using newer ceritificates.....what the
  15. m.girola

    m.girola New Member

    For me, the Bank of America, Chase, and American Express applications all do not work. The Motorola level 1 and 2 are not helpful. The best they could do is send me instructions that are too difficult for the average phone user.
  16. itsallgood

    itsallgood Well-Known Member

Share This Page