Barnacle Wifi Tethering... Testers Needed


Last Updated:

  1. Mastermind278

    Mastermind278 Well-Known Member This Topic's Starter

    Joined:
    Dec 11, 2009
    Messages:
    283
    Likes Received:
    97
    As per requests I have started a new thread. I would like a few people to test it out and see if they can get it working. I have been using it for a few weeks now and has worked perfectly on various Wireless devices that can connect to AD-Hoc Networks.

    Here are the steps that I followed:
    Code (Text):
    1.  
    2. 1. Download rtecdc.bin ([URL="http://www.mediafire.com/?ymroinj13kt#1"]rtecdc_bin[/URL]) on a computer.
    3. 2. Rename the file from rtecdc_bin to rtecdc.bin
    4. 3. Mount SDCard and copy rtecdc.bin to the root of the SDCard.
    5. 4. Open ADB Shell or Terminal (if you want to do it from the phone)
    6. [CODE]
    7. su
    8. cat  /sdcard/rtecdc.bin > /system/etc/rtecdc.bin
    9. chmod 755 /system/etc/rtecdc.bin
    10. reboot
    11.  
    6. Open Market and Install Barnacle
    8. Open Barnacle, click Start and enjoy Wifi
    [/code]--> The only settings I changed on Barnacle were the SSID and installed WEP security.

    I must also credit Vampirefo from SDX for providing a guide for the Moment in which I modified to get it for the Behold 2.

    Also special thanks to Nu115u5 for brining Root to the 1.6 Update! You will need to install the rooted kernel to undergo the above procedures. Information can be found on his thread.

    For those wondering this is working for me with the update coming from T-Mobile.

    Edit: If you get a FC from Barnacle make sure you have Wifi disabled on the phone!
     

    Advertisement
    Lyrical, sopgent7, dave5777 and 4 others like this.
  2. bakasamaz

    bakasamaz Active Member

    Joined:
    Jul 15, 2009
    Messages:
    33
    Likes Received:
    1
    I'll test it out and keep you posted..
    excited!!:D
     
  3. Nu11u5

    Nu11u5 Well-Known Member Developer

    Joined:
    Feb 3, 2010
    Messages:
    263
    Likes Received:
    234
    I'll test this later.

    If things work this file should be included in custom roms.
     
  4. bakasamaz

    bakasamaz Active Member

    Joined:
    Jul 15, 2009
    Messages:
    33
    Likes Received:
    1
    BIG Thanks to OP!!!!:D:D I tested it on microhaxo 1.6 tweaked rom v3 rooted and tether works beautifully!! :)

    Thank you thank you thank you..... :p

    You should definitely include it.
     
  5. microhaxo

    microhaxo Well-Known Member Developer

    Joined:
    Apr 4, 2010
    Messages:
    178
    Likes Received:
    102
    Good job Mastermind278 and all who contributed!

    Confirmed working :)
     
  6. Mastermind278

    Mastermind278 Well-Known Member This Topic's Starter

    Joined:
    Dec 11, 2009
    Messages:
    283
    Likes Received:
    97
    Glad to hear it is working. It was all a big contribution from both the Moment people trying to get Barnacle as well as the Galaxy people trying to get wifi tether. I kept seeing them mention of this rtecdc.bin file and figured if we play around with it enough it might work! Glad it does! =):)

    I figured if it worked for them it might work for us. I did have some doubts as they had an original rtecdc.bin file and our Behold 2 did not. However, if it works it works and we just enjoy it!
     
  7. mingkee

    mingkee Active Member

    Joined:
    Jul 29, 2010
    Messages:
    33
    Likes Received:
    5
    My BH II is doing "battery conditioning" after flashing. Will test the banacle later though I don't really need it.
     
  8. bjs2000008

    bjs2000008 Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    61
    Likes Received:
    6
    on the last line of code were it says "restart" i dont type that in.... sorry for the noob question
     
  9. Mastermind278

    Mastermind278 Well-Known Member This Topic's Starter

    Joined:
    Dec 11, 2009
    Messages:
    283
    Likes Received:
    97
    It should be reboot instead of restart...

    As I stated earlier you probably don't need all the restart/reboots that I have listed... But as I stated earlier you probably don't need all the restarts that I have listed. Nonetheless, I am almost certain that the one after moving the file to the system is required... But doing all the restarts ensures it will work correctly (might as well do them).
     
  10. mmandros

    mmandros Well-Known Member

    Joined:
    Feb 14, 2010
    Messages:
    84
    Likes Received:
    12
    I must be doing something wrong. I can launch Barnacle without problem. My computer shows the adhoc network. But I don't get an IP address. And on the phone Barnacle doesn't show any clients. Any ideas?:confused:
     
  11. mingkee

    mingkee Active Member

    Joined:
    Jul 29, 2010
    Messages:
    33
    Likes Received:
    5
    I think the key is "su" request when I tried to use.
     
  12. james.david.godfrey

    james.david.godfrey New Member

    Joined:
    Jul 25, 2010
    Messages:
    2
    Likes Received:
    1
    Works for me on microhaxo 1.6 tweaked rom v3 rooted. Thanks!
     
  13. Nu11u5

    Nu11u5 Well-Known Member Developer

    Joined:
    Feb 3, 2010
    Messages:
    263
    Likes Received:
    234
    Confirming that this works, although technically you only need to chmod 644 the file. No execution here.

    I did see that I already had a file named rtecdc.bin (real-time encoder-decoder?). Once replaced Baracle worked 100%!

    Thanks for pointing this out!
     
  14. Nu11u5

    Nu11u5 Well-Known Member Developer

    Joined:
    Feb 3, 2010
    Messages:
    263
    Likes Received:
    234
    That is exactly what I got before I installed the working rtecdc.bin file. Then everything will work.

    Make sure you put the file in the right place.
     
  15. bjs2000008

    bjs2000008 Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    61
    Likes Received:
    6
    thanx for the help Mastermind278 and good job on this... hey if you microhaxo and nu11u5 collaborate on a rom we might just have 2.2!!! well thats just a dream LOL
     
  16. Nu11u5

    Nu11u5 Well-Known Member Developer

    Joined:
    Feb 3, 2010
    Messages:
    263
    Likes Received:
    234
    After a few minutes of connection it seems to stop working while the connection stays up. If I restart the connection on both phone and computer everything comes back for a while.

    Is anyone else getting this?

    I need to check logcat next time this happens.
     
  17. microhaxo

    microhaxo Well-Known Member Developer

    Joined:
    Apr 4, 2010
    Messages:
    178
    Likes Received:
    102
    I only tested for about 4 min. How long is a few min?
     
  18. Mastermind278

    Mastermind278 Well-Known Member This Topic's Starter

    Joined:
    Dec 11, 2009
    Messages:
    283
    Likes Received:
    97
    I think the longest I have tethered for has been about 10 minutes in a row. It did work well for that time period. I did not test longer time periods. But I am sure logcat will show if there is an error causing the problem.
     
  19. ddirtyapes

    ddirtyapes Member

    Joined:
    Mar 13, 2010
    Messages:
    12
    Likes Received:
    3
    Wow, I did this whole thing F'd up and it still worked like a charm. Took me two tries due to not reading the instructions properly, but I just connected my girlfriends itouch to the wireless network and sent about 10 MB to test. Works great! Thanks for all the hard work and making this into a phone I can stand until an upgrade.
     
  20. slmar123

    slmar123 Well-Known Member

    Joined:
    Apr 7, 2010
    Messages:
    51
    Likes Received:
    21
    Just wanted to say thanks to Mastermind278 and to report my results.
    I have installed per the instructions and sucessfully have a WiFi tether on BH_Man's Take5 rom. I haven't tested longer than 2 minutes or so, as I was unaware that there might be issues. I will test longer and see if the connection is stable. I'll post my results.

    Follow-up:
    Ran for 15+ minutes and no disconnect. Just wondering if the disconnects above were from connections being idle or did you loose connection during internet/wifi activity?
     
  21. khunny7

    khunny7 Active Member

    Joined:
    Mar 25, 2010
    Messages:
    44
    Likes Received:
    1
    This is the best!! thank you so much.
     
  22. Jr_223

    Jr_223 Member

    Joined:
    Jul 7, 2010
    Messages:
    15
    Likes Received:
    0
    SWEET! its working, thanks Mastermind278 and all who made this possible.
     
  23. bearsfan85

    bearsfan85 Well-Known Member Developer

    Joined:
    Feb 23, 2010
    Messages:
    459
    Likes Received:
    97
    if you are getting an error with rtecdc.bin being read only or your computer isnt connecting to the internet through barnacle, then install barnacle, run barnacle, then uninstall it

    I didnt think the first steps were that important but they are so I figured posting this might help someone stubborn like me.

    This along with Root and a Rom makes this phone the best phone with 1.6 on it:D

    Thanks

    Posted through Barnacle tethering, lasted 20 minutes, needs to renew connection every 10 minutes, great speed
     
  24. Psychopathic

    Psychopathic Member

    Joined:
    Jun 29, 2010
    Messages:
    12
    Likes Received:
    0
    Hello, Barnacle was not working with Behold II OTA 1.6 Tweaked v3, until i followed this. Now wireless tether works great. I didn't even have to uninstall/re-install barnacle i had it already installed then i did your command, restarted phone and was done.
     
  25. Mastermind278

    Mastermind278 Well-Known Member This Topic's Starter

    Joined:
    Dec 11, 2009
    Messages:
    283
    Likes Received:
    97
    Awesome glad it works. I figured one wouldn't need to do all the steps but I wrote all of them as it was part of my trouble shooting. I figured the only required one would be the restart after copying the file over.
     

Share This Page

Loading...