Battery Discharge ProblemSupport


  1. garyasta

    garyasta Member

    I have an Ainol NOVO 7 Aurora 2 tablet with ICS that has a battery problem.
    After being used for a while and still showing 100% battery, it all of a sudden indicates that the battery is flat and needs charging.
    Is there a simple solution to the problem?

    Advertisement
    :
  2. bubbasd

    bubbasd Well-Known Member

    Dont know if this this is u want but u can check it out.
    link
    :ciao:
  3. garyasta

    garyasta Member

    Hi
    There looks to be a lot of good stuff there. Will check them out tomorrow.
    One thing! If I download the 100% battery fix install the original software and reboot, is this process likely to wipe all the apps and data that I've installed?
  4. bubbasd

    bubbasd Well-Known Member

    yep so grab yourself a backup program like Titanium Backup
    or
    Super Manager (The tool APK Manager in SM is great for backing up installed apps and force removing system apps, one thing a installed Game that requires extra download data wont be included in the apk creation)
    :cheers:
  5. bubbasd

    bubbasd Well-Known Member

    new solution

    try this first

    Install the terminal emulator
    Enter the emulator and get to a prompt. (Or use ADB to get to a shell.)
    Type the following:
    [HIGH]$ su
    # echo B8 > /sys/devices/i2c-2/2-0034/axp20_reg
    # echo B820 > /sys/devices/i2c-2/2-0034/axp20_reg[/HIGH]
    Reboot. The battery level should drop to 5%, and you can try to charge the tablet at this time to see if the problem continues to exist.

    -added info-
    (can wait a few minutes to see if the battery changed to 5% without rebooting)

    after applying this solution above the battery level when i plugged my elf 2 in my charger shot up to 99% so i disconnected it and started to go down slowly maybe it fixed it. (yep, still battery problems on elf2 Firmware 0926 i encountered it one day it just happened out of the blue thats how i came across this fix)

    other ways to fix here at
    Source:D
  6. garyasta

    garyasta Member

    This one is not solved as far as I am concerned. I have tried just about everything suggested in this forum, from updating to ROM 0925 and changing the command lines using Terminal Emulator, and including battery calibrations.

    I note that there is ROM update 1005 available. Does anyone know if this should really correct the 100% problem and firstly, does upgrading from Android 4.0.3 to 4.0.4 cause any problems?

    I don't really want to down-grade to ROM 0626 and then have to go through all the pains of upgrading to the latest again.
  7. bubbasd

    bubbasd Well-Known Member

    ever since ive had firmware 0925 for ainol elf 2 and before ive encountered the battery bug once (so good so far after the fix :D) and still have heat problems too on left side gets really hot (supposed to be fixed in previous firmware dont think so, still no differance),
    just wonder if ainol will ever get it right.:(

    ----
    this is read about deleting batterystats.bin file is interesting it points directly at android itself :confused:Read here
  8. garyasta

    garyasta Member

    I am using Ainol NOVO7 Aurora 2.
    Thanks for the info above, I've tried the command prompt changes (both of them) and upgraded the ROM to 0925. No success! The battery usage still sticks at 100%.
    I see that there is a feiyu 1105 (and possibly a later one still).
    Is it possible that the latest ROM might fix the problem?
  9. bubbasd

    bubbasd Well-Known Member

  10. garyasta

    garyasta Member

    I have heard of the 1210 ROM and have also heard that it uses more battery than earlier versions. If this is the case, it might not be too desirable.

    If it fixed the battery problem, I might consider it.
  11. bubbasd

    bubbasd Well-Known Member

    id thought id post this here goes on about custom roms pulling more charge
    here



    Have u been able to delete batterystats.bin in /data/system/ garyasta?

    if not see below
    I've used Root Explorer goto /data/system/ then delete batterystats.bin file and restart tablet.
    a new Batterystats.bin is created inside that folder. hopefully that makes any progress.
Loading...

Share This Page