battery doesnt chargeSupport


Last Updated:

  1. rimaaa

    rimaaa New Member This Topic's Starter

    Joined:
    May 6, 2010
    Messages:
    2
    Likes Received:
    0
    I don't know what's going on with my xperia x10 battery. it drops quickly. the battery dropped off till 0% and it turned off of course when i was on the way. And when i tried to charge it after arriving home, I have a problem to charge it

    I charge it from 8 pm to 2 am but it was still off and the light indicator still red ... and sometime while it was charging, the phone turned on it self and suddenly turn off again and pop up "please connect to charger, charge only 2%" and it happened many times...

    I confused... does the charger work or not? or does it take along time to recharge it again till 100%? I have charged it around 8 hours already..

    d u guy have the same problem with me?

    I have aplan to sony ericsson service center today to know what's going on
     

    Advertisement
  2. rwZephyr

    rwZephyr Well-Known Member

    Joined:
    Apr 25, 2010
    Messages:
    245
    Likes Received:
    16
    This happens when I charge of USB, also off my iPhone's 110v - USB adapter, are you using the charger that came with the phone?
    Our demo model we got at work uses an off brand charger too (The mount has a charger built in for less wires, but it's not the specific one the X10 came with) I think Sony, being well... Sony made their AC adapter proprietary with either a higher amperage or voltage or something I dont know.
     
  3. phanquangkhanh

    phanquangkhanh Member

    Joined:
    Mar 26, 2010
    Messages:
    7
    Likes Received:
    2
    I think your battery got problem. Cause you said that it dropped quickly to 0%. I had this problem before with my X1. Sometime I couldnot charge when 0%. I needed to use an outside charger (I dont know what to call it, it's a charger that charge your battery without putting the battery inside the phone)
     
  4. tracey1987

    tracey1987 Member

    Joined:
    May 7, 2010
    Messages:
    12
    Likes Received:
    0
    My phone chanrges ok in the mains charger but when i plug it into the computer it does not charge. Is it supposed to like iphone or not?
     
  5. Duncs

    Duncs Well-Known Member

    Joined:
    Sep 21, 2009
    Messages:
    112
    Likes Received:
    23
    Some usb ports in pc's and laptops are only 3v and dont have enough power to charge the x10 but if they are putting out 5v they work. On a pc try using the usb ports at the back which are usually all 5v, some front ports due to the way they connect inside the pc only get 3v. If its a laptop it depends on the specs but should be easy to find out from the makers website or the manual if you still have it.
     
  6. palace35mm

    palace35mm Member

    Joined:
    May 5, 2010
    Messages:
    19
    Likes Received:
    1
    try charging the battery using the power adaptor provided.
    it charges the battery 100%
     
  7. prakashjam24x7

    prakashjam24x7 Member

    Joined:
    Apr 28, 2010
    Messages:
    18
    Likes Received:
    2

    Hope your problem is resolved..! if not its a Motherboard issue which many are facing...! i got my motherboard replaced and the problem stopped...! you can find many with the same prblm with X10.
    try smelling the back after removing the battery...u should get burnt smell...!

    Regards,
    Senthilprakash
     

Share This Page

Loading...