Battery drain - digging deeper, possible causes

Discussion in 'Android Devices' started by Archon810, Nov 19, 2009.

  1. Archon810

    Archon810 Well-Known Member
    53

    Oct 16, 2009
    153
    81
    53
    So I have my Hero at 52% since this morning (about 8 hours) while my co-worker's is only down to 82%. When mine was at 82%, his was at 98% which is ridiculous.

    I've always had lag and battery problems and I'm still trying to trace them. I do not want to do hard resets, etc as it doesn't guarantee the problem won't come back. I want to figure out what is going on instead.

    I usually keep wifi and bt off and only turn them on when I need them (as my battery is already doing bad enough). The only things constantly on are GPS and mobile network.

    So one thing I noticed just now after looking at Spare Parts (it's a program from the app store that shows some detailed stats about battery usage and such) is that under Battery History -> GPS (since unplugged), it's listing 3 quite large markers - Camera, Bump (app that has to do with contact sharing), and Google Maps. The Camera app has 3h58m of the GPS sensor usage, and others have a bit less, which is insane. If true, this could most definitely be the cause of my battery drain.

    Here's the kicker - I don't have any of those apps running. I either killed them with Advanced Task Manager or stopped them a long time ago (for ex., I haven't used the camera since last night and recharged the phone overnight).

    Here's another kicker - the time in each of the Camera/Bump/Google Maps values that Spare Parts is reporting keep going up (you have to click back and then rerun the Battery history for it to update). I even turned off GPS and the time is STILL going up.

    I'm now at 50% battery.

    Any ideas?

    Oh, and my awake time is only 22% which is pretty good (last reboot was last night around 8pm).
     

    Advertisement
  2. Turk 182

    Turk 182 Active Member
    15

    Oct 25, 2009
    41
    0
    15
    Here's the deal. After downloading the update last night I immediately, and manually put my phone to sleep and on the charger. I wake up this morning at the awake time was something like 60%. So how is that even possible? It should have been at least 10%. Something is keeping the phone awake even though it is 'alseep' and charging. I'm guessing that if you have active sync enabled or anything that checks the web, it is keeping the phone from sleeping. And today my battery went ot yellow about 3 hours quicker than usual.
     
  3. jpgFIA

    jpgFIA New Member
    5

    Nov 11, 2009
    2
    0
    5
    Did you check the "Geo-tag photos" option in the camera settings (Camera-->Menu-->Settings)? That may be the source of your GPS usage you're seeing in Spare Parts.
     
  4. Archon810

    Archon810 Well-Known Member
    53

    Oct 16, 2009
    153
    81
    53
    I did and I know it would use GPS when running and I want that functionality but the point is it's not running and neither is GPS as I turned it off...
     
  5. teamwhite

    teamwhite Member
    5

    Dec 4, 2009
    8
    0
    5
    Was wondering if you got any resolution on this? When I check GPS usage in Spare Parts, it's showing usage by Google Maps, Compass and Here I Am app, but my GPS is turned OFF. Any suggestions? Help :(
     
  6. roland365

    roland365 Well-Known Member
    36

    Nov 30, 2009
    132
    6
    36
    On spare parts my Google maps is all blue when u check gps batt use. How can I fix it too
     
Tags:

Share This Page

Loading...