Battery increases 10-15% per restart?Support


  1. sw33ndawg

    sw33ndawg Well-Known Member

    This is since the gingerbread update. I restarted my phone at 64% and it was at 79% when it booted back up. I just now turned it off at 33% to find it at 47% when it booted back up. I'm now at 47% 15 hours unplugged with moderate-heavy use. Anyone else experiencing this and extreme battery life?

    Advertisement
  2. ScuroRaven

    ScuroRaven Well-Known Member

    Just tested mine. was at 83% before restart. 94% after
  3. AndrewTo

    AndrewTo Active Member

    bug??
  4. calbearz24

    calbearz24 Active Member

    Same problem here.
  5. rthomas10

    rthomas10 Active Member

    just noticed it too. Doesn't bother me much as it seems to have consistent drainage after the restart.
  6. raysfan79

    raysfan79 Member

    Im having the same issue here too, along with other issues since the GB update. :(
  7. WolfmanRobby

    WolfmanRobby Well-Known Member

    Not a bug, nothing to do with GB or the phone.

    Battery readings are of the available mHa's left in the battery. This can vary. If the battery heats up a little (Not even enough that you can feel it), it can throw off the readings.

    You'll see this right after a short charge, or a reboot. WHY? The battery heats up a little when you plug it in. When you reboot, you put a bit of extra load on it.

    Give it a few minutes and you will notice the battery DROP real quick. It didn't drop. The battery cooled down and it's reading more normal.

    I've seen this on BlackBerry's, iPhones, my tablet... anything with a Lithium battery.
    egDonald likes this.
  8. tCizzler

    tCizzler Well-Known Member

    I've noticed this too, however, my battery only shows up in 10% increments.... 100...90...80 etc. I'm using battery indicator pro. What is everyone going by?
  9. AndrewTo

    AndrewTo Active Member

    same here using widgetsoid
    prolly need root to get more detailed readings
  10. tCizzler

    tCizzler Well-Known Member


    I am rooted
  11. sw33ndawg

    sw33ndawg Well-Known Member


    I use battery circle. It tells you the exact amount in the notification bar. No root needed.
  12. sw33ndawg

    sw33ndawg Well-Known Member


    this never happened to me on froyo
  13. MikeAusA

    MikeAusA Well-Known Member

    Battery Monitor Widget free lets you put battery remaining in large digits on the Notification Bar in 1% steps - as well as a huge amount of info.

    Mike
  14. WolfmanRobby

    WolfmanRobby Well-Known Member

    Never happened, or you never noticed it?
    You can say, that every single time you rebooted your phone, you checked the battery before and after?

    I've been dealing with electronics for over 20 years... this is not a new, GingerBread caused, issue.
  15. eoga

    eoga New Member

    I dont know if this is the real reason, but my battery is not dropping faster than normal after I reboot and get this extra juicy. When i get the 10-20% the battery will take the same amount of time to spend this extra battery. So it seems more like a bug to me or the phone not providing the real battery status.
  16. WolfmanRobby

    WolfmanRobby Well-Known Member

    It's not a bug, it's that the phone is not really giving you the real status.

    No electronic device really gives the 100% accurate reading. To get that, you would have to take the battery out and test it with a quality Digital Multimeter and take a reading of the available mAh left. (I recommend FLUKE meters myself.)

    Even then, that will tell you what the percent of the original capacity (1800mHa) is. As you use the phone, the battery wears down. A 6 month old battery is probably only going to be able to hold a charge of about 1500mAh to 1650mHa. It's just a result of the breakdown of the chemicals (Lithium) in the battery.

    The electronics in the phone that measure the available mHa left in the battery are just not that robust or accurate.
  17. cem

    cem Member

    It happens to me too. I don't think it is a bug, I think it is a battery calibration issue. That's why I tried the app called batterycalibrator. Still, it sometimes happens, with a reduced increments after restarting. After all, sudden battery percentage increments after restarting will result in sudden drop while using, which may be bothering.
  18. androikw

    androikw New Member

    It's definitively a bug with the battery manager in GB. With no power cycling the battery meter goes down at a rate of a complete battery in 18 hours (approx.), and the phone of course dies when all the juice is gone (meter-wise I suspect). With the power cycling the power jumps up by as much as 30 % (it's variable) and the battery lasts twice as much with the same use.
  19. spydie

    spydie New Member

    Sorry Wolfman, but your 20 years in electronics is off base here. I have had two iPhones, and 4 androids and this has never happened before. ON my Atrix after the big boost on restart, it stays up for an hour or so, then drops fast. ON my wife's atrix, it gets the big boost and then never drops back down fast but goes into it's usual routine of slowly depleting just like it did before the restart. This is solely an Atrix problem. I haunt a lot of other forums and never saw anyone else ever complain about this. Only Atrix owners are complaining. And yes, I have rebooted my other phones many times, and yes, I did notice the battery before and after the reboot... never got the jump in battery before. I'm also a Ham Radio operator (electronics enthusiast and a Federal License to prove it) and my 45 years in electronics has never seen this before.
  20. egDonald

    egDonald Well-Known Member

    I used to think it was a "bug" initially. Your explanation makes sense.
    I guess you could use a similar "phenomenon" we all have experienced some time or another when using alkaline batteries for remotes or whatever household devices.

    For example, the TV remote. Some may have noticed that as the battery starts to weaken the remote doesn't seem to respond as quickly or as "strong. A good tap on the battery packs or simply removing and re-inserting the batteries seem to make the remote work normally again. This "battery power" didn't come from nowhere. Of course, this only works a certain number of times until you must exchange the batteries. :p

    Well... maybe not a direct example, but I get it :D
    WolfmanRobby likes this.
  21. spydie

    spydie New Member

    I'm not buying it. My phone's battery drops back to the old reading in a couple hours, but my wife's doesn't. She was at 62% when she went to bed. I reset the phone. It came back at 89%. Was still at 82% the next morning. Mine was at 46%. I reset the phone. it came back to 72%. It was at 42% the next morning. As for the analogy with the tv remote, that is entirely different. After many months of sitting in the remote, the battery gets a poor connection at the contacts either from oxidation or dust. moving the battery re-establishes the connection. Has nothing to do with restoring the battery. I tried the battery recalibration app. It does nothing to stop this weird fluctuation that only happens on the Atrix. I didn't have the atrix when it was Froyo, so I can't comment on that, but I've had cell phones since they were invented and this has never happened before. Too many people have noticed it on this phone for it not to be a bug of some kind. It's either the phone, the battery, or GB causing it on this phone (I've had GB on other other phones and it didn't do it, but that doesn't mean Motorola's version doesn't have the bug). It's an aggravating thing not to know for sure how much battery is left.

Share This Page