Battery life M835Tips


  1. mcr0986

    mcr0986 Member

    If you have this phone then you know that the battery life is TERRIBLE. I have never owned any device that had a battery life this bad. I tried to return it but metro hit me with the restocking fee and they didnt have the optimus in stock so i decided to keep it. I have SetCpu installed and wanted to know if anyone has had any luck prolonging the battery life even the slightest with SetCpu profiles or any other way. Thanks

    Advertisement
    :
  2. yanks_35

    yanks_35 Member

    Try juice defender(free)....I have noticed slight improvement since I installed it. Basically the phone will last me the whole day with modest use
  3. puyow18

    puyow18 Well-Known Member

    they have a new smartphone out now, the samsung admire. It is faster than the optimus, plus it has 2.3 on it. BUUUUUUTTTTT . . . if you look at the specs it lists only 3 hours of talk time (the optimus has 7.5; the m835 has 4). So you'd get a faster phone, but prob more battery drainage.
  4. mcr0986

    mcr0986 Member

    thanks im going to install juice defender but i think it will probably interfere with set cpu since they both sorta do the same thing. any thoughts?
  5. yanks_35

    yanks_35 Member

    I am not positive but I think that once you rooted your huawei m835 the cpu is automatically set to 600Mhz, which I believe is the fastest you can set for this phone. I like you installed SetCPU at first but then uninstalled it. My phone haven't slow down one bit and its seems that my phone is still running at 600MHz even after I uninstalled it. You can try it out yourself.
  6. mcr0986

    mcr0986 Member

    I am now running juice defender and setcpu and they dont seem to interfere at least while the screen is on. That is an interesting thought on the automatic 600mhz after root i am not sure about that. juice defender is nice because it seems to automatically disable data when hooked up to wifi. I shall see if this increases the battery at all or maybe it will decrease because i have so many apps running LOL :D
  7. Tokenpoke

    Tokenpoke Well-Known Member


    Juice defender is just an app killer. Wifi supersedes data without it.
    Set CPU on the otherhand....
    Make a screen off profile set to 245min/Max and set your governor to powersave. Saved my ascend a bunch of battery at the cost of a lag on incoming call display and the first couple seconds of waking the phone up.

    Also, use the power control widget to turn off wifi,GPS and Bluetooth when not in use. And keep screen brightñess to the lowest you can stand.

    Go to menu(button)>settings>display and turn off auto rotate and set screen timeout to 30s

    Unless you use your phone to alert you of emails turn synch off too. Go to settings>account and synch and turn off auto synch.

    In sound settings scroll all the way down and turn off haptic feedback.
  8. kimcheesoup

    kimcheesoup Member

    i have managed to make my battery last 2 days - no joke, by turning things off when im not using them.....

    i set my screen backlight low, unless i need it brighter.
    i turn off my wi-fi, satellite, bluetooth, and all of that.... and only turn it on when i need to use it.

    and, i sometimes i switch off my 3-G, unless i need it, b/c that saves battery too - but be advised, doing that messes with your picture messaging - you will not be able to receive or send pic msgs when your 3-G is off, and you will not be alerted of them either. i'd say, this is the only thing that you could leave on constantly, unless your battery is low - then you should shut off the 3-G until you can charge your phone again.

    it has become second nature. at first it might seem like a pain, but trust me - it extends your battery life like mad........ and i doubt you're using all those things constantly anyway.
  9. starxpilot

    starxpilot Well-Known Member

    Only advice I can give is try not using too many apps at the same time, and make sure you close them completely once done, if they are still listed in Running, then they probably will eat away your battery.

    Keeping the Wifi off is another thing. Anything else besides the Data and 3G *How is this an option?!* works best at least for me...

    Phone only has 4 hours of Talk time, what'd you expect from Metro? XD
  10. The2ndBarber

    The2ndBarber New Member


    How do you even get 3G in the first place? Mine always stays on 1x, when I called customer support they said that the 3G and the 1x are the same thing. I am having a hard time believing this because when I was on Verizon with 3G everything went acceptingly fast and now everything is VERY slow, even my simplest apps take forever to load up and even to use.
    Like most everyone one else I am having the same problem with the battery life, headphone volume, etc. Please help me
  11. starxpilot

    starxpilot Well-Known Member

    On your phone, go to Settings, About phone, Status, and go down to PRL Version. You should be at 3020 or higher. If 19 or below, especially if lower, you will need to call MetroPCS via Activation by dialing *228, and after hearing her ask "What are you calling about today?" open up your Dialpad and press 5, she should ask "Okay, so you want the Latest Roaming List with MetroUSA Nationwide Coverage, if this is not right, say Go Back." Don't say anything and it should proceed "Now just a moment..." with a little 'hip' sound. After a minute, it should say it was updated, and will ask you to repeat information, just say No, and your phone should restart, with the newest PRL.

    If it says she couldn't do it, you will either have to try again at a later time, or move about the place, surefire place is near a Metro Store.

    If your number is 20 or higher...then you will have to play the 'waiting' game, like all my friends have. Took me a long time to get the 3G, but you'll have it, if you live in an area, as I hear, with ze Purple/Home Area, or where there are towers that support it. MetroPCS | Coverage As for the towers, like Sprint's and ATT's, you really don't have a sure fire way of knowing due to location.

    They never really supported it so its denied at all places but from talking with a Corporate *And you can see it on the forums* they are using other carriers towers, where available. 1X is 1xRTT connection which is NOT 3G, 3G is CDMA - EvDo., which the M835 is Cert. to receive 1xEV-DO rev.0, but I've seen people run rev. A, if you're lucky.

    The only difference is that it's a wee bit faster, about 50-200 kpbs than 1xRTT, you can see the difference if you do a Speed Test *Avaliable free from the Market* Even then, its still crappy and slow as hell, but its all about location, location, location. Over here in Northeast Dallas/Garland Remnant, its pretty much below average, but meh. That's MetroPCS to you.
    The2ndBarber likes this.
  12. epp

    epp Well-Known Member

    In order to get 3G, you have to hit a cell site that has been upgraded with 3G. In the Boston area, I have yet to see it. My M835 has always displayed 1X since I've had it (late last year).
  13. epp

    epp Well-Known Member

    Now that I have a full-time signal at work, I reinstalled JuiceDefender and for the first day, saw no "real" difference, battery is still at 45% after being on for almost 11 hours straight.

    All JuiceDefender seems to do, is turn off the data 1X radio when the screen is off. With WiFi enabled (at home) and the screen is turned on, the app correctly turns on the 1X radio, but WiFi will not auto-connect.

    So, I uninstalled it.
Loading...

Share This Page