Battery low, cannot program


  1. ElectricHippo

    ElectricHippo Active Member

    Ok, I tried rooting my droid for the first time last night, and I really hope I didn't brick it. Here's what happned:

    - I had 2.1 update 1
    - I used the guide to rooting 2.1 here: Guide to Rooting Android 2.1 on a Motorola Droid - Droid Life: A Droid Community Blog
    - it seemed like it actually worked. I flashed their recovery image, and the phone DID NOT reboot, but RSD Lite said it was done, so I disconnected the USB and rebooted it into the recovery mgr.
    - I installed their update.zip, and that seemed like it worked too. I rebooted into 2.1 with root permissions. I tested this with the emulator, and I was able to use ROM Manager
    - then i tried using a bugless beast 0.4 rom, and the phone wouldn't boot up after that

    If I try to turn it on, I get the motorola M symbol, which then goes away, and comes back, flashing over and over.

    If I try to plug it into the USB and restore the stock recovery image, it says 'Battery Low Cannot Program'. I plugged it into the wall charger for a while, but it always says the battery is low when I switch back to USB and try the boot loader.

    It WILL boot into the Clockwork Recover Mod menu if I reboot while holding X, but I have no idea what to do with that menu.

    Is my phone bricked for good? Is it just the battery?

    Any help would be awesome, thanks

    Advertisement
    :
  2. OMJ

    OMJ Bazinga VIP Member

    It sounds like you didnt wipe data and cache when going to BB v.4

    You arent bricked and you dont have much of an issue at all. Just boot into clockwork recovery and wipe data and cache. It should boot fine after that
  3. ElectricHippo

    ElectricHippo Active Member

    Ok, I tried that and no luck. I tried the data/factory reset, and then the cache, and they both said they worked. Then I chose reboot, and it still just flashed the M over and over.

    I then went to the nandroid menu item in clockwork, and saw my restore point. I chose that and it seemed to work. It ran through a million files and then said '.android_secure.img not found Skipping restore of applications on external storage', and then also something about skipping restore of /sd-ext, but then it said 'Restore complete!', so I chose reboot, and it said 'Rebooting...', but then it just shut off.

    So I powered it on manually, and now it's back to the flashing M.

    Any ideas?

    UPDATE:
    Ok, maybe it is the battery, at least in part. When I unplug it the flashing M stops, and I think it just goes totally dead. It wont respond the the power button or any of the other buttons and the screen stays blank unless I plug it in to the wall charger - and then its back the flashing M. Could I have killed the battery? Is it not charging while the flashing M thing is happening, or at the clockwork screen?
  4. OMJ

    OMJ Bazinga VIP Member

    you still arent bricked so done worry.

    What I would do now is download a rom preferably something very plain. The new leak that is in the roms forum would be a good rom to try.

    Boot into recovery then go to the partitions menu
    Plug you phone into the computer
    Then mount USB Storage
    Then put the rom on your sd card
    Back out to the main menu of clockwork recovery and go to advanced
    then reboot recovery
    once that is done you should be back in recovery.
    I know you have done it before but wipe data then wipe cache
    Then go into the partitions menu
    now format boot
    then format system
    then back out to the main menu
    the install zip from sdcard
    then choose zip from sd card
    find the rom you just put on there and install
    Should be good to go after that
    ElectricHippo likes this.
  5. ElectricHippo

    ElectricHippo Active Member

    This sounds like a good plan. Unfortunately I've tried it twice now and I can't get more than halfway through the copy of the zip file before the phone goes dead. Maybe I really did cook the battery. I'll leave it plugged in over night and see what happens. Thanks for your help.

    Also, the rom I got from the forums was this one:

    http://bit.ly/99YEcu

    I think it's a Cyanogen. Is that a good one to use?

    thanks again
  6. klwheat

    klwheat Well-Known Member

    I would start by letting it charge fully....then try again from the recovery menu. Good luck. Also, for what it's worth, I used the BB v0.4 rom...and it was rock stable and great. Now I'm using the xultimate droid rom...and it works fine too. I've also used kangarade with success.
  7. OMJ

    OMJ Bazinga VIP Member

    I would leave it on a charger for a few hours then try again. Make sure its a wall charger. Even bootlooping I think it will charge eventually. If not you will need to find someone with a charged battery and use that. Unfortunately the droid doesnt change in recovery or in the boot loader
    ElectricHippo likes this.
  8. ElectricHippo

    ElectricHippo Active Member

    Ok, this is pretty weird. I had it charging all day with the wall socket at work. It kept trying to boot, showing the M, and restarting. I had heard that if the white light was not on, it wasn't actually charging the battery, so I figured my battery was just dead. If I plugged it into the USB, the white light would come on, but after 10 mins or so, it would try to boot up, and then go dead again.

    So I get in the car to go home, and I figure what the hell, I plug it into my car charger for the ride home(about 30 mins). The white light was not on. I pull up in front of my house and the phone is on, and working, at the desktop.

    It's exactly as I left it before the 0.4 BB. I'm at 2.1, with root. I'm pretty confused as to what happened, but it is working now, so I'm going to try a different rom through the rom manager.

    Any good guides on how to use Rom Mgr step by step? The checklist and options they presented me with last time didn't have much explanation.

    thanks again for all your help
  9. OMJ

    OMJ Bazinga VIP Member

    not much you need to know other than make sure you wipe data and cache. Some roms have an option for gapps or Google Apps if a rom has that option make sure you check it.


    thats pretty much it.
  10. blackberrywidow

    blackberrywidow Active Member

    AND make sure you have a fully charged battery, or at least a pretty good charge on it... Sounds silly but just wanted to remind

    Anyways glad you got it working again

    Side note: I have read many times of phones not wanting to charge and people thought they were dead. I even ran into it myself one. For myself, it was a matter of using AC instead of USB. That doesn't seem to be the case for you but just goes to show to try every possible option.

    Flash On!
  11. ElectricHippo

    ElectricHippo Active Member

    :mad: Aaaarrrggghhhh!!!!
    Ok, something is still fubared. I had it all working yesterday. When the phone came back on it was 2.1 with root. So I used ROM Mgr. to get Cyanogen 6.0.0 RC1, which I heard was solid. I checked the boxes for Wipe Data and Cache, and for Backup Rom.

    It rebooted, it installed Cyanogen(i think), and then rebooted and I was back to the blinking M.

    So I flashed the stock recovery and took it it back to 2.0. Boots up ok. But 2.0 sucks, it doesnt even have pinch zoom. So I take the update to 2.1. Back to flashing M.

    UPDATE: while i was writing this post the phone booted. I'm now at 2.1 update 1, and everything seems fine. Why did it have to flash the M like 10 times before booting properly? Does this mean the Cyanogen wasn't busted and it just needed to flash M for an hour or so before finishing? Is this typical?
  12. OMJ

    OMJ Bazinga VIP Member

    Not typical at all. Im not sure what is going on with you phone that its bootlooping this much.
    ElectricHippo likes this.
  13. ElectricHippo

    ElectricHippo Active Member

    Yeah, me neither. It's a bit annoying. It's everytime I boot the phone now. I'll get like 4 or 5 M before I get the all seeing eye, and then it boots ok. It's like 90 seconds or so, which I think is longer than before. Any idea how i can clear that out?

    If I can't get rid of it and take it back to how it was I'll probably try to root it again just so I can overclock it. Does that help with boot times?
  14. gwlaw99

    gwlaw99 Well-Known Member

  15. ElectricHippo

    ElectricHippo Active Member

    ok, so the procedure is this?
    - open rom manager
    - choose download rom
    - pick something like cyanogen or bb
    - it downloads and I get a notification
    - i click on that notification and I get a checklist asking if I want to A)Wipe data and cache and B)Backup my rom
    - i check both of those and i get a dialog asking if i want to reboot and install the mod
    - i click reboot and the phone reboots and installs the mod

    Did I miss a step? Do I actually have to wipe something or apply update.zip myself? Because it seems like its all automatic, but then I get the flashing M which never seems to go away.
  16. gwlaw99

    gwlaw99 Well-Known Member

    That is all correct although you might want to backup your apps first with Titanium Backup for easier reinstallation. I like to do it manually by booting into recovery. That way I can wipe data and cache three times to make sure it is completely wiped, but that is probably overly cautious.
  17. ElectricHippo

    ElectricHippo Active Member

    Sorry to be so explicit, but can you explain that? When you say you do it manually by booting into recovery, do you mean you just let Rom Mgr download the rom, and then shut the phone off, and turn it back on holding X?

    If so, where is that rom you just downloaded through the rom manager? I thought the only thing you could install from recovery was a file that had to be called update.zip and be on the sd root.

    Sorry to drag this out so much, but I'd be less concerned with step by step details if it hadn't locked up on me last time.
  18. gwlaw99

    gwlaw99 Well-Known Member

    I would try your way first as it is easier.

    To do it manually you can use the hold X method or you can choose reboot into recovery from ROM Manager.

    Once there you select wipe data and wipe cache partition 3x. Then you choose install zip from SD card and then select install zip from SD card again. Then you find the zip file in the file manager-esque menu (does not have to be renamed with clockwork) and select it. I am not sure what folder clockwork puts the ROMs as I download manually to the download folder.

    If you want to you can use Astro file manager to rename it update.zip, move the file to the /sdcard folder and then choose flash update.zip once in recovery.

    You can also wipe 3x and then reboot and install the ROM from ROM Manager.
    ElectricHippo likes this.
  19. ElectricHippo

    ElectricHippo Active Member

    Ok, I'll give that a try with Cyanogen.

    A few more questions, just for my curiosity:
    - is the Cyanogen 6.0.0 a Froyo 2.2 OS with all the wifi/tethering features?
    - do I need to activate my phone and do the google setup in between flashing the recovery image and copying over the update.zip, or can turn it off when i see the activation screen/phone call thing, boot into recovery and use the partition menu to mount the usb and copy over the update.zip?
    - also, I get this message from RSD after the phone reboots when I click Close -' Application is currently busy. Closing application may DAMAGE the attached device. Do you wish to continue?' - This is after the phone has rebooted into the activation screen, and RSD does say Progress 100%. Is this a big deal?

    thanks for all the help!
  20. ElectricHippo

    ElectricHippo Active Member

    Ok, this may be unrelated, but maybe it's due to me activating my phone like 3 or 4 times today because of all the flashing.

    Has anyone ever gotten 'All circuits are busy' when you flash the recovery image and then go to activate the phone? is VZW on to me or is this coincidence?
  21. gwlaw99

    gwlaw99 Well-Known Member

    I don't use Cyanogen, but I think that is correct. I only activate after a new ROM is installed. I never use RSD so I do not know. I don't think it will hurt anything.

    "Busy" does happen sometimes. You might try dialing *22899 and see if that works.
    ElectricHippo likes this.
  22. ElectricHippo

    ElectricHippo Active Member

    You've been super helpful, I feel bad keeping this thread going, but I'm one of those people that needs to know how everything works.

    If I flash a recovery image and reboot the phone into recovery, do I then,

    -wipe data/factory reset
    -wipe cache
    -apply update.zip

    or

    -apply update.zip
    -wipe data/factory reset
    -wipe cache

    what i'm getting at is, the update zip is the 15MB rooted 2.1 update right? does wiping data/factory reset undo that? Do I want to apply update.zip last?
  23. gwlaw99

    gwlaw99 Well-Known Member

    This.

    -wipe data/factory reset
    -wipe cache
    -apply update.zip

    As long as you have renamed the ROM to update.zip and moved it to the /sdcard folder. Do the first two 3x.
  24. ElectricHippo

    ElectricHippo Active Member

    Ok, I did like you said, and the 2.1 root update went in ok. It bootlooped for a while before it came up, but eventually I was in.

    I downloaded ROM Mgr., flashed ClockworkMod Recovery, and that seemed to work.

    Then I downloaded Cyanogen 6.0.0 RC1 off a direct link in this forum, and copied it to the sd card.

    I rebooted into clockwork recovery.

    I hit wipe data/factory rest 3x

    I hit wipe cache 3x

    I hit install zip from sd card, selected the zip file, and it did it's thing, 'Welcome to Cyanogen 6.0.0 RC1 etc', and then it finished.

    I selected reboot, and it did, but now it's hung on the Motorola M. Not bootlooping like before, just stuck. Solid M, and it's been like this for about 10 mins. I didn't want to jump the gun because i've seen guides say that the first boot can take a while, but how long should I wait? Should I reboot, or wipe/install again?

    thanks for all your help
  25. nstallion

    nstallion Well-Known Member

    When you first boot it might sit at the boot animation for a while, but not the M.

    I'd do it over. This time format boot as well. If you go into the advanced partitions menu there are more options and you can format boot, system, data, and cache individually (and sd card or sd-ext as well but you shouldn't do that).
Loading...

Share This Page