Battery Meter Showing a Question MarkSupport


Last Updated:

  1. MikeTyson

    MikeTyson Active Member This Topic's Starter

    Joined:
    Nov 24, 2009
    Messages:
    25
    Likes Received:
    2
    Friend of mine said he activated a Droid today, brand new, and the battery meter is showing a "?".... No meter just the empty battery meter with a question mark inside of it...

    Anyone have that issue or ever heard such a thing?:confused:
     

    Advertisement
  2. Athos

    Athos Member

    Joined:
    Feb 19, 2010
    Messages:
    11
    Likes Received:
    10
    After a bit of searching i came across this on motorola's support forum.

    Sounds like the problem. Other things I came across were cleaning the battery contacts and double checking the seating of the battery.
     
  3. Metacom

    Metacom Member

    Joined:
    Jun 6, 2010
    Messages:
    10
    Likes Received:
    0
    I had the same problem. I just removed the battery, and put it back in. All seems to be working now. Hopefully that solved it!
     
  4. G.Armour

    G.Armour You know you want to. VIP Member

    Joined:
    Jan 11, 2010
    Messages:
    4,534
    Likes Received:
    306
    That's interesting, never had it happen to me but will store it, that way if it happens, I'll know how to fix it..
     
  5. Tyrial_hannah

    Tyrial_hannah New Member

    Joined:
    Oct 3, 2011
    Messages:
    1
    Likes Received:
    0
    i had the same issue, read all the forums and tried everything. finally i put the battery only in the freezer away from water(lithium reacts with water) and waited 5 to ten minutes and then put the battery back in and plugged it in, pushed power on, and instant start up with 5% battery life already. try this and let me know the results. Thanks ahead for feedback. :D
     
  6. nloomans

    nloomans New Member

    Joined:
    May 17, 2014
    Messages:
    1
    Likes Received:
    0
    But... my phone got a non removable battery!

    (my phone is a moto g)
     

Share This Page

Loading...