Battery saving tip - really works!Tips


Last Updated: 2012-06-27 01:03:33
  1. matttye

    matttye Well-Known Member

    I noticed that my "Android OS" was keeping my phone awake for like 4 hours in a 16 hour period. I have BetterBatteryStats installed and checked the kernel wakelocks. I was getting a "wlan_rx_wake" wakelock which was causing 92% of my kernel wake locks.

    After some googling, it turns out that this is related to the phone responding to wireless router DHCP queries, and the simple way to resolve it is to assign a static IP address to your phone. Luckily my router allows me to use static IPs in conjunction with DHCP, so I didn't have to reconfigure every device on my network.

    The stay awake time now is less than half an hour for Android OS and it's only using 6% battery, when it was using like 20+% before. It's a very noticeable difference for such an easy change!

    ---

    Now I just want to figure out how to stop cell standby using so much battery! It's currently using 2% less battery than the screen which has been on for two hours. That's insane :( I suspect we'll have to root and install a custom radio or wait until Samsung pulls their finger out!

    Advertisement
    phlojo, pdl2mtl90, Covart and 2 others like this.
  2. wunderchar

    wunderchar Member

    I can't believe how much battery cell standby takes up either! I understand the screen taking up a lot of my battery usage but standby.... Grrrr
  3. ScoobyWRX

    ScoobyWRX Well-Known Member

    Matttye, could you explain, in simpleton terms :confused:, how I set this up please :)
  4. XplosiV

    XplosiV Master X is Watching You VIP Member

    Get yourself the Nfc programming app and some NFC stickers and program a sticker for a night mode where you can turn off all non essential functions like mobile data, bluetooth, wifi, ringtone etc with one quick swype of your phone over the sticker. ;)
  5. XplosiV

    XplosiV Master X is Watching You VIP Member

    You have two options at least.

    One: see if your router supports 'ip reservations' this means DHCP will assign each device on your network the same in each time it connects. Ie if you assign your S3 the ip 192.168.2.10 then your S3 will be assigned that ip by DHCP every time it connects to your network.

    Two: more hassle, but disable DHCP in your router and manually assign a static ip for each device on your network, then on each device you have to set up the same static ip as set in the router. So its a tad more complicated and time consuming.
    Shogun1 and ScoobyWRX like this.
  6. Deisenaut

    Deisenaut Member

    You don't have to do this - you can change the DHCP range - ie. From 192 168 0 2 to 192 168 0 100 and then you can use any ip address from 101 to 253 for your static assignments
  7. rlb4

    rlb4 Well-Known Member

    How can we find out if our router supports this? I have a D-Link DIR-655.
  8. SUroot

    SUroot Well-Known Member Developer

    Ip reservations and static aren't the same necessarily. My netgear does both. Reservations are still dhcp. When that mac requests an ip via dhcp, it gets a reserved, pre specified ip. Dhcp is still used so power wouldn't be saved
    davoid likes this.
  9. XplosiV

    XplosiV Master X is Watching You VIP Member

    I'm sorry, I'm not really understanding what point your trying to make here.

    Yes you will have an ip range regardless if your using DHCP or not.

    Why have a bigger ip range than needed? My range is set for each device that needs one, plus 2 spare with old macs, that I just edit as needed for guests.

    The op stated the need to assign a static ip, typically set via disabling DHPC within the router & assigning each network device an. Then you have to set up each device individually to use the ip you set in the router.

    I think the op was meaning reserved ips when he stated he had set a static ip in conjunction with DHCP.
  10. matttye

    matttye Well-Known Member

    My battery life has improved since manually assigning the IP in my Asus. I think it supports DHCP and static IPs alongside each other.
  11. SUroot

    SUroot Well-Known Member Developer

    Yes they all should.
  12. Covart

    Covart Well-Known Member

    I hadn't manually checked this before, but it appears my Cisco Linksys E3200 router auto assigns static IP addresses ranging from 192....100 to 150. Guess that's why I never had a battery issue.

    Good info to know though. Much thanks OP.
  13. d4v3cl4rk

    d4v3cl4rk Member

    Doesnt puttin your phone in flight mode stop all the above?
  14. XplosiV

    XplosiV Master X is Watching You VIP Member

    This should be true, however in flight mode you also won't be able to receive calls or texts.

    A simpler option would be to just turn off wifi. But some people like to keep it on while at work and home, for which this topic may be more relivent.
  15. tnedator

    tnedator Well-Known Member

    On my Atrix, turning WiFi off dramatically reduces my battery life. More specifically, it isn't just turning off WiFi, but instead if the phone is connected to WiFi vs. using 3G data, the battery life is about 50% longer.

    My phone is hitting an exchange account, two Gmail accounts set to push/sync and 3 IMAP Idle accounts setup in K9 mail, so in essence I have 6 push email accounts setup.

    I bring that up, because at least with the Atrix, using WiFi doesn't just give you a faster connection or save your wireless data usage, but can dramatically improve your battery life.
  16. XplosiV

    XplosiV Master X is Watching You VIP Member

    Using ANY extra data components will drain your battery, be it wifi, bluetooth, gps, mobile data.

    So turning anything off that your not needing especially at night, will help your battery life, that, is not in question.

    The op simply stated that there was an issue with wifi draining the battery because it was constantly polling local networks, and thus the fix was to manually assign an ip from his router for his S3.
  17. tnedator

    tnedator Well-Known Member

    You misunderstand my point.

    Option A: Using mobile (3G) data turned on (WiFi off) to update the 6 push email accounts.

    Option B: Using Wifi (Wifi on) to update the 6 push email accounts.

    Battery life with option B is about 50% longer than option A. That isn't turning something "off" it's turning something "on."

    I was responding to your comment about turning off WiFi and letting people know that in some cases, turning off WiFi, but still using mobile data, will result in significantly lower battery life.
  18. surf1

    surf1 Well-Known Member

    I have the DIR-655 too, and read on dlink that it supports DHCP Static. However still lost on what we're supposed to do in this thread lol?

    If I go to my Dlink IP, it shows 3 devices connected, and my phone ends in .194, computer .196, and printer .193
  19. tnedator

    tnedator Well-Known Member

    Based on what the OP posted, using "DHCP Static" would have the same battery problem as DHCP. DHCP Static is not the same as setting a static IP on the phone (or other device). Instead, it's simply setting up a permanent DHCP lease on the router. Meaning, the device still looks to the router as the DHCP server to assign it an IP (the device is setup for DHCP). However, any time the device needs to be assigned an IP (every time it connects to the router or when a lease expires), the router gives it the same IP.

    This is an alternative to using a true static IP, but it is still a DHCP IP and behaves as a DHCP IP in all ways.

    So, if there truly is a battery hit for using DHCP, you will see the same battery hit using DHCP static.
  20. matttye

    matttye Well-Known Member

    From what I gather it's about renewing the DHCP lease that causes the wakelock, so a permanent lease would probably do the trick too.

    Worth a shot anyway.

    My Android OS went from using about 30+% to 5% ish simply by assigning a static IP. Cell standby is the biggest battery hog by far now for me. :(
  21. XplosiV

    XplosiV Master X is Watching You VIP Member

    Ah, now that's totally understandable, I would imagine that the data transfer rate over wifi is higher thus more economical on power than using 3G. Wouldn't surprise me.

    @op glad you found a fix that works for you, I wonder if this is because of other wifi signals in your local area.
  22. matttye

    matttye Well-Known Member

    I used wifi analyser and picked a channel unused by my neighbours. Doesn't seem to have had an effect on battery life but the signal is better.
  23. XplosiV

    XplosiV Master X is Watching You VIP Member

    Yea getting a free channel is great for overall wifi speed as data doesn't clash as much.
  24. tnedator

    tnedator Well-Known Member

    That's not the way DHCP works. If the phone is responding to DHCP queries from the router, as you suspect, that would happen whether or not it was a permanent/static DHCP lease. It's not like the normal lease is 60 seconds or something, they are probably at minimum 24 hours (probably longer).

    So, if DHCP is the problem you described, then the ONLY solution would be to change the phone from DHCP and enter an IP address manually.
    matttye likes this.
  25. tnedator

    tnedator Well-Known Member

    That's my conclusion as well. I brought it up only because I think many people have the mistaken belief that having WiFi turned on burns more battery. While it probably does in some situations, such as if you aren't actually using data, there are situations like mine where activating wifi makes a huge, positive difference in battery life.

Share This Page