Battery Statistics: com.motorola.weather ???Support


Last Updated:

  1. mxsjw

    mxsjw Well-Known Member This Topic's Starter

    Joined:
    Jul 7, 2010
    Messages:
    1,311
    Likes Received:
    171
    Phone has been on for 6 hours and com.motorola.weather says it's used 23% of my battery. I'm only using BW configured to refresh once an hour with accuweather. Why is the stock weather even working?
    HAAAAAALP!!! please:D
     

    Advertisement
  2. jdk33

    jdk33 Well-Known Member

    Joined:
    Jul 16, 2010
    Messages:
    211
    Likes Received:
    37
    That service is an update service for the Motorola weather widget, it's completely separate from BW. It runs on boot whether you use the Motorola weather widget or not. If you're rooted, I would disable it. If not, just open battery manager, click on com.motorola.weather, and click force stop in the dialog that is displayed. That'll fix it until you reboot.
     
  3. mxsjw

    mxsjw Well-Known Member This Topic's Starter

    Joined:
    Jul 7, 2010
    Messages:
    1,311
    Likes Received:
    171
    Thanks, I stopped it, but it automatically restarted it's self...

    I don't remember it doing this before 2.2 Froyo. There has to be a way to shut it down or make it go to back ground and not update besides root...right?

    Something with the GPS settings?
     
  4. mxsjw

    mxsjw Well-Known Member This Topic's Starter

    Joined:
    Jul 7, 2010
    Messages:
    1,311
    Likes Received:
    171
    Ok, so I haven't changed any settings, did a full discharge, battery pull, and recharge and I'm not having the issue today. :D, but weird?
     
  5. jdk33

    jdk33 Well-Known Member

    Joined:
    Jul 16, 2010
    Messages:
    211
    Likes Received:
    37
    I guess it's possible it was a GPS related problem. I'm pretty sure the Moto weather service uses GeoLocation.
     
  6. mxsjw

    mxsjw Well-Known Member This Topic's Starter

    Joined:
    Jul 7, 2010
    Messages:
    1,311
    Likes Received:
    171
    Oops, you just reminded me...I turned on GeoLocation last night (it was off all day yesterday, just had the other 2 GPS options on)...I'm betting that is what fixed it.
     

Share This Page

Loading...