batterySupport


Last Updated:

  1. northernale1

    northernale1 Well-Known Member This Topic's Starter

    Joined:
    Jul 24, 2010
    Messages:
    328
    Likes Received:
    27
    ok this morning as i was using the x10 to web surf with wifi and plugged into wall charger,, the battery level was decreasing, i find this unusual as my old iphone3g would charge while usung it plugged in,,,

    is this normal for the x10???
     

    Advertisement
  2. MrWomble

    MrWomble Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    774
    Likes Received:
    51
    The X10 naturally decharges when plugged in

    Once it hits 100% it is known to switch off the charge and use battery power rather than mains, some have reported anything from 75% upover till it recharges again

    So depending on what levels it was at when you noticed it, yes it can be normal
     
  3. northernale1

    northernale1 Well-Known Member This Topic's Starter

    Joined:
    Jul 24, 2010
    Messages:
    328
    Likes Received:
    27
    was at 83% when I plugged it in,, down to 72% and green light in corner was on whole time,, and also was the charging icon,, but they may just be on when ever plugged in,,,
     
  4. CuBz

    CuBz Well-Known Member

    Joined:
    Sep 21, 2010
    Messages:
    1,654
    Likes Received:
    230
    I experienced something similar, but my battery had died, so I plugged the charger in and left it for 5 minutes before I used it, then when I tried using it, the battery died again, even tho the charger was plugged in
     

Share This Page

Loading...