BB 7.9...wifi connects, but no internet access!


Last Updated:

  1. Redflea

    Redflea Well-Known Member This Topic's Starter

    Joined:
    Oct 6, 2009
    Messages:
    2,623
    Likes Received:
    289
    I'm having an odd issue w/Pete's BB 7.9...

    I am able connect via WiFi to home network just fine - connects quickly and I get a proper IP.

    However, nothing will connect - email, browser, marketplace, etc...

    Everything works fine from my laptop on the same wireless network. Never had any issue w/any guest laptops at my home on the network. I don't have mac address filtering or any other settings like that...am using wpa.

    Any ideas? Never seen this happen before...previously I've used my phone on wifi from home it worked, but that's been quite a while, can't remember when/which ROM.

    Again - I connect fine to my wireless network, get an IP, but when I try to access anything from my phone it acts like I'm not connected. Go back to 3G and all is fine. Tried going back and forth between wifi and 3g, and it behaves the same way each time...appreciate any help.

    <EDIT>

    Now it's working...weird. Didn't change any setting. I was trying another ROM (that wouldn't even boot for me - Chevy has a new 2.1 w/working auto-brightness, mute, keyboard lock) and after flashing back to 7.9 now wifi is working.

    I hate it when stuff fixes itself and I don't know why...oh well, glass half-full and all that.
     

    Advertisement
  2. SeaGrizzly

    SeaGrizzly Well-Known Member

    Joined:
    Jun 14, 2010
    Messages:
    46
    Likes Received:
    0
    Red I am having this same issue and I have updated radio, rom's all kinds of crazy things and still no luck what so ever getting on any wireless networks. I have to put in static IP's all the time to get them to work.
     
  3. katndog

    katndog New Member

    Joined:
    Aug 10, 2010
    Messages:
    3
    Likes Received:
    0
    I too am havi.g this issue. My husband who has an X too, he can accesss everything that i cannot.
     
  4. shrink57

    shrink57 Well-Known Member

    Joined:
    Dec 19, 2009
    Messages:
    1,529
    Likes Received:
    149
    Still cannot connect to my WIFI (Belkin N) with any 2.2 ROM (tried every combination of ROM / Kernel / Security settings you can imagine). This is with 3 different Droid phones (gave my Droid "throw against the wall therapy" and was able to get a free replacement). All the 2.1 ROMs run fine. From the research I have conducted this seems to be a problems specific to certain routers and Froyo. I guess it will be 2.1 until I spring for a Droid X or I switch routers (or both).
     
  5. javaman70

    javaman70 Member

    Joined:
    Aug 1, 2010
    Messages:
    14
    Likes Received:
    3
    I am running BB 0.4 froyo with belkin wireless n router. With no problems since Install.
     
  6. dmodert66

    dmodert66 Well-Known Member

    Joined:
    Oct 24, 2009
    Messages:
    1,553
    Likes Received:
    221
    @ Redflea, just out of curiosity, why are you running BB 7.9?
     

Share This Page

Loading...