Behold 2 w/ Galaxy ROM USB Issues

Discussion in 'Android Devices' started by MinisterPhobia, Feb 25, 2010.

  1. MinisterPhobia

    MinisterPhobia Active Member
    16

    Feb 25, 2010
    34
    3
    16
    A few weeks ago, a friend and I went through the process of making my Behold 2 think it's a Galaxy (thanks to all who made that possible!). Now, after having played with it for a while and the lack of vibration annoying me, I've decided to try to use Odin to revert to the standard Behold 2 ROM.

    This is where my problem comes in: I am unable to get any USB Driver for the phone to work. In USB Debugging, out of debug, in download, or any other way I can think of. The phone just doesn't seem to want to connect. When not in USB debugging mode, I can get my computer to recognize the SD card and access files, and it'll charge, but, I can't get any other USB functions to work.

    I'm not sure if this is a driver issue or if this is an issue with the phone itself.

    I'm running Windows 7 Pro 64bit.

    Could someone walk me through troubleshooting this?
     

    Advertisement
  2. hnrclothing

    hnrclothing Active Member
    15

    Feb 23, 2010
    44
    0
    15
    The only way my computer will see the phone in those modes is when I reboot I press f8 then turn sign drivers off. I have downloaded every driver that was recommended for W7 and still didnt work until I did this. I am a noob, and dont know too much, but this is how I got around it. Hope its that easy for you.
     
  3. MinisterPhobia

    MinisterPhobia Active Member
    16

    Feb 25, 2010
    34
    3
    16
    Nope, doesn't work. I just tried it and the drivers do not install. The computer seems to recognize the phone, but, the drivers fail to install.
     
  4. BH_MAN

    BH_MAN Well-Known Member
    313

    Feb 17, 2010
    1,381
    1,667
    313
    I had to Manually install the Driver's via Device Management in windows 7 for mine to work. Hope that helps.
     
  5. hnrclothing

    hnrclothing Active Member
    15

    Feb 23, 2010
    44
    0
    15
    I had to do the same thing, forgot about that.
     
  6. MinisterPhobia

    MinisterPhobia Active Member
    16

    Feb 25, 2010
    34
    3
    16
    Didn't work for me. There's a couple of "Unknown Devices" in my device manager that I can't seem to get any drivers installed for.
     
  7. hnrclothing

    hnrclothing Active Member
    15

    Feb 23, 2010
    44
    0
    15
    Did you right click them, go to properties, I think advance properties, update driver/ driver details (or something in that area, I dont have my laptop).

    You have to path the driver to where the drivers folder is located to allow it to find them.
     
  8. spiz

    spiz Well-Known Member
    93

    Feb 14, 2010
    920
    128
    93
    Redmond, OR
    I had the same problem, same operating system.

    I ended up using this:
    MEGAUPLOAD - The leading online storage and file delivery service

    It will make your computer think your phone is a galaxy, and everything will work just fine. Give it a try and let us know.
     

Share This Page

Loading...