Bell Galaxy Dead


  1. accentchick

    accentchick Member

    I am sooo hoping that this thread isn't dead yet. I made the mistake of trying to upgrade from 1.5 to 1.6 without reading all the instructions first. I flashed it with odin and 1.6 (russian one) and didn't read the part where it said not to do the phone section . So now my bell phone will not recognize any sim cards. I have searched high and low for the original firmware but every torrent I find has no seeds. I'm begging someone to pleaseeeee post a working link for the 1.5 original bell canada firmware.

    Advertisement
  2. yabbadoo

    yabbadoo Member

  3. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    Alright, so after a couple PM exchanges, here goes the small tutorial (and files) I promised you:

    Start by downloading this file. Take the RECTOOLS.tar.gz file in the "put_on_internal-SD" and place it on the root of your SD card. (Plug your phone via USB, select transfer files and then place it in the top folder of your phone, not in a subfolder).

    Then, use Odin to flash some of the files in the firmware folder of what you downloaded. (You need to be in download mode, you should know how).

    Do it exactly like on this picture:

    [​IMG]

    You should now have 1.6 with a custom recovery. (If it starts to work, stop here. :p).

    Power off your phone, start into recovery mode (do so by holding the “Lower volume button”, the Call button and then power button, all three at the same time but in that order).

    You should see a green menu with lots of options. Select Nandroid backup, wait for a while.

    Next, select "Mount SD(s) on PC", and cut the nandroid folder on your SD card and store it safely somewhere else on your computer. It shouldn't be on your phone anymore. Download this folder instead (a backup I just did). Extract the nandroid.zip (it should become a nandroid folder) and place it on your phone.

    On your phone, select "Unmount SD(s) from PC", then select "Restore latest backup", select SLOT4, press the home button to confirm and then cross your fingers.

    Keep me posted.
  4. accentchick

    accentchick Member

    so right down to the last step everything went good. Then I hit home button to confirm but it just went back to green option screen? Should it reboot automatically or say something to sey restored successfully?? When I hit reboot system now it still comes up with the lock screen which I can hit dismiss and get into my phone and everything is the same.. hmmm advice?
  5. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    Are you sure you pressed the "Home" button? It's the small oval button between the "Back" button and the button you must hold to power on the device. You should try again to be sure.

    If that doesn't work, tell me exactly what files/folders are in the nandroid folder on your phone please.

    I'm surprised it didn't work.
  6. accentchick

    accentchick Member

    lol duh! I was hitting the ok button not the home button. So got it to do previous backup, restarted the phone and still coming up with the lock screen and not recognizing bell network :( Also in the nandroid folder on my actual phone is the following:
    a subfolder called "mem=109m"
    in that folder is a folder called " slot4-cbdmrs12-19800720-1814
    then in that folder are the following files:
    boot,data,dbdata,nandroid.md5, recovery, system and userdata"
    Should I eliminate the subfolders and move all files just to the main nandroid folder??
    Here are pics of what its doing:

    [​IMG]
    [​IMG]
  7. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    Don't change a thing about the backup, it worked fine and the folders are OK.

    You should power off your phone, remove the back cover, remove the SIM card and reinsert it according to the small diagram, with the golden stripes touching the golden part of your phone. Make sure you insert it back correctly (it happened to me before). I doubt that will solve anything, but it might be worth trying.

    Alright, at this point you really should find someone you know with a Bell phone and a SIM card. Try using your card in their phone, but more importantly their card in your phone to see if the problem is the SIM card and not the phone.

    If there's no one willing to do that (they should be willing to help you, there are no charges, no risks, etc.), you can always go to a Bell store and tell the rep just that: you want to check if the SIM card is the problem or if it's the phone.

    I had the exact same issue happen to me: it asked for an unlock code. I thought it was my fault, and I ended up paying to unlock my phone and get the code. Of course it didn't work: it turned out to be a defective SIM card. They exchanged it free of charge and I was all set.

    PS: I did place my SIM card in my Galaxy to see if the Nandroid backup I gave you worked: it did, I had perfect reception.
  8. accentchick

    accentchick Member

    k so i tried taking out the card and putting it back in...didn't change
    I have two other Bell phones so i tried both sim cards....didn't work

    any other suggestions besides throwing it under a moving bus lol
  9. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    I tried to contact someone that was active a year ago here on the forum that also had a Bell I7500L, and he connected to the forums two days ago so he seems to be active. Let's see if he still has the firmware somewhere on his computer (which is unlikely but worth trying).

    Meanwhile, your best bet would be to find any kind of Brazilian firmware for our phone, since it would also work on your phone and you would probably get the signal back (don't worry, there's English language in the options ;)).

    I haven't really looked, but you might want to dig around here, there was a thread for i7500L users and I think Brazilians had that version too.

    I figured out why my Nandroid backup didn't work: what you need right now is the AMSS part of the firmware, which isn't included in a nandroid backup. Odin really is the only option.
    accentchick likes this.
  10. Lelouch

    Lelouch Well-Known Member

    AMSS is the part responsible for baseband. And you did a mistake by flashing European baseband; I think that North and South America has different GSM working range.
    You will need ODIN and official Samsung firmware for I7500L.

    Here is some link for you Brazillian
    Hope that it helps. Maybe DaSchmarotzer can help you further.
    accentchick and DaSchmarotzer like this.
  11. accentchick

    accentchick Member

    ITS ALIVE!!!!!! So I finally found the Brazilian firmware that works on Bell Canada ( i just googled the file name from the link posted above and hoped for no viruses lol). It works but is back on 1.5, but you know what? I don't care!. I'm selling it, i got me a Galaxy S II :) Thanks to everyone who helped out and if anyone needs the files in the future i will be keeping them ALL so get in touch me and I can provide them so no more bricks lol.

    Thanks again guys :) :)
  12. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    Great, I'm glad you got it sorted out. ;)
  13. Lelouch

    Lelouch Well-Known Member

    Yep, cause it's official Brazilian made firmware by Samsung.

    Cause you already got SGS2, now you can try again to flash/install custom Recovery and ROM. Use the guides found in this part of the forum (or ask questions if not sure).
    I'm sure that it will help you in the "near" future when Samsung drops official support for it. So you could flash future custom ROM based on future Android releases (most known custom ROM is CyanogenMod or based on it). This experience will really help you in the future (why be bound to only official firmware, cause community has even more to offer?).

    P.s: that is just my humble opinion (I'm glad I helped in some way) :cool:
  14. coquitlambc

    coquitlambc New Member

    How come I have no luck like you? Now I have the same problem as yours. I tried the Brazilian firmware, but the phone began to ask me "Service Provider Control Key" instead of "SIM Network PIN Code" and still cannot connect to any mobile network by pressing "Dismiss". Can anybody help me?

Share This Page