Big problem when flashing insecure kernel


Last Updated:

  1. Hi, I think I have buggered up my phone.
    I recently updated the firmware on my s2, it was rooted before the update.
    I like to have it rooted to block air push adds and use sd maid. I followed the same process as before to root my phone: I flashed an insecure kernel using odin which said it was successful with the intention of using s2 root. I then waited for the phone to reboot but it wont leave the loading screen. I have no idea how to fix this. As I say, I dont really know much about it all, i just like to have it rooted for certain things. I dont bother with custom roms and what have you.
    If anyone could help me out that would be great, otherwise I'll have to chuck the damn thing.
    I am on three network in the uk.
    Thanks for any help anyone can give me

    Advertisement
  2. ironass

    ironass Well-Known Member

    Hello and welcome to Android Forums dizzyandwasted! :)

    You haven't by any chance flashed an insecure, CF-Root, Gingerbread kernel to an ICS ROM have you?
    dizzyandwasted likes this.
  3. Thank you, it's nice to be here Ironass
    I am really not sure....I downloaded the kernel from xda. It was GT-I9100_XWLA4_insecure (similar to the one i used before the firmware update) which seemed to flash alright on Odin but then it wouldn't boot. After that didnt work I tried to flash a CF one - CF-Root-SGS2_XW_XEN_LP7-v5.4-CWM5.tar
    Is there a way for me to fix it?
    If it is going to be very complicated (I dont want to annoy anyone 'cos I really have no idea what I'm doing) Is there a way to factory reboot it..I did back my phone up on my pc with kies before I updated
  4. ironass

    ironass Well-Known Member

    That is a Gingerbread kernel and would not work on an ICS ROM.

    That is an ICS insecure kernel but it depends on what your original ICS kernel was before you started rooting.

    Can you tell me what ICS firmware you are currently on. Type in *#1234# on your dial pad and give me the first 3 lines of information please.

    EDIT If, as you say, you cannot get past the boot screen... can you remember what firmware you updated to?

    You're lucky day then dizzyandwasted, I'm in one of my, rare, good moods! :)

    As you already know how to root... it's only a question of finding the right kernel for you.
    hippityhop likes this.
  5. I'm glad I caught you on a good day :)
    So we need to figure out which kernel I need. I'm afraid I can't get the phone to boot to access the dial pad and get the ics firmware info. If it helps I only updated yesterday so it will be very current.
    When I looked at the info in about phone I think it was XWLP and then 4.0.6 something. Why didn't I just bloody write it down.

    in so far as i can tell the last update released for three in the uk was april and it was: United Kingdom (Three) H3G - I9100XWLP7/I9100H3GLP3/I9100NELP3 Android 4.0.3 Ice Cream Sandwich
  6. ironass

    ironass Well-Known Member

    XWLP? doesn't narrow it down too much I'm afraid. I doubt that it said 4.0.6 as 4.0.3 is the latest stock firmware for the Galaxy S2, GT-i9100.

    I'm beginning to think that flashing a whole new ICS firmware might be the answer to your problem. It's very simple and easy to do... particularly as you have Kies and Odin already installed.

    Can I just check your model number please... as I've been caught out on this before. Have you got the Samsung Galaxy S2, GT-i9100 model and no other variant?

    OK... that helps me... hang on.
  7. I think its XWLP7 4.0.3.
    Yep and it's definitely a Samsung GT-i9100 :)
    Whatever you say is best I will do. I am just pleased that there's a chance I haven't bricked it. I think in future I will leave well enough alone
  8. ironass

    ironass Well-Known Member

    Rather than messing around with kernels I'm suggesting that you flash the ICS firmware for H3G, ICS, again, using Odin.

    This will take you back to the moment you were updated and you will not be rooted. We can deal with that later.

    So, I suggest downloading the H3G firmware, here.

    Then flash it using Odin and the instructions, here. Ignore the firmware that is suggested in their instructions and use the one I gave you.

    This, "should", not wipe your phone but, as with any updating, it might. However, you have your information backed up with Kies and, I hope, with Google.

    Are you OK to do this?
    Calum1 and dizzyandwasted like this.
  9. Right, excellent that sounds like something I could manage.
    Yea I'm not too fussed if my phone gets wiped as I am backed up with Google and Kies :)
    I shall get on with that and I'll let you know how I get on. Might be tomorrow though as I have to get to work soon.
    Thanks for all your help, really!
    Rhian
  10. ironass

    ironass Well-Known Member

    In the words of the immortal Del Boy in Only Fools and Horses... "He who dares Rodney... he who dares!".

    That's the spirit dizzyandwasted.

    It takes about an hour to download the file anyway.

    No problems. If you get stuck or are unsure... DON'T PANIC! just come on here and I'm sure that one of us can help.

    Good luck!
  11. ZR160_MAJ

    ZR160_MAJ Well-Known Member

    Now from a womans point of view....Do you think men are REALLY bad? lol

    Hope your phone gets well soon

    Maj
  12. Calum1

    Calum1 New Member

    hey

    the exact same thing happened to me (followed and out of date CNET guide on how to root, used a gingerbread kernel on an ICS version, phone wouldnt boot past load screen)

    i followed ironass' instructions and it worked perfect, phone working exactly as it was before. massive thanks to ironass!

    could anyone point me in the direction of an insecure kernel I can use to root my ICS 4.0.3? (GT-i9100)
  13. Calum1

    Calum1 New Member

  14. ironass

    ironass Well-Known Member

  15. Calum1

    Calum1 New Member

    Hmm... following the instructions but when Im in Odin

    ID:COM doesnt turn yellow when im in download mode and the phone is connected via USB.

    Tried waiting 20 mins. and still nothing.
  16. Hawker

    Hawker Well-Known Member

    Make sure you have installed Kies, and also make sure you are not using Kies before opening Odin.
  17. Calum1

    Calum1 New Member

    Got the problem fixed and phone is now rooted :D

    I had kies installed but after id followed ironass' guide for some reason my computer wouldnt comminicate with my phone through kies anymore so I had to reinstall the drivers (which was simply done by the troubleshooting feature in kies)

    I also changed USB port which may have helped but I doubt it.

    Since I stumbled across this post by googling, it might be worth explaining how I rooted my phone incase Calum2 ends up here through google with the same problem (im new to this today).

    After I had followed ironass' instructions to get my phone back to ICS and working, I then googled this:

    how to root gt i9000 XWLP7

    Replace XWLP7 with the kernel that your phone displays in About

    Here is the site I used to root:

    Android AdvicesHow to Root Galaxy S2 I9100 on XWLP7 ICS 4.0.3 Firmware
  18. brayyo

    brayyo Member

    Hello, i have the same problem i also followed the out of date cnet guide to root my ssgs2 and installed a gingerbread kernel when i have ICS on my phone using odin. but for the life of me i can not get it to boot back up i followed your advice Ironass but i could not install the kernel H3G, in odin it kept saying failed(red) in the top left box, but when i installed the Gingerbread Kernal it was successful(green). so my problem at the moment is that odin will not install the kernal you suggested. i am very worried that i have lost my SSGS2 if anyone can help i will be extremaly grateful?

    Thanks for your help.
  19. jakecompton

    jakecompton New Member

    @ironass i need help also i got lg viper 4g lte and on odin its not yellow. and the kernel thing i type the password in and nothing happens? what do i do? i downloaded kies but idk? my kernel vrs on phone is 2.6.35.11 -perflge@android-buld#1

    im just trying to root my phone with android-root.org thing. im confused as hell

Share This Page