Black screen of death.Support


Last Updated:

  1. mustfly

    mustfly Member

    Just curious if anyone else has seen this: Your S2 is on all day,...just kind of hanging out in "idle mode"...leave for a while and then come back to it (knowing the battery is full) and the screen is black, the phone unresponsive. Not sure what the deal is. I initially thought I'd perhaps left a battery draining app on (GPS or Bluetooth, etc) but that was not the case. I plugged the charger in and the phone beeped when it recognized the charger had been inserted...but nothing on the screen...no battery charging icon. Nuttin. In each case, I've had to remove the battery and re-insert and then it comes back to life just fine...and shows what I suspected...a FULL battery charge. This seems to happen very randomly, ex...phone was on and fine,...went to do my workout...came back an hour later....unresponsive phone. Just curious. Thanks for any pointers.

    Advertisement
  2. marik69

    marik69 New Member

    Installing darkyrom solve the problem for me.
  3. mustfly

    mustfly Member

    my phone is not rooted.
  4. DemoniWaari

    DemoniWaari Member

    Hello there. I'm having this rather annoying problem. I tried to install newest firmware via kies aaaand it didn't go anywhere plaaplaa I had to boot the phone, and now it wont boot. It just gives me the black screen of death.

    So I tried to use kies' recovery -> stucks at 1% every single time.
    Tried to do hard reset, did nothing.
    Tried to flash ICS with odin and it gets stuck on various places. Like sbl.bin, or setupconnection or right now it's stuck on factoryfs.img
    Tried to flash stock rom with odin, same thing happens.

    So got any more ideas what to try before I throw this garbage out of the window?

    EDIT: Awesome, just got the kies recovery to 8%! And then it stopped. Seriously, this is like tenth time I've had to fight for hours to get my upgrades working.

    EDIT2: Now odin gives me:
    <ID:0/003> NAND Write Start!!
    <ID:0/003> Transmission Complete..
    <ID:0/003> Now Writing.. Please wait about 2 minutes
    <ID:0/003>
    <ID:0/003> Receive Response form LOKE
    <ID:0/003> Complete(Write) operation failed.
    Sigh...
  5. jeremy_inc

    jeremy_inc Well-Known Member

    I only ever had this problem when I used a different kernel, which it doesn't sound like you have.
    What Android version is your phone on?
  6. iT0mm0

    iT0mm0 Well-Known Member

    take out the battery, hold power and home buttons for 10 seconds, put battery back in and reboot <--- soft reset
  7. GalaxyS2

    GalaxyS2 Well-Known Member

    My phone did this for the first time yesterday. I've had my phone since launch week (about 9 month) it is rooted but not made any changes to it lately.
  8. Cribology

    Cribology New Member

    Just had this happen on my phone
  9. simes6600

    simes6600 Well-Known Member

    sounds like the infamous sleep of death (SOD), which i used to get now and again on stock firmware. since flashing checkrom i only got it once, and it was kernel related.
  10. suchita

    suchita New Member

    Same here, black screen, but I can receive calls and touch works. My phone is rooted. Happens randomly not very often for now and the only fix is taking out the battery. Should I be worried?
  11. HammieL

    HammieL Member

    Happens to me VERY OFTEN. VERY ANNOYING. I'll be using my phone just fine, then after letting it sit for a min, it wont turn back on unless I remove the battery. Pissing me off!
  12. HammieL

    HammieL Member

    Very similar problem, but my phone refuses to connect through USB and just locks up every time I try to access the files or add music, etc. Love my GS2, but this is very frustrating.
  13. Atma

    Atma Well-Known Member

    I've merged these 2 Black Screen of Death threads. If the posts seem a little wonky that's why. :)

Share This Page