blank external sd cardSupport


Last Updated: 2011-04-03 20:12:58
  1. k2caliguy

    k2caliguy Member

    Hi, I dropped my phone last week, and replaced the screen this week. However, yesterday my phone stopped reading the sd card. It recognizes when I remove it. I try to format the sd card but software doesn't do anything. in the settings i got to sd card and the format box is grayed out. and lists total space "unavailable" and available space "unavailable."

    any other ways for format it, or get it to work. I'm trying to working to find another device to read the micro sd card, see if the card is now bad. the phones hardware I believe works because its recognizes when i physical remove the card and put it in.

    would a factory restart fix this? I hate to lose all my apps and settings on the phone...

    Advertisement
  2. Martin88

    Martin88 New Member

    I have exactly the same problem. I did a factory reset though and that didn't fix it.

    Have tried two 4gb SD card's and it still says its unavailable. One minute it was working, then suddenly it wasn't.

    The only thing I can think is that I connected my phone to a PC between it working and not working.

    I've tried formatting the card with the format tool in Windows too, but nothings worked so far...
  3. f@scin8

    f@scin8 Active Member

    Recognizing when a card is placed or removed from the phone is electrical. It doesn't mean the software can recognize the card as being an SD card. Before formatting the card it has to be able to at least read from the device. Formatting will write to it.

    I bought a brand new 32GB SD card and formatting was not necessary. I believe most come formatted FAT32.

    Did you unmount the SD card before removing it? I don't remember if you have to mount it manually or not when you put a card back in. But you should unmount the card before removing.

    Mount/unmount is in Settings and SD card. With the SD card mounted, "format" is grayed out. This makes sense because storage devices have to be formatted with a filesystem before being mounted. Try unmounting and see if format becomes an option.

    Also, when phone is connected to computer via USB and you mount the phone to the computer, the SD card is not available for the phone to use.

    larry
  4. k2caliguy

    k2caliguy Member

    I reset the phone to factory settings and that did not solve the problem. The unmount and mount of the sd card under setting are grayed out, I can't select them.

    I have a adapter when I can put the micro sd card into a sd card. I am going to try that tonight, and see if my windows xp software can read the files that were stored on the card, before it became unreadable. I can then narrow down if it is the phone or the card.
  5. k2caliguy

    k2caliguy Member

    " One minute it was working, then suddenly it wasn't." I had the exact same situation, within a few mins, the sd card icon was up in the upper left with the red line through it.
  6. f@scin8

    f@scin8 Active Member

    Hopefully the SD card is the problem. Good luck.

    larry
  7. k2caliguy

    k2caliguy Member

    Yeah I figured out the samsung micro sd card is defective. I have an adapter and plugged it into the sd card port on the side of my laptop. and windows showed that the card had 0 bytes, couldn't format it.

    This Saturday, we shall we how the service is towards giving me a new micro sd card. turns out I bought from a 3rd party verizon store. Even though it looks like a verizon store, with its signage inside and out.
  8. ChristianX10

    ChristianX10 New Member

    I lost all my pictures and had to recover them with the photorecover application. I tried to format the SD using android's format option and nothing, I also used SDFormatter and nothing.
    I was about to purchase a new SD Card, but I first wanted to fix a configuration in Roadsync because it was crashing my Xperia, making it unusable.
    Roadsync was using the SD Card as the location for email storage, so I changed that location to the internal memory. After that I gave another try to the android's format option, and.. voila, it displayed a different message, it prepared the SD card!!

    The SD Card is working perfectly now!!!

  9. horizonstar

    horizonstar New Member

    Thank you Larry.

    I fixed mine by your way. Unmount the card then mount it back on. Mine is a Lexar 16G.

Share This Page