Bloatware Must Die! (My noob rooting journal)

Last Updated:

  1. RobertB-DC

    RobertB-DC Well-Known Member

    I finally reached my saturation point, deleting apps I like because of megs and megs of bloatware on my Optimus T. All I want to do (at this point at least) is delete the bloatware, and maybe run a low-level backup using (root-only) Titanum Backup. I don't want to overclock the poor thing -- it wasn't built to be a sports car, and I don't want it to become a $200 space heater. I don't want to install new ROMs so that I can flash it at my buds and pretend it's an iPhone with a purple case. I just want to get rid of the crap.

    So, for the benefit of my fellow noobs, here's the step by step process I followed.

    * Research the crap out of the whole concept.
    Although I'm a programmer, and I'm familiar with Linux, I've never gone to the trouble to root any of my devices. The most I've done is helped my son understand that the mass of digits on the Game Shark 64 screen are actually DWORDs, and that you can spell things like 4AC0FFEE and DEADBEEF with hexadecimal numbers. So I wanted to make sure I had some clue what I was doing. (By the end of this process, I'll know if I succeeded in that task!)

    * Download z4root
    All roads seem to lead to this post on Thanks to the handy QR code in the post, I was able to drop the .apk file directly onto my SD card.

    * Install z4root
    Astro wasn't working -- it's on the SD card, and this phone frequently loses track of SD apps (which is one reason I want to free up phone memory space). But I was able to open the z4root apk file from my browser (xScope).

    Note: if you're not familiar with installing outside the Android Market, a good start is to go to Amazon and follow the process for installing *their* market app. For obvious reasons, you can't get it from the Android Market. ;)

    * Unmount the SD card
    I saw this advice somewhere, and it seems like a good idea. z4root installed to the phone, so it's still available at this point.

    * Run z4root
    So, I have the choice of Temporary Root or Permanent Root. There's no promise that Temporary will actually work -- well, there's no promise in any case, but Permanent at least has been tried more often. So I just jumped in and hit the Permanent button.

    * USB debugging
    Oops, I forgot to turn on USB debugging. z4root sent me to the settings page, where I turned it on.

    * Run z4root again!
    After some grinding, and some messages at the bottom of the screen, I was taken to a blank white screen showing only the notification bar. Then the phone rebooted. At this point, I wondered if I should have taken out the SD card physically, since rebooting of course re-mounted it.

    * Wait wait wait
    The phone normally takes a while to load everything after a reboot, but this time it seemed to take even longer. But once I looked away to type this, my gadgets finally reappeared. Everything seems normal; Gmail works, txt receiving works. I'm wondering how I can even tell that I've changed anything?

    * Delete something!
    So, can I just delete the crap now? Went into Applications and headed straight for the biggest offender: 10MB behemoth ThinkFree Office. Can I uninstall it? NO, not from the app list, not from the app info page. It's not going to be *that* easy.

    * Whoa, what's that?
    There's a new application showing up in the list with the other non-deletable "Applications": Superuser. YES! But clicking it doesn't cause my phone to leap tall buildings; it's where I set things up. Unfortunately, I don't know *how* to set things up at this point.

    * Take a break
    That's enough excitement for one playdate. I'll do some more research and see how I can use my new, Godlike powers. Meanwhile, I'll watch for any strange behaviors that would prompt me to back out. But the bloatware's days are numbered.

    I'll post an update when I get back to poking on the phone. Meanwhile, any suggestions (and cautions, especially those) are heartily welcomed!

  2. RobertB-DC

    RobertB-DC Well-Known Member

    Ok, I couldn't wait any longer to try out *something*, and it occurred to me that the next logical step was:

    * Install Titanium Backup
    It's a biggie, so I moved it to the SD card (at the suggestion of App 2 SD Pro, one of my favorite time-savers).

    * Run Titanium Backup
    Lo and behold, the Superuser program popped up! That's when I figured I should log back in to androidforums and make sure I added more info.

    * Learning from Dawdling
    I got to learn an interesting tidbit about Superuser: it doesn't wait forever for you to answer. Good security feature. It closed without granting SU, and Titanium told me to try again later.

    * Try again
    It took a while to figure out that I had to re-open Titanium and pick "Reload application" from the menu. This time, it worked! It told me to go tick the USB Debugging checkbox -- which I had done earlier, but sure enough, it wasn't ticked (probably because of reboot). Looks like there's lots of cool options to learn about, yay!

    Gotta go now, will do some more after son's sports activity.
  3. RobertB-DC

    RobertB-DC Well-Known Member

    No time to play over the weekend... had to wait until I got to work today. Wait, something seems backwards there...

    * I fire up Titanium Backup. It checks for SU access and finds it. It also tells me again about the USB developer mode, so I hop over and check it again. Titanium seems to be generating more "Superuser mode granted" options than it did before.

    * A "#" shows up in the Notifications area, telling me "su binary outdated". I click the message, expecting a Market update... silly rabbit! A Linux-style screen displays and I'm asked whether I'm ready to upgrade from a 2.x.x to a 3.x.x binary. That's a pretty big jump, so I back out.

    * I was actually away from my PC when I tried that, but I wanted to poke a little more. So I tried the "Clean up the Dalvik cache" function. It did a lot of work, as far as I could tell, popping up "Superuser mode granted" over and over (assumably, for every Dalvik cache). Then at the end of several minutes, Titanium grinned to itself and told me it would have freed up over 9MB, but since I hadn't upgraded to Pro, NO CAKE FOR YOU! Gee, maybe I should have been told that *before* the cache purge process started? (But I'm still planning to fork out the dough once I've proven to myself that this process is worth it.)

    * So I'm back at my desk, avoiding any real work (o hai boss), and I'm hitting the "Backup/Restore" button. After the one-time plug for Titanium Media Sync (which sounds kinda interesting), I see the big list of stuff to back up. Interestingly, the pre-installed apps (including crap like "Diner Dash 2 Demo 1.4.2") are in red. What I don't see is a way to actually DO a backup.

    * Schedule doesn't seem to have an option to change what's listed as scheduled backups, and I don't see anything saying "Back up the whole blasted phone". The "Add new schedule" adds a bunch of identical functions that I can't get rid of.

    * But "Edit Schedule" seems to give me what I need. I take the first added schedule (leaving the two originals, since they're probably the ones I'd actually want to schedule) and change it to "Backup all user apps + system data". I cross my fingers and hit RUN.

    * Titanium minimizes itself, leaving an icon in the notification bar, which I can pull down to see the status. With each app, the "Superuser permission granted" box displays. It'll be doing this for a while, I can tell, so I'll post what I've got so far and look busy for the boss.

    Next up, hopefully: Search-and-destroy the bloatware that sparked this odyssey in the first place.
    livewirefilms and lethalgorman like this.
  4. RobertB-DC

    RobertB-DC Well-Known Member

    Well, the backup worked... and now the Titanium Backup app list is populated with interesting information about each app. I especially like the distinction between "System service" (red) and "System service with useful data" (green).

    Time to terminate with extreme prejudice.

    * First victim: Diner Dash Demo. Listed as a System Service (lol). For fun, I hit Freeze, just so I could see Titanium beg for money.

    * Ready, fire, aim: I hit Uninstall. A warning displays pointing out that if I bork the phone, it's my own stupid fault. Yes, I want to uninstall this critical system application.

    * Titanium is granted SU, several times, and Diner Dash Demo is Dead. It shows on the list with a line through it.

    * A check with DiskUsage (another favorite app) still shows the corpse there (, still 452kb being taken up. But the app is gone from the Applications list. App2SD reports 24MB free now. (Note: at this point, I didn't actually realize that the app seemed to still be there...)

    * Tried to order by size, but the "ordered by (click to change)" doesn't seem to have that as an option. Or at least, it's not in the first few options. I would have quit trying after it went through several minutes of "Building data freshness information" for a sort method I really don't care about at this point... but then it was stuck on that. So I hit it again, and it spend another several minutes building "exact app size" information. Which isn't totally useless -- though I really don't care that my next victim is 10MB vs 9,655,350 bytes, I just want to kill the big, useless apps. Guess I could have used the Filter function, but I'll save that for another time.

    * Time to jump ahead several levels and defeat the boss: ThinkFree Office, app = 15.9mb.

    * Result: Success! But App2SD still reports just 24MB free. DiskUsage shows a big, ugly as taking up 10.0MB. Did I not have the tools to defeat the big boss?

    * Being a Windows programmer, I did what we always tell our clients: reboot and try again. Will come back to the thread after that task (and at least one look-busy email to the boss) is complete!
    livewirefilms and lethalgorman like this.
  5. RobertB-DC

    RobertB-DC Well-Known Member

    Strangeness... clearly, I don't fully understand the intricacies of Android OS memory allocation. Rebooting removed both Diner Dash Demo and ThinkFree Office from the phone, and they no longer show up in DiskUsage. But I still only have 24MB free. However, I think the "System data" box in DiskUsage has increased in size -- it's now 48.4MB (but I don't know what it was before.

    But heck, it feels good to get rid of the crap I don't use, seeing as how it's MY DANGED PHONE. So I'll go ahead and put a gun to the head of the following (thanks to this ROM thread for a list of stuff I likely don't need):
    * AppPack
    * DoodleJump
    * DriveSmart (deleting this one is said to help performance, battery life, startup time)
    * DualClockWidget (what an amazingly useless dual clock!)
    * Live Wallpaper Picker (also "Android Live Wallpapers" and "Magic Smoke Wallpapers")
    * Pacman
    * Google Talk
    * Web2GoHome

    Stuff from that list that I don't see on my phone:
    * GenieWidget
    * Protips
    * Visualization Wallpapers (Maybe that's "Magic Smoke", above)

    Stuff not on that list that look deleteable
    * Alarm clock
    * Analog clock
    * Car Home (two versions shown, but both are 2.2!)
    * Home Screen Tips (n00b that I am, I do think I've outgrown this)
    * Telenav GPS (seriously, you want me to pay for what Google does better for free?)
    * Something called "Power Off 2.2", that looks totally useless. (j/k)

    Pre-installed apps that I actually use, and will keep:
    * Facebook
    * Maps
    * My Account (not very useful, but wouldn't want to make T-Mo... I mean AT&T&T mad)
    * StreetView
    * Twitter (though I only use it for syncing contact icons)
    * YouTube

    There's a few others that I might delete, once I'm sure of what I'm doing. I think I'll let the phone mellow for another few days before plucking more than the low-hanging fruit.

    BTW: Titanium's order-by is saved between reboots, so it started up with a long recalculation again. But it turns out that a long-press pops up a list of sort orders. I think I flunked the n00b test (again).
  6. RobertB-DC

    RobertB-DC Well-Known Member

    I picked a few more low-hanging fruit, including "Drive Smart", and I'll know over the next few days whether getting rid of that one will help performance and battery usage.

    Some Googling ("android system partition") has taught me a bit more about the /system partition vs the /data partition. I'll try to learn more before I do any deep poking there. It seems like I should be able to move apps from /data to /system, but I'm sure it's more involved than that. (Heck, I don't see why I can't just resize the partitions, except for the change of completely losing my data like I did when I "just" resized my hard drive partitions one time!)

    And I'm updating that su binary now:

    * Click the Notification message.
    * Console-style window displays showing that I'll be updating installed version 2.3.1-ef to 3.0.3.
    * Google around, find and a peaceful, easy feeling.
    * Say ok, watch cool command line messages scroll past, smile inwardly at the developer's wit.
    * Run Titanium again. SU asks to verify root access (permission list got reset, which I think is a Good Thing).

    No problems with the SU update. I know, anyone who's installing custom ROMs and overclocking their phone wouldn't have even hesitated, but maybe this note (like this thread) will help give other noobs like me the confidence to void their warranties.

    Edit (instead of new reply): I've noticed a huge improvement in the accuracy of my Graffiti text input. Previously, it seemed like the CPU couldn't keep up with my finger swiping, which often led to problems. In fact, it's the reason I quit using the Swipe keyboard -- a stroke from point A to point B would be broken or drop out somewhere in between. This is definitely a change since I rooted out Drive Smart -- I can't imagine any of the other apps I smashed today could have had a similar impact. ROOT FTW!
    livewirefilms and lethalgorman like this.
  7. RobertB-DC

    RobertB-DC Well-Known Member

    First real glitch encountered!

    I tried to use Titanium Backup to delete WiFi Calling, a useless "feature" that I couldn't even get to work, but which always starts up. If I recall correctly, it lets you use your wifi to make calls, but still takes the minutes out of your account, which makes it almost entirely useless. Of course T-Mobile's coverage stinks -- my living room is an "emergency calls only" zone -- so maybe I'd have used WiFi calling if I could have made it work. The only good thing I see coming from the AT&T&T merger is getting access to those additional cell towers.

    Anyway, I hit the kill switch on WiFi Calling, and it appears to have been successfully deleted. But then I get a Force Close message on (the WiFi Calling app). I hit the FC button, but the message appears over and over and over. I was afraid I was going to have to do a battery-out reboot, because the message appeared over the "Power Off" dialog, but by pushing the button and pushing the "power off" option quickly enough, I was able to get it to shut down -- despite the FC message appearing over the shutdown screen.

    Powering back on... no problems noticed. Just a little bit of excitement! It's probably a good sign... if the app was holding on to the edge that desperately, it was probably dragging the system down the whole time.

    I've also started breaking other rules, moving downloaded applications to the SD card. That was a little exciting too... on my first try, Titanium Backup got stuck in "Processing" and I had to power cycle to get it to quit. But the app did get moved!

    It looks like it's about time for me to upgrade my Titanium Backup. It's definitely worth the six bucks and change for what it's done already (even though the app itself claims a $5.99 price, lol). It looks like that would let me move the apps I actually do want to keep on my phone into that increasingly-empty System partition (54MB free now vs 23 MB in regular space), using the pro-only "Convert to system app" option.

    If that works, I may move some "System" apps, like Twitter and Facebook, off to the SD card. It looks like the process would be to use the "Convert to user app" pro-only option, then move the app to SD (voluntarily or otherwise). That should be smoother than the free alternative: delete the app and then get it from the Market, which would have the same effect but would lose my settings.

    Basically, root access and Titanium Backup are letting me actually manage my phone's three memory spaces:
    * SD card for non-widget apps that I can live without if needed
    * Data partition for apps that I might delete
    * System partition for apps I'm going to keep

    Of course, it would have made more sense for the System partition to actually contain, well, System apps. But they made it so big (thanks to bloatware), I don't think I can justify just letting that space go to waste.

    (Side note: Nobody has replied to this thread, but it's getting plenty of views. I've found that such a condition means either my brilliant prose has answered everyone's potential questions fully and completely, or else I'm full of crap and everyone's laughing to themselves cuz they're too polite to say STFU NOOB. I'll go with the first one, at least in my own mind.)
  8. mn1968

    mn1968 Well-Known Member

    I was in the same situation as you...I only wanted to root & remove the bloatware. I have no desire (at this point, anyway) to install a custom ROM. After reading your posts it prompted me to root my phone as well. I followed the guide at Android Central [How-To] Root, Recovery, ROM without touching a computer. Although everyone says this method is outdated I found it very simple to follow. Everything worked perfectly.

    I too have found that simply removing the bloatware via Titanim Backup doesn't automatically increase the disk space. The Dalvik cache needs to be cleaned, which the free version of TB won't do. However, you can boot into recovery mode by opening Android Terminal Emulator (Free) and typing "reboot recovery" (without quotes), or by powering off the phone and when the phone is off press and hold (Volume down + Home button + Power) until the recovery screen comes up. Once in the Android System Recovery use the volume button to scroll and the menu button to select. Choose wipe, select Dalvik cache. Doing this gave me back 25mb of internal storage.

    Hope this helps someone,
    FloydPink001 likes this.
  9. RobertB-DC

    RobertB-DC Well-Known Member

    You're not kidding about the Dalvik cache cleanup. I did upgrade to Titanium Pro, and the first thing I tried was the Dalvik cache cleanup. I figured it would unload a few meg -- but it was more like 30MB! Holy crap, that more than doubled my puny available space.

    I was guessing that the cache would just get rebuilt over time, but it's been about a day and I still have the space. At this point, I hardly even need to bother moving stuff around between /data and /system, because I've got more space than I've had since I got the phone.
    lethalgorman likes this.
  10. RobertB-DC

    RobertB-DC Well-Known Member

    So I tried moving an app from User to System... and it didn't go quite as expected. Fortunately, the first "beneficiary" of the process was one I could live without: "Barcode Scanner" (the ZXing app and library used by many other barcode apps). I figured if something went wrong, it could be easily reinstalled, and I wouldn't lose any setup parameters.

    But when I told Titanium to move the app to "Convert to system app", it just stayed at "Processing" forever. After five minutes or so, I even tried Astro File Manager's task killer to kill all the Titanium processes, to no avail. I had to power-cycle the phone.

    When I got back, Barcode Scanner was gone. Not a user app, not a system app... it was gone, and apps that use it (like BarClone, the only no-GPS grocery card app) complained that it wasn't there any more.

    So I got to try out Titanium Backup's eponymous Backup function! It worked like a charm, brought it right back.

    Then, I noticed Titanium has a "Problems?" button right on the opening page. One hint the button includes is, "If it hangs during some operations, hit 'Preferences' and set 'App processing mode' to 'AUTO, Indirect'". That's *exactly* what's been happening, so I did what it said (the option is way down the Preferences list).

    Tried again: move Barcode Scanner to System. Poof, it's now a red-letter application! "Uninstall" is no longer an option, either from the app info page or from the Market.

    I'll do some more poking when I have time, but so far, rooting my Android has been a fun and educational process, and it's left me with twice the phone I started with.
    livewirefilms and lethalgorman like this.
  11. RobertB-DC

    RobertB-DC Well-Known Member

    Interesting tidbit on moving an app to System. I converted Barcode Scanner and App 2 SD to both be System apps, but then I noticed that they no longer showed up in the Android Market when I listed "My Apps". Bad news, I thought: if the Market didn't see them installed, I wouldn't be able to get updates! So I figured I'd just use the freed-up Dalvik Cache space and be happy.

    Well, over the weekend, App 2 SD had an update. Lo and behold, it showed up on in the Market after all! I installed the update, and App 2 SD now shows up in "My Apps". And strangely, so does Barcode Scanner!

    I figured this was good news, though. At some point, the phone does see apps that are added to the System partition. So I moved the app that I really do want to keep safest of all: Titanium Backup. And sure enough, it doesn't show up on "My Apps", but now I know that I'll (most likely) get my updates. So I'm going to start moving the rest of my most-have apps to System.

    One thing did break, though: my App 2 SD widget now says "Problem loading". Well, actually it says:


    ... because the text is crammed into a 1x1 widget space. But re-adding the widget worked without a hitch. It's good to know that, though, before I add Beautiful Widgets to my System folder (and break all its little friends).
    livewirefilms and lethalgorman like this.
  12. RobertB-DC

    RobertB-DC Well-Known Member

    It's a whole new phone these days. My friend has a new Android with gigs of memory, compared with the tiny 200MB on our Optimus T's, so I don't think he's going to be pushed to root for a while. But for this entry-level phone, I can't imagine going without rooting and aggressively managing the apps.

    I've seen another nice side effect. I was having constant problems with my SD card apps. They would randomly go away, leaving a generic icon on the desktop that claimed "not installed". Unmounting and re-mounting the SD card (in Settings) would sometimes fix the problem... but sometimes it would just result in a different set of SD card apps going AWOL. I was worried that my SD card was going bad, but it was the second card to have the same problem.

    Now that the bloatware is no longer hogging CPU time at bootup, my SD apps are no longer going randomly missing.

    I assumed I would never need to root my phone, because I never planned to be an uber hacker with a pocket full of custom ROMs. Turns out that my low-end phone pretty much requires root to unlock its full potential. Huge thanks to this forum for pointing me in various directions, most of them right :) , and pushing me to take the plunge.
    livewirefilms and lethalgorman like this.
  13. RobertB-DC

    RobertB-DC Well-Known Member

    A few quick updates:

    * I thought I'd converted Titanium Backup to a System app. I was wrong! Titanium Backup isn't included in Titanium's list of apps it can back up. What I thought was the app was actually just the Pro unlock key. Silly me, but sillier Titanium for not letting it back itself up. (Of course, how would you restore it?)

    * One of my favorite "Freeze" victims is Voice Dialer. I never use it, but the easily-pressed button on my Bluetooth headset starts it automatically. Not any more.

    * For some reason I can't figure out, Titanium won't let me move the "Graffiti" text entry method to System (or SD, for that matter). I wonder what they did to block it? I was able to move other keyboard apps to System with no problems.
  14. PCAce

    PCAce New Member


    I got a kick out of reading your journal. I read it straight through to this post. If I counted the times I cracked up, I would need more hands! Last year around this time, I embarked on the same path you have taken. There are some eerie similarities--in your experiences and your experience (I was an assembly language guru back in the days of DOS). I especially enjoyed your "resize partition" mention! Having two older sisters, you could have evened the odds if we were brothers. <WEG> [wide, evil grin]

    Thanks for sharing!

    P.S. One disappointing fact about the Optimus T is that the processor is only 600 MHz. Had it been a full GigaHertz processor, it would run Adobe Flash. Flash is the reason I wanted to get an Android phone over a year ago. Boy, was I disappointed when I went to check it out and discovered it wasn't available. Neither is Firefox :(

    Interestingly enough, this latest replacement unit shipped with a 4GB SDcard, whereas the previous unit shipped with a 2GB SDcard. Too bad I already purchased an 8GB card this summer.
    RobertB-DC likes this.
  15. PCAce

    PCAce New Member

    I also fell victim to the phantom app syndrome. It usually happened with Opera Mobile. I would be browsing (with eight or nine tabs open) and the phone would slow to a crawl and then reboot. When it came back, Opera was gone! Good thing Opera Link saved all my settings and bookmarks. I find it unfathomable that LG even considered providing less than a gigabyte of internal storage. I mean, it is a camera phone, a web browser, and is a platform for graphical games! It's like manufacturing a bicycle with 4-inch tires! Hello?!?

  16. matiasch

    matiasch New Member

    Great write-up RobertB-DC, thank you.

    I would like to add a few items to your excellent description / instructions.

    1) If you are running Android Version 2.2.2 then z4root may not work. I had to use GingerBreak-v1.20 to root my phone.
    2) Strangely, I see Superuser when I press the Apps button but not when I look under Setting -> Applications -> Manage Applications.
    3) DO NOT PRESS Volume down + Home button + Power as suggested by mn1968. This reset my phone
  17. mn1968

    mn1968 Well-Known Member

  18. AngelArs

    AngelArs Well-Known Member

    You didn't format it correctly. It should have ended with [/ QUOTE] (without the space) instead of QUOTE]. Hit edit and add the [/ in front of 'quote' and it will be fine ;)

    RobertB-DC - GREAT thread! THANKS!
    RobertB-DC likes this.
  19. AngelArs

    AngelArs Well-Known Member

    Before deleting I always freeze an item to make sure it's not going to effect something else in the phone. I froze DriveSmart but then I noticed that it was still listed in the phones main menu, and when you click on it you obviously get a lot of error messages.

    My question for you; after you actually deleted DriveSmart was it still listed in the menu? It should be located at system settings/DriveSmart (third item from the top, between Call Settings and Sound). Thanks :)
  20. RobertB-DC

    RobertB-DC Well-Known Member

    That's something I hadn't thought to try! Sure enough, DriveSmart is still listed there. Clicking it generates a Force Close on Settings (process But deleting DriveSmart hasn't caused any issues beyond that glitch, which is easily avoided. Though now that I know about it, I may go in to Settings and hit DriveSmart occasionally, just to show the phone who's boss. :cool:
    lethalgorman likes this.
  21. AngelArs

    AngelArs Well-Known Member

    Have you tried to remove Carrier IQ? That's the program that manufactures secretly put on all phones to spy on you with (see this page for more information).
  22. RobertB-DC

    RobertB-DC Well-Known Member

    Actually, according to the Lookout Carrier IQ detector (market link), my Optimus T doesn't have Carrier IQ. I got mine in June 2011 -- I wonder if newer purchasers have it, and I wonder if rooting my phone and killing the bloat prevented T-Mo from adding it? I think I'll make a thread for that question, cuz I'm curious now.
    lethalgorman likes this.
  23. AngelArs

    AngelArs Well-Known Member

    They probably called it something else back then :p I think it's listed under IQRN and I couldn't find any such listing on my Optimus, so that's one more reason to love this phone :D

    I think it would bog down the little 600Mhz processor so they didn't use it. There is probably a more primitive version of it on our phones though... something worth looking into ;)
  24. RobertB-DC

    RobertB-DC Well-Known Member

    I've been using SMS Popup (market link) almost since I got my phone, because it's lightweight and efficient. I gladly sprung for the $2 donation, too, even though it's totally voluntary (the app isn't crippled or ad-driven). I even used Titanium to move it in to ROM.

    But now that I've got more space, I'm trying GO SMS, the hugely popular SMS replacement for the clunky messaging program on the Optimus T. I decided I'd had enough when I saw that nobody else's Android seems to be without a bubble-style conversation interface. And GO SMS seems to have all the features of SMS Popup... in fact, it looks as though they copied the configuration options word for word! That's not very nice. :(

    Despite that moral twinge (ameliorated somewhat by the small donation I made to SMS Popup), I think I'm going to move SMS Popup out of ROM, freeze it, and move it to SD. I don't want to delete it, in case Go SMS doesn't work out. Then, I'll move GO SMS to ROM, because it's darn near 10MB! I couldn't have even considered installing it without going through the rooting and pruning process.
    livewirefilms and lethalgorman like this.
  25. AngelArs

    AngelArs Well-Known Member

    You know you can always delete it and still download it again from "My Library" if you want :)

Share This Page