Block Restricted/Unknown numbers?Support


Last Updated: 2014-07-02 23:12:44
  1. jayno20

    jayno20 Well-Known Member

    I am trying to do this through the phonebook... I read in another thread that it can be added to the phonebook and then set to "send to voicemail". I can do that, but it doesn't send the call to voicemail. Am I doing something wrong? I'd rather not use an app for this if I don't have to.

    Advertisement
    irishpack and dene1 like this.
  2. jayno20

    jayno20 Well-Known Member

    OK I figured it out, for anyone else wondering, here is what you have to do:


    Add a contact named Restricted, Blocked, Private, Unknown, or whichever is contacting you.

    You can't add it on the phone though because the NUMBER for the contact must read "RESTRICTED" as well as the name of the contact. I did it through contacts at gmail then synced it with my phone. After that just tell the phone to send this contact straight to voicemail and it works like a charm!
  3. CatsTide

    CatsTide Well-Known Member

    nice work around or....just get an app for that
    sohail456 likes this.
  4. Wynnded

    Wynnded Well-Known Member

    I have wanted to be able to do that for a very long time. Well done.
    sohail456 likes this.
  5. terryzx

    terryzx Well-Known Member

    You can also sign up for You Mail and block them with a recording that you don't accept those type numbers and then it hangs up and will not allow them to leave a message <GRIN>
    MiniMe56789 likes this.
  6. jayno20

    jayno20 Well-Known Member


    Yeah I didn't want an app because it still rings your phone for a second before then going to voicemail. This way goes STRAIGHT to voicemail and only lets you know you missed a call but it never rings.
  7. Fatso Jetson

    Fatso Jetson Member

    Great tip. This will be the first thing I do when my phone arrives.
  8. DevHead

    DevHead Well-Known Member

    I use aFirewall. You'll have to change the settings to your preferences, but you can block those not on your contact list and have them automatically sent to voicemail.
  9. jayno20

    jayno20 Well-Known Member


    From what I've read about that app it still rings your phone for a second before sending it to voice mail. Doing it the other way goes straight to voice mail.
  10. DevHead

    DevHead Well-Known Member

    I like aFirewall, because it allows me to block everyone who is not on my contact list (not just restricted, unknown, private, etc. numbers).

    Strange, but I don't even get a ring for a second before being sent to voice mail. Knock on wood. :D
  11. Photomentalist

    Photomentalist New Member

    I love this way of doing it. So simple and yet so effective. Shame I can't have a special voicemail account just for telemarketers though.
  12. mylinuxbox

    mylinuxbox Well-Known Member

    I have tried this on my Hero with 2.1 and the calls come through as normal.

    I have created a contact via google. co. uk/contacts with the name Unknown and no number and the calls come through. I have also tried it with the same contact where the name is unknown and the number I typed Unknown also. still the calls get through.

    Can someone tell me if I am doing this wrong?

    it is all well and good saying 'there is an app for that' but they are not great.
  13. mylinuxbox

    mylinuxbox Well-Known Member

    Have just figured it out.

    Firstly, in the web browser go to google .co .uk/contacts.

    Create a contact with the name Anonymous.

    Then add nonumber as the number.

    Sync with your phone and set the new contact to be sent to voicemail.

    Worked first time.

    Not sure if you need the uppercase A in the name but that is how I have it and it works.
  14. awesomemom

    awesomemom Member

    jayno20.........i tried it and didn't work for me
    i have been getting calls for over 2 weeks now from a "private number" every day and sometimes twice a day, it is getting rather annoying......
  15. Wynnded

    Wynnded Well-Known Member

    I think that the way this works best, for my anyway, is like this.

    You'll need a Gmail account. If for no other reason then to back-up your contacts...and to block calls.

    Set your device up to sync between your contacts and your Gmail account. Something like Menu-Settings-Accounts & Sync.
    Then on your computer (you may be able to do it on your device, I don't recall) create a contact in your Gmail account called "Restricted" (w/out the quotes), I also made one for "Private". Go to your device and Sync them. Then if I've explained this coherently, you should have a contact in you list called "Restricted" and "Private". Next, go to your dialer, hit Menu then Blocked Callers and it should allow you to checkmark any of your contacts adding them to the list.

    This is just kind of general as I'm on a different device now with a custom ROM. Good luck.
    awesomemom likes this.
  16. awesomemom

    awesomemom Member

    Hi! i did just that and the call still gets through......ughhhhh!!!!!
  17. Wynnded

    Wynnded Well-Known Member

    Well...dang...

    How about this.
    On your device, go to People and scroll down to Restricted and touch the figure of the head. There should be a pop-up, touch View. Now you should be able to view Restricted's Details. Under Options, there should be listed an option to Block Caller, touching this should bring up a pop-up asking you if you want to enable this, OK and Cancel are your options. Hopefully that will happen, or not happen as is our intent.:)
  18. awesomemom

    awesomemom Member

    yes, also tried that, and also called verizon, they told me they cant block a "private number", they said they will make a note of it and my next step is to call the police....well it is a "private number" and all they do is hang up they don't say anything or leave any kind of message.....:confused:
  19. Wynnded

    Wynnded Well-Known Member

    Yep, that's the same thing Verizon told me years ago when I was having the same issue on my dumb phone. The other suggestion that they made was for me to change my phone number. lol

    It's been a while since I've had to set this up, but have you tried what I quoted above? You'll have to go into Gmail and type in Restricted/Private Number/etc. in the phone number field for the contact of the same name. Then sync, then check you device to make sure that it went through. If you go into the details for Restricted, it should read Restricted in the Call Mobile and Send Message areas. I forgot about this until I reread the quote above and then went in and checked what was showing up on my device. Hang in there.
  20. awesomemom

    awesomemom Member

    Just tried that....hopefully it works, will let you know, thanks!!!!:)
  21. awesomemom

    awesomemom Member

    It didn't work.....i don't know why verizon wouldn't help me out! i am so frustrated!:mad:
  22. Wynnded

    Wynnded Well-Known Member

    Verizon can't/won't block those numbers because there's no number to block. If you were able to give them a number to block, then I think they offer a service for it, but there's a fee.

    Shucks....maybe we need to go back to square one and check some basics.

    -In Gmail there's a contact named Private Number/Restricted Number/Blocked Number (exactly what is showing up on your caller ID) and in the place for their phone number the word Private Number (or whatever) is typed in.
    -On your Inc2 your Gmail account is successfully syncing with you Inc2 to transfer this and all other contacts to your Inc2.
    -In the contact list on your Inc2 when you go to the contact named Private Number and look at the phone number, it should read Private Number as well. Just below that, under a heading called Options, there should be a Block caller setting and it should read ON.

    [​IMG]

    If these things are correct, as far as I can tell, it should work and these calls should get sent to voice-mail. The only alternative that I can think of would be to decline these calls on the screen or silence them by pressing the down volume button when they call until you can find someone who is sure of what they're doing and can physically go into you device and check your settings.

    We'll see how that goes. lol
  23. MiniMe56789

    MiniMe56789 New Member

    How do you exactly set up your mail to block these calls so they will receive a recording and hang up the call..... HELP!

    Thank you.
  24. MiniMe56789

    MiniMe56789 New Member

    I found out what "You Mail" is. THANK YOU SOOOOOOO MUCH! It works incredible.
  25. saudiqbal

    saudiqbal New Member

    I found a little help, if you add the number -1 in your number list android will detect the call as unknown, but it is still not sending the calls to voicemail.
    Test it here, create a contact named "Unknown" with phone no "-1" and forward it to your voicemail. test it by calling private, you ll get the call but after you hangup the testing phone you ll see the name of the contact and -1 there in your missed call list. It needs some more testing.

    reference http://stackoverflow.com/questions/...wn-private-restricted-calls-in-my-android-app

Share This Page