Bluetooth Autoplay in CarSupport


Last Updated:

  1. FatStig

    FatStig New Member This Topic's Starter

    Joined:
    Jul 23, 2010
    Messages:
    1
    Likes Received:
    0
    This is a growing problem with cars that have built-in media centers such as Ford Sync and Subaru Media Hub. This also happens with some bluetooth headphones. When the droid is connected using the headphone jack it works perfect. When the droid is connected using bluetooth, autoplay finds a random mp3 on your card and starts playing it automatically using the default music player. Even if it is not open. It also turns shuffle on. Beyond annoying. Please help. Thanks.
     

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,416
    Likes Received:
    1,919
    Do you use the music player at all, or do you use services akin to Pandora (Slacker, Last.fm, etc) for your music?

    I had the same problem once, but I think it happened *after* I used the media player for the first time while I was connected via BT - before that it would not do it, and since I have flashed a different ROM on my phone it does not do it anymore.

    If you *do* use the media player and play music of your SDCard, not sure how to fix it, other than trying something like ATM / TK to kill the media player before enabling the BT connection.

    Since I discovered Pandora, I stopped keeping music on my SDCard - It's too small for all my music anyway, and I got tired of having to move folders onto and off of the card - Services like Pandora give me all of the configurability I want, and while I occasionally want to listen to an entire album, for now I am content with random play music from Pandora.
     
  3. EvilAndroid

    EvilAndroid Member

    Joined:
    Jul 24, 2010
    Messages:
    6
    Likes Received:
    0
    I too would like to know if anyone has figured out a way to configure/disable the autoplay feature. I like keeping all my music on the phone, but don't like the fact that my device just starts burning battery while I'm listening to Sirius.

    Any suggestions on how to disable the autoplay feature without having to to TK everything everytime would be great.

    thanks
     
  4. EvilAndroid

    EvilAndroid Member

    Joined:
    Jul 24, 2010
    Messages:
    6
    Likes Received:
    0
    Just an update... Pandora autoplays now too... this is so annoying.
     
  5. dliska

    dliska New Member

    Joined:
    Aug 1, 2010
    Messages:
    1
    Likes Received:
    0
    Have to add my frustration here as well. I'll be listening to doggcatcher, pandora, etc... and the music starts playing right after turning on my car. This really needs to be a feature we can disable.

    The behavior I would prefer would be: what ever was playing when the car was turned off (bluetooth connection cut), start playing that again when it's re-established. If I'm listening to podcasts for example, pause on disconnect and resume on connect. Seems pretty simple to me. Whatever you do, please don't start playing random music!
     
  6. newdroidman

    newdroidman New Member

    Joined:
    Nov 9, 2009
    Messages:
    1
    Likes Received:
    0
    I disabled the media feature of the bluetooth for the Ford Sync and it stopped it autoplaying. It means I can't listen to Pandora, though, without enabling the media function again. Has anyone found the solution to this, yet?
     
  7. Dulanic

    Dulanic Member

    Joined:
    Oct 7, 2010
    Messages:
    10
    Likes Received:
    1
    Majorly annoying! I just got a vehicle with BT audio support and it does the same shit. I hate having to kill fix it every time I get in the car. I want to play slayer not a random MP3!
     
  8. Dulanic

    Dulanic Member

    Joined:
    Oct 7, 2010
    Messages:
    10
    Likes Received:
    1
    I found a fix with Tasker. I have it activate when it conects to the car's bluetooth. It kills my 3 possible music apps and then provides me a menu with Music Player, Pandora and Slacker. So while this is not a "fix" it is a good work around for me.
     
  9. abexman

    abexman New Member

    Joined:
    Dec 8, 2010
    Messages:
    1
    Likes Received:
    0
    @Dulanic - I am trying with Tasker and I cannot get it to work. My car is launching "Google Listen" on bluetooth connect and while I can get Tasker to kill this app when not in the car, it won't do so while I am in the car. Can you post the Tasker profile steps you setup or better the profile itself for download? Any guidance would be great. Thanks!

    Currently I have the Tasker profile in context of bluetooth connect with my car set to kill the Listen app and load the Groovershark app, but it only does the latter. The Listen app still autoplays.
     
  10. Criminosis

    Criminosis New Member

    Joined:
    Jul 14, 2010
    Messages:
    3
    Likes Received:
    0
  11. Metal Bender

    Metal Bender New Member

    Joined:
    Mar 25, 2011
    Messages:
    1
    Likes Received:
    0
    Easy solution to stop autoplay. In the car switch to User Device on the Media button, and pick an input source other than BTST (line in or USB). Then your phone will not autoplay when bluetooth starts up.
     
  12. Jerry-rigged

    Jerry-rigged Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    253
    Likes Received:
    25
    Sorry to dig up an old thread - but has anyone come up with a fix for this? MetalBender's fix does not work for my '010 pickup...

    My phone will almost always start to play on BT connect & disconnect... Often with more than one player at a time... This is really starting to p!$$ me off...
     
  13. gpend

    gpend New Member

    Joined:
    Oct 30, 2010
    Messages:
    1
    Likes Received:
    0
    I figured I would get on here and bump the thread since this is still apparently and issue. Here is what I have found: I have several various headsets that do a2dp and avrcp that work as they should; waiting patiently until the user asks for music. however, the other day I was in a friends car (mazda 6 w/bt) listening to amazon mp3 on my samsung epic and every time we got out I would insure that the amazon app was paused and that no other music app was playing. every time we got back in the car the default music player would start playing... the same song every time. it occurs to me that, yes, it is a function of the remote device requesting music. but also that the android device should pay attention to what is currently open/last playing and resume that instead of opening the default player every time. (e.g. if I pause the amazon app it should pick that up. But if nothing is open it should keep quiet.)
    just my 2 cents. I hope this makes it to someone that can fix the actual problem in Android.
     
  14. AllisonW

    AllisonW New Member

    Joined:
    Oct 1, 2011
    Messages:
    1
    Likes Received:
    0
    Not sure if my solution addresses the problems described here - but it might help. I just got a new car (Subaru Forester) and started using bluetooth to connect to my Droid X. Every time I got in the car, my phone started automatically playing music - not over the car sound system, just on the phone. It was using Pandora, so on Pandora I went to "preferences" and selected "off" for Bluetooth for Automotive. Great! Problem solved.

    The next time I got in my car, the phone started playing music using the Android music app that came on the phone. It doesn't seem to have an Options or Preferences settings, so the Pandora solution wouldn't work. Found the answer in the Droid X users guide - in app settings, go to "Wireless & Networks", choose Bluetooth settings, then press and hold the name of the bluetooth device - a popup opens; choose options, then you see "Profiles". There are two settings - "Phone" and "Media" which can be checked off or on to provide audio over the bluetooth. Uncheck the "Use for Media audio".

    This won't work if you ever want to use the phone to play music over the bluetooth, but I intend to use my ipod for music, so it works for me.
     
  15. haymat

    haymat New Member

    Joined:
    Oct 19, 2011
    Messages:
    2
    Likes Received:
    0
    I had the autoplay/bluetooth problem with the Microsoft Sync in the Ford I drive. The solution was turning off "Autoplay" in Sync inside the car; the phone was fine as-is.

    (I actually had another problem: Astro Player Nova also has a "Start by headset" setting that also auto-starts the application on the detection of bluetooth. Changing this setting and the Sync Autoplay fixed the problem for me. I only installed Astro Player Nova in an attempt to fix this problem by bypassing the default Droid 2 music player.)

    All is well now.
    ---M@
     
  16. pawmbi

    pawmbi New Member

    Joined:
    Apr 19, 2011
    Messages:
    1
    Likes Received:
    0
    @Hymat

    So just so I understand because I have a Mercury Mariner with Sync. There is a feature in the Sync that I can turn on/off called auto play? We are having this exact same issue with our EVO..get in turn on and connects and randomly starts playing Media Apps..or in the case of my wife clips or sound tones since she has no songs downloaded to her EVO. I will check this out and see if this fixes the problem.
     
  17. TangoOversway

    TangoOversway New Member

    Joined:
    Jan 21, 2012
    Messages:
    1
    Likes Received:
    0
    At the risk of my new post being an example of threadus resurrectus, I'm having this problem on my Droid.

    I just got an audio system installed in one of my cars. Up to now I had never used bluetooth and did use an audio jack to play Slacker through my stereo in that car (the older one). It worked fine and I liked that when I pulled the jack out, Slacker (or Pandora) stopped.

    But now that I replaced the in-trunk CD changer in the newer car with a newer audio system, I find that my mp3 files (and I don't have many) get played randomly. Sometimes I get in and the BT pairing starts the files playing, but, even worse, it happens the other way around. I turn off the car and Slacker stops playing, as it should, and within 20 seconds, my phone is playing an MP3 file.

    Has anyone fixed this yet? The first time it started playing, I didn't have music on and an old time radio show MP3 file started playing and the voices scared me. I hit the break and almost caused an accident. I've added that info as a comment for Google, but I don't see anything showing this is fixed or there's a patch or what I can do to stop this.

    Also, does anyone know if this is fixed in the newer Android phones Verizon sells? I'm considering an upgrade and this bad enough, for me, to push me to upgrade to a newer phone. (It's about time anyway and Verizon has even called to remind me of that.)
     
  18. dgt02

    dgt02 New Member

    Joined:
    May 3, 2011
    Messages:
    2
    Likes Received:
    1
    Thank you - this seems to be the only option with some configurations.
     
    DanDroide likes this.
  19. Macmagoo

    Macmagoo Active Member

    Joined:
    Jun 17, 2012
    Messages:
    38
    Likes Received:
    2
    Hi all, this issue seems to be widespread. Samsung Galaxy S3. Ford S Max. I switch the sony radio to BT Audio to use my phones nav software, music starts to play and the nav voice comes through on top of the music. Any tips appreciated.
     
  20. TheLordofLight

    TheLordofLight New Member

    Joined:
    Dec 13, 2015
    Messages:
    1
    Likes Received:
    0
    Hello everyone.... This is a solution that works. I have a 2014 Subaru Forrester and a Galaxy S3, and every time I start my car my ringtone would start up on my phone. VERY annoying. I dont use my phone for music, I have a iPod for that.

    Anyway, go into Bluetooth setting, you'll see car m_media setting, hold down the settings button just to the right and a menu will pop up that says media audio... Uncheck that. You may get a message that says "This will turn media off from phone".


    You will have to repeat this everything you turn off Bluetooth,but it works. No more spongebob theme song playing on my phone every time I start my car.

    This will also turn off the BT audio option when skipping through car audio modes( FM,AM,USB,BT).


    If your not using your phone for music, this definitely works. Hope this helped !
     
    Last edited: Dec 13, 2015
    #20
  21. WilliamAF

    WilliamAF New Member

    Joined:
    Jan 2, 2016
    Messages:
    1
    Likes Received:
    0
    It has been determined that the problem is with Sync, NOT our phones.

    I tried setting Autoplay OFF, but the music kicked in anyway.
     

Share This Page

Loading...