Bluetooth Issues / Downgrade?Support


Last Updated:

  1. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    Since upgrading to 2.1, I am having difficulty with the Bluetooth connection to my Car (Fiat Blue & Me system). Most of the time it connects then drops after a few minutes, and sometimes won't connect at all.

    I have seen that quite a few Hero owners are having the same issue with other built in car systems, but so far, I haven't been able find a fix.

    I have contacted HTC and are waiting for a reply, but has anyone out there managed to get around this problem or is there anyway I can downgrade to 1.5 without rooting in the meantime?

    Thanks, Steve.
     

    Advertisement
  2. peterc10

    peterc10 Well-Known Member

    Joined:
    Jan 10, 2010
    Messages:
    711
    Likes Received:
    80
    Nope .... just the opposite with me.

    The BT connection to my Bury car kit is much better and more reliable with 2.1 than it was with 1.5.
     
  3. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    Thanks, but I think the issue is with some Bluetooth devices that are built into the car by the manufacturer. I have a ticket open with HTC, but they have not offered any suggestions yet :(

    Does anyone know if I can downgrade to 1.5 without rooting?

    Thanks, Steve
     
  4. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    OK.. HTC have said it is not possible to revert to 1.5.

    Does anyone know if it is possible to root the phone after it has been upgraded to 2.1 (Official ROM, unbranded / unlocked handset), and are 1.5 ROMs still available?

    Would really like to get the HandsFree working again ;)

    Thanks. Steve..
     
  5. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,757
    Likes Received:
    8,888
    You can downgrade from 2.1 ;)

    You need to make a goldcard and put it in your phone. Then if you run one of the 1.5 installers it should install just fine :)
     
    Steve-Silver likes this.
  6. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    Thanks for the information Xyro!

    Can I use the official ROM that is still available from the HTC website, i.e, version 2.73.405.5?

    Cheers, Steve.
     
  7. Xyro

    Xyro 4 8 15 16 23 42 Moderator

    Joined:
    Dec 1, 2009
    Messages:
    12,757
    Likes Received:
    8,888
    Having a goldcard lets you install whatever you want, so if that's the latest 1.5 version then yeah, that's what you want.
     
  8. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    Thanks Xyro,

    I have created my goldcard, ready to go...

    It look's like it will be my only option. Fiat 'Tech' Support don't want to know and HTC say they don't have any answers either.

    Would be interested to hear if anyone else is having problems with the Hero and Bluetooth systems built into their car, but I think I will have to take the plunge and downgrade to 1.5 :-(

    Cheers, Steve.
     
  9. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    Update: I have successfully downgraded phone to 1.5 (Thanks Xyro)..

    I am unable to install a few applications now though (Sky Remote Record, Google Maps and Swype Beta etc.), but at least Car and Handset seem to be working together again.

    Got me wondering though, I wonder if any custom 2.1 ROMs use a different Bluetooth Radio profile to the Stock ROM?... :rolleyes:

    Any Ideas??

    Thanks, Steve
     
  10. jev

    jev Well-Known Member

    Joined:
    Dec 24, 2009
    Messages:
    190
    Likes Received:
    17
    I'm running froydvillain on my phone (froyo). The step from 2.1 to 2.2 was an enormous progress in BT as far as I'm concerned. I now have a reliable connection to my Citroen's audio system, including telephony. You should give that a try!
     
  11. Steve Adams

    Steve Adams Well-Known Member

    Joined:
    Nov 8, 2010
    Messages:
    188
    Likes Received:
    14
    my 2.1 works great with my Jeep factory nav. almost too good, im inside and start my vehicle using autostart, and its connected from over 100 ft away.

    Everything jeep makes is great anyways, including their nav systems....i have all the woods roads in the bush on my GPS factory...

    and the hero with 2.1 is a great complement to that.
     
  12. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    Thanks Jev,

    I am a bit nervous about rooting the phone after reading a few guides, especially after I have finally got Bluetooth to work again after a couple of months. But... I am sure I will miss the Apps that I have lost so it probably won't be long! ;)

    Cheers. Steve.
     
  13. Steve-Silver

    Steve-Silver Member This Topic's Starter

    Joined:
    Jan 9, 2010
    Messages:
    17
    Likes Received:
    0
    Hi All,

    Sorry to bump this old thread, but I thought I would post an update in case anyone else is having a similar issue and stumbles upon it.

    I have taken the plunge and rooted my phone to FroydVillain 1.7.2 (Android 2.2.1). I am pleased to say the process was quite painless, and the Bluetooth in my car appears to be working fine now :)

    As an added bonus, my Hero is much more responsive than either of the stock ROMS, and it's like having a new phone!

    Cheers, Steve.
     

Share This Page

Loading...