Bluetooth problem with BMW iDriveSupport


Last Updated:

  1. jondiehl

    jondiehl Active Member This Topic's Starter

    Joined:
    Dec 20, 2009
    Messages:
    31
    Likes Received:
    0
    I previously owned the HTC Hero and it worked flawlessly with my BMW's iDrive system.

    The Samsung Epic though, will pair and make/receive calls, but the issue is that my phone book does not show up in iDrive like it did before. Neither does my missed calls, top 8 calls, recent calls, etc. In addition, when I receive an incoming call, it shows the callerid phone number, but not the contact name assigned to it.

    It's frustrating to have to always dial from my phone, rather than using the iDrive controls... that's the whole point of "hands free" right?

    Anyone know if there's an update for this?
     

    Advertisement
  2. dawankler

    dawankler Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    102
    Likes Received:
    17
    Have you considered that this might be an issue with iDrive instead? A friend of mine has had issues every time he's gotten a new phone (BB, iPhone, and Android) with his 335. I know the iDrive system is a little goofy about contacts syncing and you might google around for people having similar issues for a fix.
     
  3. jondiehl

    jondiehl Active Member This Topic's Starter

    Joined:
    Dec 20, 2009
    Messages:
    31
    Likes Received:
    0
    Yes, of course. However, every other phone I have or have had, syncs contacts just fine. I think its a Samsung galaxy series issue. My brother's evo, my wife's transform, my old hero, my old moto q phones, etc.... all sync fine. In looking at other bmw forums, everone is having an issue with this phone and thbeir idrive. I am hoping the update to 2.2 fixes it, but was curious if someone had an app to fix it before that
     
  4. jademan

    jademan New Member

    Joined:
    Oct 21, 2010
    Messages:
    2
    Likes Received:
    0
    Just switched to Epic from Pre, and though I like the phone, I am majorly bummed that it won't work in my 08 Acura TL-S. The Pre worked perfectly (except for being able to transfer phonebook entries from device to car - but phone operation was flawless).

    I can get the Epic to pair, but then it falls off to "paired, but not connected" repeatedly, and the car then reports no phone is found. Going back into visibility mode for the 90 seconds and then reconnecting works - but only temporarily as the cycle then repeats...

    Looking around, it does seem there are many BT connection issues going on with the Epic. I'm hoping 2.2 will help...? Any other suggestions appreciated.
     
  5. arudko

    arudko New Member

    Joined:
    Jan 8, 2011
    Messages:
    1
    Likes Received:
    0
    Just picked up a 2011 BMW 550 with the iDrive system. Having nothing but issues trying to get my HTC Incredible to work and stay connected. Sometimes I can get it to connect for a few minutes at a time then my phone says paired but not connected. I try to connect and it fails. I've done the process from scratch several times. Verizon says its a know issue with iDrive. The phone pairs with other cars just fine. I also here the version of bluetoothe may be an issue for the incredible. I am told there is a work around but cant find one.
     
  6. nyclio

    nyclio New Member

    Joined:
    Jan 8, 2011
    Messages:
    4
    Likes Received:
    1
    iDrive has always given me problems pairing my phones in my 550 as well.

    The best solution I found was to just turn my phone off while I'm driving and enjoy the hell out of the car since it's so much fun to drive. :D
     
  7. EmM HoLLa

    EmM HoLLa Well-Known Member

    Joined:
    Feb 14, 2011
    Messages:
    51
    Likes Received:
    5
    Anyone figure out a solution to this or find an android phone that pairs fully with a BMW 650i?..
     
  8. jondiehl

    jondiehl Active Member This Topic's Starter

    Joined:
    Dec 20, 2009
    Messages:
    31
    Likes Received:
    0
    Nope, the 2.2.1 update on my Epic 4G did nothing to help fully pair/sync with my M6's iDrive. I've gotten used to it though, I just always have to dial with the phone.
     
  9. EmM HoLLa

    EmM HoLLa Well-Known Member

    Joined:
    Feb 14, 2011
    Messages:
    51
    Likes Received:
    5

    Same here.. What is funny is a friend of mine has an HTC Evo and it synced up perfectly.. I am seriously considering getting an EVO if there is no way this can be fixed..
     
  10. jondiehl

    jondiehl Active Member This Topic's Starter

    Joined:
    Dec 20, 2009
    Messages:
    31
    Likes Received:
    0
    That's funny, I have a guy at my office who just bought an Evo and it won't sync with his new Ford truck and it's Sync multimedia system. We walked out to the parking lot and my phone worked perfectly with his Ford Sync, and his Evo worked perfectly with my BMW iDrive.

    We discussed trading phones, but the problem is, his phone is brand new, my phone is 6 months old... so an even swap wouldn't be totally fair (mine looks like new though). I'd miss the smaller form factor and better screen of my Epic though. I'll suffer with the limited bluetooth syncing in the car for now. ;)
     
  11. fredphoesh

    fredphoesh Active Member

    Joined:
    Dec 30, 2009
    Messages:
    36
    Likes Received:
    0
    I am pretty sure the issue is with my BMW and not the phone, my SGS1 worked fine, but my new SGS2 not... and I think it is something to do with bluetooth versions... actually at first my SGS did not work with my 2008 bmw, but started working at some point - which I put down to burning a new ROM for my phone.

    I wonder if

    1/ changing modems in the phone would make a difference
    2/ downgrading the bluetooth version in the phone would make a difference.

    AFAIK BMW do not take responsibility for this... that they have a compatibility list and everything else is at your own risk. It would be great to get to the bottom of this.

    Mark.
     
  12. psyxologos

    psyxologos Well-Known Member

    Joined:
    Jul 8, 2010
    Messages:
    237
    Likes Received:
    20
    I had a similar problem:

    Both my wife and I have HTC Sensation (Android phones) and both connect to the same car (BMW 530d Tourer F11) no problem. Both get the messages all right, my wife's phone gets the address book all right and the contact details stay there. Mine connects OK the first time I pair the phone, both messages and address book. After three minutes the address book is nowhere to be found, and I get a 'no contacts stored' on the professional navigation screen.

    When pairing both phones for the first time to the car, I get a pop up screen asking me if I want to allow the phone to share my address book with the car. In both cases I chose yes and tick the box that says 'always accept'. But while in my wife's case the address book stays, mine disappears. The funny/weird thing about it is that my address book information (name of contact etc) is there (on the dashboard underneath the rpm and tachometer) if I press the telephone button in my steering wheel, as well as appearing in my 'last numbers' and 'missed calls' and 'received calls' on my professional system. But as I said, it does not appear in my 'phone book' category in the professional system.

    If I delete and unpair my phone and the car and re-pair, the same thing happens. Phone book appears for a few minutes and then disappears again...

    This is what worked for me:

    After restoring the phone to factory settings, my car and phone synchronised! Next morning everything was lost again! So I though to myself, what have I done since resetting the phone (and the address book worked in the car) and up to the moment where it stopped working? Well, I had added pictures to some of my contacts. this, for some reason stopped the phone sharing messages and the address book with the car. The messages stopped being updated (so only messages from up to last night were displayed) and the address book went. After I removed the pictures the address book and the messages synchronized again.
     
  13. Epicurean

    Epicurean Well-Known Member

    Joined:
    Sep 1, 2010
    Messages:
    438
    Likes Received:
    54
    Have you considered trading vehicles? ;-)
     
  14. jondiehl

    jondiehl Active Member This Topic's Starter

    Joined:
    Dec 20, 2009
    Messages:
    31
    Likes Received:
    0
    LOL, hell no!

    I finally got it to work today though! I just updated my rooted Epic 4G with an ICS rom and my contacts are back in my M6's iDrive system. woot woot!
     

Share This Page

Loading...