[Boost Mobile] For Discussion of Development for CM7 Only


Last Updated: 2012-11-29 05:38:14
  1. hroark13

    hroark13 Well-Known Member Developer

    My Prevail CM7 thread has 2,4308 replies

    No one will ever want to read it because it is way too long

    I want this thread to stay on topic
    The topic is the development and bug fixing of CM7 for the Warp
    Do not post thank you posts, I know that you appreciate my work, but that type of post will make this thread too long, please just click the Thank You button, and the Ratings Stars Above

    This thread is for developers, testers and those who want to learn how to test and develop
    Another exists for install support and other stuff here
    http://androidforums.com/warp-all-things-root/520578-cm7-pre-alph-help.html#post4118799

    This thread is NOT for helping anyone install the ROM
    This thread is NOT for helping anyone setup and Android Build system
    THIS THREAD IS NOT FOR MODDING THE ROM WITH TWEAKS AND SCRIPTS
    START ANOTHER THREAD FOR THAT STUFF

    This thread is about compiling my CM7 source code

    I know there is other CM7 sources by Quietestorm, and I helped him a bit to get CWM working, but this thread is only for my source code

    This thread is about fixing my CM7 source so that it works with the Warp hardware

    This thread is for reporting bugs with the source code, and discussions on how they can be fixed

    Please keep this thread on topic

    OK so now that I got that out of the way, the Warp forum has asked me to help with CWM,CM7 and made donations, so that I can get a WARP, Thank You to all who donated

    This 1st OP post is the only post that is allowed to have the words thank you in them

    The development thread starts in post 2



    If I have helped you, and you like my work, please click on the Thanks Button and give my thread a rating by clicking on the stars above.

    If you would like to buy me a beer cofee, you can click on the PayPal button

    [​IMG]

    Advertisement
  2. hroark13

    hroark13 Well-Known Member Developer

    Here is the source code

    http://www.mediafire.com/?0mmfbz5y2jjg0pl


    Here is the version of CWM you need to install the ROM


    If you already have CWM you can update it with this zip file
    http://www.mediafire.com/?2c8dr53ttbbmq1n


    If you don’t have CWM you have to flash this image with Fastboot
    http://www.mediafire.com/?6oqw67hruadjpwj


    Here is the latest version of the ROM that you have to install with the new CWM
    http://www.mediafire.com/?ndsyetj52j6nnkg

    Here is the latest patch for the latest version of the ROM
    http://www.mediafire.com/?k96hdi5h379mh1n


    IF ANY ONE ASKS HOW TO DO THESE THINGS I WILL DESTROY THE UNIVERSE
  3. hroark13

    hroark13 Well-Known Member Developer

    STATUS

    This ROM is odexed and has to stay that way until everything is fixed
    I do not like waiting for a de-odexed ROM to boot, when I am rebooting 30 times per hour doing trouble shooting

    WORKING

    it boots (yey)
    Audio
    Screen Rotation
    Bluetoothe (pre-alpha1-patch1)

    NOT WORKING

    RIL (telephony, 3G)
    WiFi
    GPS
    Camera
    Most Stuff


    MAJOR BUGS



    MINOR BUGS


    Phone crashed once on boot and reboots, (you will notice the Boot animation restart)







    .
    ZTEAndroidWarp and AndroidxD like this.
  4. hroark13

    hroark13 Well-Known Member Developer

    change log

    03/23/12 initial release pre-alpha1
    03/24/12 pre-alpha1-patch1 - fixes bluetoothe and new boot animation
    AndroidxD likes this.
  5. hroark13

    hroark13 Well-Known Member Developer

    reserved
  6. bads3ctor

    bads3ctor Well-Known Member

    How do you do these things? Hmmm....I closed my eyes and the universe exploded :D

    MODERATORS...PLEASE BLOW OFF THIS POST...B4 HROARK13 DESTROYS THE UNIVERSE! THANK YOU

    hroark13.....I made a frankenzip(what I call a zip I put together from mismatched roms!) from your /system and my updater-script and flashed it to the Transform Ultra and it booted.....well....almost! It booted for like 2 minutes and then went into ram dump mode....weird. I'd be willing to bet it will not boot without CIQ.
  7. hroark13

    hroark13 Well-Known Member Developer

    Snake X and AndroidxD like this.
  8. hroark13

    hroark13 Well-Known Member Developer

    the thing I want to fix, that is driving me crazy is the screen not waking up and the phone not rebooting correctly if you set the phone to stay awake

    there is a section in the kernel init.arthur.rc that looks like this

    on boot

    #ZTE_TORCH_YTC_20110913 BEGIN
    # NOTES FROM HROARK - CM7 DOES NOT BOOT WITH OUT THIS SECTION)
    # KEEP THIS AS THE FIRST SECTION UNDER on "boot section"
    chown system system /sys/class/leds/flashlight/brightness
    chmod 0774 /sys/class/leds/flashlight/brightness
    #ZTE_TORCH_YTC_20110913 end



    this i believe is some how related to this issue, i was changing some of the permissions in that sections and the the phone would not boot


    so ultimately this is probably an issue with the kernel zImage and ZTE added that section to work around the issue with the kernel

    from what I gather we do not have working source code for the kernel

    I have have tried compiling the kernel source code but it will not boot the phone

    I have also noticed in the stock ROM I was having some issues with the phone not waking, but this was more erratic and only happened once in a while I think




    ,
  9. ron580

    ron580 Well-Known Member

    i don't think those lines have anything to do with the screen not waking up. isn't that for the led flash in the back? while searching through the file system i found that if you set /sys/devices/platform/leds-gpio/leds/flashlight/brightness to 255 it enables the back led flashlight

    edit: im guessing zte left out files from the kernel, is it possible you can fix it as you did on the prevail.
  10. downthemachine

    downthemachine Developer Incognito VIP Member

    Well it compiles, we just haven't been able to make one boot. Shinjitsu sent out an email to zte to see if they have any input.
  11. shinru2004

    shinru2004 Well-Known Member Developer

    There reply was amazing too

    Dear Valued ZTE Customer

    we really understand but Sorry to inform you that we can't provide this now .

    Should there be further assistance, please do not hesitate to contact us.

    Best Regards
  12. hroark13

    hroark13 Well-Known Member Developer

    OK it seems the issue with the screen coming on after power button and sleep is an issue with my new phone, I am going to exchange it, and take those issues of the list of bugs
    Snake X and Spiyder like this.
  13. JBrd400

    JBrd400 Well-Known Member

    Just wanted to get some clarification regarding an issue I'm getting when compiling CM7 using hroark's source. During build, I get errors complaining about the code to create shared libraries being found in 2 different locations. (once in the Cyanogen source and once in the arthur source)

    Is it safe to say that the arthur-specific code should take precedence? (i.e. device/zte/arthur/libaudio) If so, is it just a matter of commenting out the corresponding code in the Cyanogen source or is there a better way to resolve the conflicts? (since there are multiple shared libraries that are duplicated)
  14. hroark13

    hroark13 Well-Known Member Developer

    so you are compiling this with out any changes and it it is stopping in the process, with that error ?


    can you tell me how you are trying to compile this ?

    have you made any changes to and of the files, either mine or the CM7 source ?



    just give me a brief list of everything you have done





    ,
  15. hroark13

    hroark13 Well-Known Member Developer


    this is how I compile it


    make clean
    make clobber
    source ./build/envsetup.sh
    lunch ZTE_Warp-eng
    mka -j4 bacon



    ,
  16. hroark13

    hroark13 Well-Known Member Developer



    ok i just tried to compile the source from github and got that error too

    may be it is something I changed is my last commit

    i will look in to it



    ,
  17. hroark13

    hroark13 Well-Known Member Developer


    it seems that github is not reflecting the stuff that I deleted, in my local folder

    I am probably doing the commits wrong

    for now you can download this and put it in your device tree this is the current version I am using

    arthur03-29-12.zip







    ,
    Snake X likes this.
  18. JBrd400

    JBrd400 Well-Known Member

    I'm basically starting over from scratch as I thought my cyanogen source got screwed up so I deleted and re-downloaded the CM7 "git" files last night. (same errors though) I have made some small changes, but I think they are required for CM to build.

    Here's what I've done so far:

    Created an "arthur" folder in ./devices/zte and copied the files from your github in there.

    Created a new cyanogen_arthur.mk file in ./vendor/cyanogen/products as it wouldn't even try to build without that. Just copied the config for the blade and modified product info based on your build.prop. (hopefully that was the right thing to do)

    Ran "source ./build/envsetup.sh"
    Ran "lunch" and selected ZTE_Warp. This failed initially. With the error below. Had to add "-eng" to the end of the value in vendorsetup.sh and it seemed to work fine after that.
    Ran "make clobber clean" and deleted the ./vendor/zte/proprietary folder as I did try adding some different files to the build previously. Removed it for the sake of testing and still get the same error.

    I normally run the actual builds using CM Compiler, however I also tried using "mka -j2 bacon" as well and get the same error. If I look in the Android.mk file in both of the locations shown in the errors, I do see code to set up the various shared libraries. (code is similar, but not the same) Just for the heck of it, I commented out all the CM code and it still wouldn't build right...got errors related to Wifi. (same result when I commented out your code and left the CM stuff. So I'm not sure what's going on, but I'm pretty confident I won't be figuring it out by myself. :) Anyway, here are 3 libraries that it's hanging on if it helps.

    Sorry about the long post, but I believe that is the extent of my changes. I'm almost positive I didn't make any other changes to your code or the CM stuff.

    Edit: Eh, sorry...didn't notice your posts as I've been typing for a while... haha Glad you were able to reproduce the errors though. Will try out the files in your .zip.

    Edit again: I renamed my existing "arthur" folder and pasted the contents of your zip into a new one. Now I get a similar error, but for libaudioalsa. Get the same if I overwrite the existing source files as well.

  19. hroark13

    hroark13 Well-Known Member Developer


    you are doing too much, and making it complicated

    do not just rename the old arthur folder delete it or move it out of the cm7 folder

    just take my zip in the above post and unzip it into the device/zte/arthur folder

    make clean
    make clobber
    source ./build/envsetup.sh
    lunch ZTE_Warp-eng
    mka -j4 bacon
  20. JBrd400

    JBrd400 Well-Known Member

    I tried it renaming the arthur folder and creating a new one only with your .zip contents and also using your existing source and overwriting with the zip contents. Same result either way. Not sure what I'm doing that's too much though. As far as the actual build goes, I'm running effectively the same commands you are. (though it may be hard to tell how I listed everything) The other changes like creating cyanogen_arthur.mk and modifying vendorsetup.sh, etc. were necessary to get the build to work as well. Just wanted to give the full picture in case one of those other steps could be the issue.
  21. hroark13

    hroark13 Well-Known Member Developer

    not for me
  22. hroark13

    hroark13 Well-Known Member Developer


    do you want me to remote into your system some how , and do it

    because I am not sure if you are understanding my instructions
  23. JBrd400

    JBrd400 Well-Known Member

    Okay, good to know. I removed both changes and did the steps you mentioned.

    Now it's hanging at libaudiopolicy again. Sorry, but I must be missing something if it works for you with the latest zip. If you want to remote in, that's fine with me. Teamviewer?
  24. hroark13

    hroark13 Well-Known Member Developer


    Ok

    I have never used teamviewer, but I will install it now

    what info do I need for it ?
  25. JBrd400

    JBrd400 Well-Known Member

    It's a nice app and free for personal use. Once you get it installed, you'll need my ID/password to make the connection. Can I email you through the forums or send you a PM?

Share This Page