1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

[Boost Mobile] How to: Stop 4.3 MK5 Update Notification


  1. mydian

    mydian Well-Known Member

    Update: to block the 4.4 Kit Kat update follow the information below but use the build # L710VPUCNJ3 instead of L710VPUBMK5.


    I figured there are others like me avoiding the MK5 4.3 update so I thought I would post how to stop that annoying notification once and for all. There are other methods that say to freeze this app or rename this file but both those methods mess up other things. The correct way is to modify your build.prop.

    The following instructions are how to modify the build.prop manually but there also are build.prop editors you can use. However I've never really messed with any so i won't be able to provide much help if you have a problem. If you use a build.prop editor then you only need to look at steps 1, 4, 5 & 6. Please make a backup with a custom recovery first.


    I am not responsible if you brick or damage your phone! I have done this mod successfully on my phone and my old phone when I wanted to block it's OTA. I can't stress enough how important it is to make a backup before modifying /system! While there are quite a few steps listed below this is a pretty simple process. Basically all you need to do is copy a file, edit 2 words (sort of), rename the old file (to create a backup), then replace it with the new edited version.

    1. Boot into recovery and make a backup! This is very very important even if you are using a build.prop editor. If you modify your build.prop incorrectly you could end up stuck in a boot loop. After you make a backup restart back into Android.

    2. Using your favorite root explorer (I use ES File Explorer) navigate to /system and copy your build.prop to your sdcard.

    3. Open the build.prop in a text editor (I use the one built into ES File Explorer.)

    4. Scroll down 10 lines or so. What you're looking for is the 2 lines after:
    I find it easier to look for that line.

    5. The 2 lines you need to edit are one right after the other:
    6. Next replace L710VPAMG2 with L710VPUBMK5 in both lines. When you're done it should look like this:
    7. Make sure system is mounted as writable.

    8. Navigate back to /system.

    9. Rename your old build.prop found in this directory to build.prop.bak (it's always good to have backup!)

    10. Copy your newly modified build.prop to /system

    11. Check the permissions for your new build.prop. I had to add the read permission for group and other (it should be 644).

    12. Navigate to /cache and delete the OTA update. It should be a zip file with a real long file name. The file name for me ended with MG2_to_MK5_Update_FWD.zip. On my S3 it was the only zip file in that directory.

    13. Make sure system is no longer mounted as writable.

    14. Reboot your phone. After first boot if the OTA notification is still present just swipe it away from the notification shade (don't click on it.)

    And that's it. I haven't had any update notification for 2 days now.

    This should work with any rom (and any carrier) but if you're running a Sprint rom the build # you're changing may look different. Also if you have a custom rom there may already be a flashable zip to fix your build.prop. Moar & Wicked Sensations both have zips.

    One other thing. Only change the build # in the 2 lines that are posted above. Changing Android version numbers or the build # in other places could cause unwanted results. For example, if you go to settings, about phone, you'll notice it still says MG2 after this fix. But Boost thinks you're on MK5. ;)

    Enjoy!

    Advertisement
  2. Capn069

    Capn069 Well-Known Member Contributor

    Good work bro. :thumbup:
    mydian likes this.
  3. mydian

    mydian Well-Known Member

    Thanks. Last year when I wanted to do this to my old phone I read so much misinformation. I hope this helps somebody out. I posted it from my phone so when I get home I may clean up the formatting a little.
  4. struckn

    struckn VIP Member VIP Member

    I second that, nice tutorial for a problem that I am seeing reported by users left and right.
    mydian likes this.
  5. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Nice write up :D

    Have you tried putting it in a flashable zip file? :thumbup:
    mydian likes this.
  6. mydian

    mydian Well-Known Member

    I cleaned it up some so it should be easier to read. I swyped that at work using Evernote and then copied and pasted it lol.

    Thanks I saw a couple posts today asking how to block the update so that's what prompted me to do it. Especially since it's pretty easy to do.

    Thanks. I thought about it, or even just posting the build.prop but that would only work for the stock rom. This fix should work for every Sprint 4.1.2 TW rom. That and I don't know how to make a flashable zip. :eek:
  7. struckn

    struckn VIP Member VIP Member

    Flashable zip creation is a skill I would like to learn as well! However, it would do a lot of people good, especially those who are more noob than expert, to get "hands-on" with some things and know more of the nuts and bolts associated with being rooted. I am no expert on the technical side, not by a long shot, but I can do all the most important things myself without a "one-click" or third-party solution that just does it for me and I hope it works without bricking my phone. At least if my phone does get screwed up I can blame myself for not following instructions, and that is the way I prefer it!
  8. mydian

    mydian Well-Known Member

    Updated thread for blocking Kit Kat. New build to use is: L710VPUCNDC

  9. alpha2k

    alpha2k Well-Known Member

    There is also a sure fire easy way to disable the nag with a file I use that also stops the ota nag. The file is called FOTAkill.apk.

    If your rooted just place this file in system/apps folder and reboot. Once rebooted it should not nag you again.

    I find this way much easier to do than editing a prop file as it take a single move and a reboot. Not that the editing the prop file doesn't work, just for me, it's less work and step this way.
    mydian likes this.
  10. mydian

    mydian Well-Known Member

    To block the newest OTA the build to use is: L710VPUCNJ3
    cwhatever and RuutNuBe like this.
  11. RuutNuBe

    RuutNuBe Active Member

    Thanks mydian. I deleted/moved the ota zip the day I got it and I haven't gotten another update notification yet.
    mydian likes this.
  12. mydian

    mydian Well-Known Member

    I still haven't gotten one at all. I'm waiting for it in hopes to catch the tar.
  13. RuutNuBe

    RuutNuBe Active Member

    My wife still hasn't gotten it either. I'm wondering if it has something to do with the fact that I used the paid app Wifi teather router at work and pumped over 2 gig of data through my hotspot in about an hour about two weeks prior to getting the ota. Maybe some kind of plug??
  14. RuutNuBe

    RuutNuBe Active Member

    Just modified the build.prop to L710VPUCNJ3. Followed directions exactly but for some reason it boot looped. Had to do a philz restore to correct the soft brick. All is ok now, except for the persistent ota notifications.
  15. mydian

    mydian Well-Known Member

    That's strange since I have done this to my phone to stop the latest update notification and it worked fine. Did you remember to set the permissions?
    RuutNuBe likes this.
  16. RuutNuBe

    RuutNuBe Active Member

    I know I did something wrong. Just can't figure out what. ES file explorer showed system properties set as rwx-rwx-rwx. I must have changed this previously so I left it that way. Build.prop was set to rw-rw-rw. Just the two lines were edited with ES editor. I'll try again when I have some time but am a little nervous. This was my first soft brick.
  17. mydian

    mydian Well-Known Member

    Just make sure you make a backup first and you'll be fine. Worst case scenario you just have to restore it.
    RuutNuBe and cwhatever like this.
  18. RuutNuBe

    RuutNuBe Active Member

    Do you think my exposed framework could have been an issue? Looked around xda but didn't find any mention of it. I hate to uninstall exposed on just a unfounded concern.
  19. mydian

    mydian Well-Known Member

    No I don't. I'm using xposed and it's working fine. Although the only module i use is Wanam. Maybe try a different editor? I use Total Commander for my file browser now and used it's built in editor.
    RuutNuBe likes this.
  20. RuutNuBe

    RuutNuBe Active Member

    Working fine now. My second try went smoothly. Thanks for your help. I copied/pasted the first time. Maybe I got an extra space or something.
    mydian likes this.
  21. mydian

    mydian Well-Known Member

    That could be. I'm glad you got it working. :)

Share This Page