[Boost Mobile] Root after B08c update (should also work on earlier builds)


Last Updated:

  1. vitalitouch

    vitalitouch Well-Known Member

    I cannot get the new nandroid to work. I downloaded the file from woodstock, ran system reset and cleared cache and davik cache from CWM and it said it wont mount sd card. I tried to reboot phone, and it just hangs at the green android at startup. I read around the forums and see that the sd card could be the issue. (i had a 16mb class 6 sandisk in, so i swapped back into the original card.) When i tried to restore with the new card in place, it reads the card just fine, but im getting a MD5 mismatch error. Anyone? I had woodstocks slightly modified nandroid installed prior with no issues. I'm sure im just missing something somewhere. Hopefully someone has a thought. Thanks everyone.

    P.S. In a moment of desperation, i tried to restore the old nandroid so i could at least use the phone, and it now wont load the old one, or any of my backups either. It keeps saying md5 mismatch :(

    Advertisement
  2. Rally 517

    Rally 517 Well-Known Member

    i would say either recopy to sd card or redownload whole file. happened to me when i did my girls phone today should work then
  3. Woodstock77

    Woodstock77 Well-Known Member

    Thats gotta be one of your apps. Make a list here and lets try and figure out which one it could be. When I was still using mine alrm clock extreme and words with friends were the only app I had issues with.
  4. vitalitouch

    vitalitouch Well-Known Member

    I just wanted to update everyone, in case someone else has same issue... I was getting a md5 mismatch error. I deleted every nandroid i had from my sd card, went back to the original sd card, and re-downloaded the newest woodstock nandroid...unzipped, restored, PRESTO! SUCCESS! Thank you everyone for all your work, and care in this form....I feel so connected :)
  5. dylanp

    dylanp Well-Known Member


    Thanks Woodstock...here goes, also I uninstalled adfree, skyfire browser and a couple of go launcher themes but this is whats currently installed


    amazon
    spades
    amazon kindle
    speedtest
    appaware
    spin to riches
    beautiful widgets
    superuser
    beautiful widgets animation
    tetris
    bills t
    itanium backup pro
    bravose
    tweetcaster pro
    busybox free
    uno
    cache cleaner
    volume +
    contact remover plus
    voodoo OTA rootkeeper
    coupon closet
    weather forecast
    deal leak
    wireless tether
    dolphin browser hd
    word search
    dropbox
    you tube
    ebay
    bank of america
    facebook
    google voice
    fast reboot
    groupon
    my backup pro
    living social
    opera mini
    lose it
    pandora
    yahoo mail
    phandriod
    market enabler
    quick boot *installed today*
    gmail
    root explorer
    link2SD
    screenshot
    jorte
    shopsavvy
    key ring
    smart office
    gin rummy
    software data
    freecell
    file expert
    four square
    flash
    flixster
    GO Contacts, Dialer, Keyboard, Locker and Launcher EX
    GO SMS, GO store, GO widget

    I also have all of the stock apps installed...why although I've been rooted forever I dont know...im also thinking about changing my PRL back since I had to wipe the phone,,,that works best at work for me so I will be doing that in the next few minutes I guess

    I have had titanium backup for a bit but recently bought the pro license incase of emergencies like this but i hope i backed up correctly and I mean maybe i could have just backed up all users apps and thats it no user info or anything so i would have to relog into my apps fresh...just thinking that hopefully I didnt copy something back over to the phone from an app or data that was an issue
  6. dylanp

    dylanp Well-Known Member

    Sorry...not finished but I have several go launcher and go sms themes that I did not list but I can, 19 launcher themes and 20 sms themes....obsessive I know and I deleted a few today...smh
  7. Woodstock77

    Woodstock77 Well-Known Member

    I would start by looking at apps that run in the background alot. I would just pick 5 apps uninstall them and see if it stops doing what its doing. If it does I would reinstall one at a time until you find the culprit. If uninstalling those five doesnt fix the problem reinstall all five and try five others and so on a so forth.
    If I had to guess the most likely problem apps I would say

    • yahoo mail
    • bravose
    • tweetcaster pro
    • cache cleaner
    • living social
    • four square <<<notoriously bad app
    • appaware <<<notoriously bad app

    Go through all of your apps and see if any have ads in them.
    Apps arent built with viruses in them normally but apps that have ads involved with them are known to open a way for viruses to get onto your phone. I would get adfree off of the market and use it to eliminate ads. I know alot of people who only root so that they can use adfree.

    I personally dont understand having that many apps. Well I do but you have so many that kind of do the same thing. That i dont understand. I mean you have three browsers. Why?
  8. dylanp

    dylanp Well-Known Member

    i had adfree installed but it didnt seem to work for me but I may not have been loading it correctly...I figured you would notice the similiar apps and for the browsers I like dolphin because it brings up mobile sites right away and it is easier for me to log in to a few things, then i like opera because it does both and seems to run pretty fast. I also have file explorer and root explorer to see which works best to manipulate files and just havent removed one of them yet, I like the ease of file explorer because root explorer seems intimidating...I can go on and on with a few others but I wont:D its funny that you mention viruses because one of my emails seemed to get hacked recently and I have virus protection on my laptop so I was thinking it had to be the phone so I installed lookout...which found nothing but it seemed to lag the phone so i uninstalled that about two days ago...I will definetely take your suggestions and remove a few and see what happens...im so surprised at foursquare I love that app...im mayor all over the place haha but if it has to go then its fine too...thanks again I will update you after my testing:D
  9. MrBobo

    MrBobo Well-Known Member

    maybe to help eliminate some possibilities, my phone does not restart and I put a star next to the ones I have installed as well.

    not sure why you would need these ones:

    link2sd (you running out of space on the phone?)
    cache cleaner (just my opinion that these do more harm than good)
    dylanp likes this.
  10. TheTenthLetter

    TheTenthLetter Active Member

    So... I currently have CWM Recovery, but I can't run the B08c update without FTM mode. However, I can't get FTM mode without reverting the Warp to stock. To top it off, the stripped-Nandroid build that you made available is only B08, with the B08c Nandroid still containing the Boost Zone/Mobile ID/etc. I know its early in the morning still, but am I missing something here? I feel like I'm running in circles trying to figure this out :\
  11. Woodstock77

    Woodstock77 Well-Known Member

    That latest nandroid is b08c. Yes in order to update you have to put stock recovery back on then update then put CWM back on. If you use my one click installer linked in the OP (Original Post) then that would be easy as one click for you to do. If all this is just too much to do for you and your happy with your phone just leave it at b08b. I didnt make this stuff hard for you bro. Im guessing you are wanting me to strip a b08c nandroid for you. Somebody should I think but it wont be me. I dont even use the Warp anymore. I only did this much because I care. If its not enough then so sorry for your bad luck bro.
  12. TheTenthLetter

    TheTenthLetter Active Member


    Cool bro. Thanks for the response. Wasn't a fan of all the icon/graphical updates so I'm going back to stock... bro. ;)

    Really though... my only concern was getting CWM back on after multiple people reported that they're weren't able to achieve that post-update. Appreciate the snarky response though... Thanks, bro. I knew this place was getting a little too chummy lately.
  13. MrBobo

    MrBobo Well-Known Member

    I followed Woodstocks method using his two batch files to go to stock recovery then update and go back to cwm recovery and used the zip on the op to root, it all was painless
    dylanp likes this.
  14. esparks004

    esparks004 Well-Known Member

    Can someone help? I have followed the instructions, but cannot get past installing the correct usb drivers for adb. I get to the point where it is waiting on my device. I go into device manager, update driver on Android yellow exclamation point, browse to the location i downloaded the usb files to. When i click ok to install, it doesnt install the drivers. Any idea, i have tried front/back usb...i have downloaded and installed the android-sdk and installed google usb drivers. im running this on xpsp3...is that an issue?
  15. TheTenthLetter

    TheTenthLetter Active Member

    I feel your pain... Someone else around here was recently having issues with XP, think they figured it out though. I'll see if I can help find that post...
  16. esparks004

    esparks004 Well-Known Member

    Well my issue is not Xp related. I am home now and running win7 64bit, still cannot install the drivers. I did not previously have CWM installed. I have already updated to c and want to install CWM so i can root. Steps i have taken:

    1. updated firmware using ZTE Tool.
    2. Downloaded usb_drivers file and zte warp recovery installer.
    3. checked usb debugging/unknown source setting
    4. connected phone via usb...can see phone in device manager
    5. ran as admin file Flash_CWM_recovery
    6. file reboots phone, phone stays at green man while file process is stuck at waiting for device.
    7. click update drivers on other device Android in device manager...browsed to usb_driver location. click install...but nothing happens. does not install drivers.

    What am I missing? Any help would be appreciated. Thanks.
  17. Woodstock77

    Woodstock77 Well-Known Member

    Ok at this point your at the green android and nothing is happening.

    Go to device manager and look.
    You should see up at the top something like this.

    [​IMG]

    Or it could show it as having a bad driver or wrong driver. Either way it isnt working and what you do next is right click and choose Update Driver Software.
    Next choose Browse my Computer for driver software and ok.
    [​IMG]

    Now choose Let me pick from a list of device drivers on my computer.
    [​IMG]

    Click have disk and choose the drivers you downloaded
    Now Uncheck Show compatible hardware.
    You should now see several options. Try each one and try to continue the CWM install after each try until you find the correct driver for adb during bootloader.
    [​IMG]
    My guess it is going to be adb bootloader interface.
  18. alpha2k

    alpha2k Well-Known Member

    I had this in Xp Pro SP3 and what I did was just choose update driver, then instead of choosing from the list, I let windows find the best driver, it found what it needed and worked ever since.
    I have seen people choose from the list, but I decided to let windows do it's thing for a change, and it worked fine.
  19. esparks004

    esparks004 Well-Known Member

    Thanks Woodstock77....my options was many to pick from....since my device was listed as other android....listed was an option for ADB interface...once i selected that option it gave me many options for ZTE....i selected ZTE single ADB interface and all is well...waiting for devices...found my device process went smooth following. Thanks Again.
    nookout and Woodstock77 like this.
  20. dylanp

    dylanp Well-Known Member


    Thanks for the advice...I'm an app-a-holic and I know it :D I uninstalled yahoo mail, foursquare *tear* and I have had NO reboots since doing that this morning...I have link2sd because I figures that the more stuff I can put on the SD card the better the phone should run with out all the junk since I install apps at the drop of a dime ooohhh and I uninstalled cache cleaner, I thought it would help because I am on the internet like crazy and I have a sweeper sort of thing for my laptop to clear cache there so I figured why not let something do it for the phone....I may try to reinstall one of the apps but probably not...but I hate the stock email app which is what i am using for my yahoo accounts...maybe I will happen upon another, the stock is so plain, Im a visual person:D you guys all ROCK!
  21. Rollout

    Rollout Active Member

    I have followed Woodstocks tutorial. I still can not get this rooted... It stays on the green droid after reboot, and no driver will allow me to install, they all say that the driver does not contain information about my hardware.
    2 days of trying, on 2 different computers.
    The real bummer is that I used Titanium backup, and now I can not restore my apps, and settings until I get this rooted.
  22. Rally 517

    Rally 517 Well-Known Member


    just use the bo8c nandroid made by woodstock its rooted
  23. esparks004

    esparks004 Well-Known Member


    I was in the same boat....I was able to follow WoodStock77 advice above(post #67)...and got it to install. I didnt use the drivers provided. I did as he said and choose from the listed devices.
  24. sidewinder767

    sidewinder767 Member

    OK Woodstock : It has to be my driver install here because where yours is listed as Android phone at the top of the list mine is listed as ADB Interface with a drop down of ZTE Composite ADB Interface underneath. I looked for the driver as you showed in the pic's above but there's no bootloader at all in the list. I do know how to install an uninstall drivers it's just not working. I think the zte adb bootloader driver are not installed properly. So......If someone can tell me how to install the correct ones it will probably work fine. I hope ! I'm running 64bit w/7 . Thanks............
    $$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$

    DRIVERS - -DRIVERS - DRIVERS

    ############################################################
    UPDATE : This is the fix for me and probably others. Xoriths post below got me rooted with CWM. Many thanks to Xorith and others. Backing up with titanium backup now !

    Hello folks!
    I, too, was having a difficult time getting Windows 7 (64-bit) to update the drivers. I even installed the latest SDK general drivers. It would keep going back to saying that "Unknown Device" was the best driver for my hardware. When I'd try to force the issue by using "Have Disk..." it would then tell me that the android_winusb.inf did not contain driver information suitable for a 64-bit OS...

    So I Googled my heart out until I found this:

    -- Okay, I can't post links - no matter how helpful they might be... so instead let me tell you to Google for "Making Fastboot work on 64-bit Windows 7 systems" and it should be the very first link

    It's a quick guide that I found which uses PdaNet's drivers and it worked great for me!
    Spanked and Hexadecimus like this.
  25. Hexadecimus

    Hexadecimus Well-Known Member

    Thank you!

    And sticky this thread!!!

Share This Page