1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[Boost Mobile] Testers wanted

Last Updated:

  1. Sebastian404

    Sebastian404 Well-Known Member

    Ok guys, I have a build of Clockwork Mod Recovery and I need someone to test this...

    first of all I want to get the disclaimer out of the way.

    I don't own a ZTE Warp device, and am thus unable to verify the functionality of these files, any loss of data/warranty/limb/life or other such damage is your own problem.

    However, I am I professional, and I have done this a number of times so confidence is high. also I find worse case you can go back to your provider and say 'it just broke, I do not know what happened' and they will likely give you a new one.

    with that out of the way.

    ClockworkMod recovery:


    Support files:


    Generic USB drivers (From latest SDK)


    Once you have the correct usb drivers installed (if your on windows) do the following:

    2. adb-windows.exe reboot bootloader
    3. fastboot-windows.exe flash recovery b2_recovery-clockwork-
    4. fastboot-windows.exe reboot
    5. adb-windows.exe reboot recovery
    (if your on linux change '-windows.exe' to '-linux', OSX use '-mac')

    normally the method to get into clockwork mod recovery involves turning the device on while holding the volume down button, or it could be volume up, or any other combination, try it and report back.

    I am a big OSX and Linux fan girl, and I know the majority of issues people will have is with drivers, I'm not going to be able to help out there too much, I hope the rest of the community will.

    Any and all feedback would be great... as I say I cant test it, but it should work..... let me know

    *the board is called arthur that is why the file is named so.

    Spanked, shinru2004 and TCA4000 like this.
  2. TCA4000

    TCA4000 Active Member

    Hey when I get settled in at work i will test it and let u know. Thanks for your hard work so far:D

    Can I push the image using terminal on my phone? If so what commands do I use?
  3. TCA4000

    TCA4000 Active Member

    Bump sorry
  4. TCA4000

    TCA4000 Active Member

    Bump again sorry!!!
  5. Sebastian404

    Sebastian404 Well-Known Member

    Im not sure if that whould work from a partial root, but you could try putting flash_image and the recovery.img onto the sdcard and then

    cp /sdcard/flash_image /data/local/
    chmod 04755 /data/local/flash_image
    /data/local/flash_image recovery /sdcard/recovery-clockwork-
    reboot recovery

    But really adb is he best way
  6. Woodstock77

    Woodstock77 Well-Known Member

    You would be suprised how many people have trouble just installing adb on a windows pc. When I have time tonight I will test it out.
  7. Woodstock77

    Woodstock77 Well-Known Member

    Ok so I did as above. On this step I get an error.
    1. adb-windows.exe shell /data/local/flash_image recovery /sdcard/recovery-clockwork-
    Its says segmentation fault.
    So I continued and when i try to boot into custom recovery I get a screen that has a small white window that says FTM and it gets stuck there.
  8. aladdin99

    aladdin99 Well-Known Member

    you did power+volume down which enters ftm mode. I believe it is the same as download mode on Samsung phones. Try power+volume up.
  9. Woodstock77

    Woodstock77 Well-Known Member

    Yeah with that I get stock recovery.
  10. TCA4000

    TCA4000 Active Member

    i have adb installed on my computer at home, I was asking because I was at work and we can not install it there.:D
  11. Woodstock77

    Woodstock77 Well-Known Member

    I was wrong about needing it. Everything is right there in those support files to download. But I cant get it to work. If I follow the first directions at reboot to bootloader it hangs at the android logo. If I follow the second instructions I get segmentation fault. Ive been looking around and it seems to be a permissions problem.
  12. TCA4000

    TCA4000 Active Member

    I got the same results as Woodstock77 did. I even tried the advice you gave me earlier and still got the same segmentation fault. Any ideas of what going on?:eek:
  13. Sebastian404

    Sebastian404 Well-Known Member

    The green android screen is the bootloader.. If you want to check try..

    Fastboot-windows.exe devices

    It should find your device..

    As to the segfault.. I re-complied a new version of flash_image using the latest NDK, incase that is the issue, I've tested it on another ZTE 2.3.5 device I have and it works fine... can you re-download the support.zip and try that?
  14. Woodstock77

    Woodstock77 Well-Known Member

    Ok then while at bootloader we loose coms.
  15. Sebastian404

    Sebastian404 Well-Known Member

    have you installed the USB drivers I linked in the first post? you need a different set of drivers for the bootloader than ADB..

    nothing is simple when it comes to windows and android I'm afraid...
  16. Woodstock77

    Woodstock77 Well-Known Member

    well I was able to communicate and the img file is on the sdcard but I will try a few more times.
  17. Woodstock77

    Woodstock77 Well-Known Member

    Ok so in bootloader its looking for a different driver. The one linked above doesnt work. I searched and cant find a compatible driver.
  18. Woodstock77

    Woodstock77 Well-Known Member

    ok Sebastian404 I didnt see where you had edited your last post. Tried everything again. On the first set of instructions I get: [​IMG]

    On the second I get:[​IMG]

    Both of them after reboot to recovery I hang at bootloader. I tried power+up volume. Nothing. I dont even have stock recovery now.

    I can see something about "error scanning partitions" could be a permissions fault maybe?
  19. Sebastian404

    Sebastian404 Well-Known Member

    Having poked around the ROM somewhat I've noticed a few interesting things, and I think part of the issue here is they have used EXT4 file systems rather than the more usual yaff2, thats why I think flash_recovery wont work.

    And I've also realised the device has a snap dragon CPU, and I built clockwork for armeabi, rather than armeabi-v7a. ARGH

    I'm away from home now for a week, so I'm not going to be able to build another version till then, I've only got a crappy 32bit laptop with me :(

    I'll see what I can do in the meantime, tho... I might see if I can borrow a 64bit laptop
    Woodstock77 likes this.
  20. Woodstock77

    Woodstock77 Well-Known Member

    Great. Now that my communication issues are GTG I think we can make some progress. Im ready when you are. Thanks again.
  21. freesunshine

    freesunshine Well-Known Member

    Hey Woodstock...how did you get the driver to work? I've tried 5-6 different USB drivers but none worked and can't get pass the "Unknown Device".

    PS..this is in bootloader.
  22. Woodstock77

    Woodstock77 Well-Known Member

    Yeah that was where I had the problem too. Its gonna sound stupid but i just moved my usb from the front usb to a back usb on the PC and it let me intall the drivers in the first link.:eek:
  23. freesunshine

    freesunshine Well-Known Member

    Now, I feel stupid...haha! You're a genius Wookstock! Now I can stop pulling my hair out! :D

    I guess now we just wait for Sebastian. :)
  24. Sebastian404

    Sebastian404 Well-Known Member

    Ok guys, I've managed to build... something.. I had to borrow someone's laptop to make it, so it's not my normal build environment, it pasted the santy check, but I have no way to test it... but hopefully it should work..

    I've updated the first post with the new verison, care to give it a go?
    attrapp and Woodstock77 like this.
  25. Woodstock77

    Woodstock77 Well-Known Member

    I'll be off work in about 8 hours then I'll test it out. Thanks.

Share This Page