BOOST SGS2 FH29 Root Achieved!


  1. guyphs

    guyphs Well-Known Member

    So I thought I'd post here to let peeps know I rooted my SGS2, custom kernel, custom recovery, and SU. Most of the hard work was already done, the basic instructions are (which are here) got me root but I wasn't exactly sure if it would work for my build until I, well, tried it. I take no credit, all the hard work was done by others, I just figured out how to apply it to my phone. As per usual, I take no responsibility if your device ends up fried, etc etc. All I can say is that these were the steps that I took on my Boost SGS2 running FH29 (you can find out what build by going into settings and about phone) and that I'm now running CM10.

    Make sure you've installed Kies beforehand. Then get Odin and the linked kernel. Reboot your SGS2 into download mode (power off, then hold vol - and power, then press vol + when prompted) and connect to your computer. Odin should see your phone. Click PDA in Odin and select the kernel dl'd from the link, make sure auto reboot is checked in Odin, then flash it. Your phone should then reboot.

    DL SU binary zip. Don't unzip it, just put the zip file on your SD card. Then power off the phone. Hold vol + and power to reboot into the custom recovery (first thing you should probably do now is make a nandroid -- so backup). Then flash the SU zip you put onto the sd card and reboot. VOILA, you should now have root access on your device.

    Also, I can confirm that you can get a working CM10 build with most everything working on it (incl. 4g) -- that's what I've got going right now and it's working fine so far.

    If you want to install CM10 on your device, there are some additional steps that you need to take. The Kernel listed above is for TW-only roms, so you'll have to flash an additional kernel. The one that I used is here. Basically download the kernel with CWM in it, save it to your SD card, reboot into recovery like before, and flash the CWM zip, then select the option to reboot recovery and then you should be in CWM recovery (and have the kernel flashed).

    Then download CM10 and gapps -- The CM10 ROM I used is here. You'll also need to flash google apps, and you can download that for jellybean here. Download both of those to your SD card and flash them in recovery, first CM10, then gapps. Then wipe your caches (both reg and dalvik) and reboot. ONLY FLASH CM10 AFTER YOU HAVE FLASHED THE SECOND KERNEL WITH CWM. You should now be running CM10!

    One word of caution for everyone, BEFORE FLASHING TO CM10 AND WHILE YOU ARE STILL ON THE STOCK, ROOTED ROM, make a titanium backup of all your apps. This is important because you never know if you may need some stock app later. A great example of this is the voicemail app. You can't get it on the play store and without it you won't have visual voicemail. I can confirm that you can make the backup and restore it once you're running CM10 and it works fine.

    As I posted below, I do not have MMS working. I need to figure out how to edit APN settings for Boost, and when I figure that out I'll post back.

    Advertisement
  2. SelfElevated2

    SelfElevated2 Well-Known Member

    Good find... thanks for sharing:D
  3. mkkt808

    mkkt808 New Member

    Which CM10 build do you have? I have achieved root access...thanks for the break down.. but when I tried to flash the newest version of CM10, it aborted for some reason. Which version did you use? Do you have a working MMS? I have tried the methods seen to fix mms and nothing has worked for me so far.
  4. dhabell

    dhabell Well-Known Member

    the link you provided links to a kernel that specifically says is tshould not be used with CM roms. Im confused.
  5. guyphs

    guyphs Well-Known Member

    Yeah -- sorry about that. I'll edit the OP to reflect the steps needed to take to flash CM10. As for MMS, you'll need to edit the APN settings and I'm just not sure how to do that yet in CM10 as the method I'm familiar with doesn't seem to work.
    PurpleTentacle and cerj like this.
  6. guyphs

    guyphs Well-Known Member

    As well you should be. I should have made clear in the original post that you need to take the additional step of flashing another kernel before going on to CM 10.
    PurpleTentacle and cerj like this.
  7. Chaniyth

    Chaniyth Member

    Will this work without needing to flash a custom kernel? In other words, will I be able to just flash the SU zip to obtain root? Thanks.
  8. cjreyes666

    cjreyes666 Well-Known Member

    I used the steps below to make mms work on a LG Marquee after flashing CM9.

    Go to Voice Search and speak "open apn"
    If not working download AnyCut to have a direct widget to apns

    Open the apn settings and it will most likely be blank.

    Menu>NEW

    *NOTE* THERE MUST BE 2 APNS FOR MMS TO WORK!

    For the first, fill in only the following fields:
    Name: home
    APN: Boost_Mobile
    leave everything else blank except APN Type near the bottom. Enter default,supl

    Now hit menu save.

    Once again, make a new apn by hitting menu>new
    Name: Boost
    APN: Boost_Mobile
    Username: Boost_Mobile
    Password: *
    MMSC: http://mm.myboostmobile.com
    MMS Proxy: 68.28.31.7
    MMS Port: 80
    MCC: 311
    MNC: 870
    APN Type: mms

    Not now hit menu save.

    *NOTE* ONLY ONE APN WILL BE SELECTABLE.
    This should be the APN named "home"

    Click the little circle on the right to select (may be hard to see)

    Now hit home. Then reboot. If not working download a third party sms app such as Go SMS Pro or Chomp.

    As well all credit goes to Phrant1c and all the people who helped test it out.
    cerj likes this.
  9. guyphs

    guyphs Well-Known Member

    I don't think so -- I don't believe you can flash the SU binary in stock recovery, or at least I haven't seen anyone saying you can do it that way.
  10. Gizwinkus

    Gizwinkus New Member

    I tried this on my Boost SG2 FH29 phone and it appears I'm screwed. After successfully flashing AGAT 0.5.4 kernel the phone will not reboot. It just stays on the initial boot screen.
  11. guyphs

    guyphs Well-Known Member

    Did you get any errors in Odin? Can you boot into download mode or recovery?
    Gizwinkus likes this.
  12. Gizwinkus

    Gizwinkus New Member

    My bad, somehow I flashed the wrong kernel. I did as you said, this time using the real Agat 0.5.4 and I'm now rooted. Thanks.
  13. guyphs

    guyphs Well-Known Member

    Glad to hear. I'd hate to to think I borked someone's device
  14. mkkt808

    mkkt808 New Member


    I was able to get in and do everything you said, and still no luck with mms. Does anybody else have any suggestions. This mms issue has been a problem for me since the day I got this phone and Boost has reset it dozens of times with no luck. Do you think it is a hardware issue? I've tried multiple things from various forums of things that have worked for others and nothing seems to work for me. Help!!
  15. guyphs

    guyphs Well-Known Member

    I've had no luck with the MMS either. I can receive mms messages, just not send them
  16. cerj

    cerj Well-Known Member

    THANK you Guyphs for the post and cheers for your successful root. Im new to Android and forum. Is There a specific Odin for the sgs2 fh29 I should download.
  17. ITJ

    ITJ Well-Known Member

    i think there is...i found odin3 v1.85 supports the epic touch...also does it require a pit file also?
    cerj likes this.
  18. cerj

    cerj Well-Known Member

    There is a post about mms and a possible fix by FEDDY on another forum. Not sure of the rules here about posting,if its ok i can post exactly where its at. I'm trying to gather as much information about this root as i can before i do it.just happened to come across the post so i thought I'd share.
  19. Chaniyth

    Chaniyth Member

    Im a bit confused on how this root works, i've rooted every Android device i've ever owned before without any confusion but this method on this particular device is a bit confusing.

    I don't wanna "lose" the stock ROM stuff, I mainly only want root so I can get rid of annoying ads on websites, apps, etc. I'm not really interested at the moment to use CM, I just want a basic root, yet have stock ROM apps, etc. Is there anyway to do that?
    cerj and SelfElevated2 like this.
  20. kevincott

    kevincott Well-Known Member Contributor

    I seem to be bootlooping on my shiny new Boost SGS2 after installing CWM and SU.

    I can get to CWM6 without issue but cant boot, the CM10 aqua circle just keeps spinning.
  21. SelfElevated2

    SelfElevated2 Well-Known Member

    I feel the same as you. This is ridiculous that we have no clear cut root.. why are we even on Sprints galaxy s2 forum if we can't use everything they can use on theyre forum...

    We need or own boost mobile galaxy s2 thread to end this confusion. I've asked mods but they are content with us feeling like Minorities and confused on what we can use.. we need to all post a thread asking for our own boost version thread and maybe that will get our request granted:banghead:
    cerj likes this.
  22. kevincott

    kevincott Well-Known Member Contributor


    Fixed
  23. Chaniyth

    Chaniyth Member

    Ok, so the AGAT v5.04 flashed without issue, IF I want to go back to the stock kernel is there a way I can? I don't see any stock kernels online yet, so... o_O

    SU installed fine too so im rooted. However, "just in case" i'd like to be able to restore the stock kernel.
  24. Chaniyth

    Chaniyth Member

    Could you post the fix for those that may run into this same issue? Thanks.
  25. guyphs

    guyphs Well-Known Member

    I believe the kernel is just a kernel with root, so just flash the kernel and reboot and you should be stock with root.

Share This Page