Boot loop after factory reset :(


  1. tseven

    tseven Member

    I know what you're probably thinking "Idiot, you didn't read the numerous warnings did you?"

    The thing is, I just bought Optimus V from a dude on craigslist today. It appeared to be running a stock rom etc, so I performed a factory reset to make sure all his data was off the phone.

    It's now stuck in a boot loop where it shows the LG logo then a white box with an orange arrow coming out next to the green droid bot.

    I've followed several posts on fixing this, and they all include flashing a recovery image.

    The problem is, I get "can't find recovery partition: No such file or directory" every time I try flashing it.

    I'm assuming the previous owner tried rooting or something. Or perhaps he flashed a stock rom after rooting.

    I'm able to adb shell into the phone, and I'm assuming the phone has already been rooted since I can run "su" and no error occurs.

    Any ideas on how I can fix this?

    I'll be using this phone for testing mobile websites on, so I actually prefer if it were stock, but I'll take booting at this point.

    Advertisement
    :
  2. tseven

    tseven Member

    Thank you, but before I had a chance to try this, it looks like I messed things up more.

    Before I made things worse, I was able to open and adb shell with the phone and maintain it while it was looping. Now I have a 3 second window in which adb will connect.
    I've tried chaining the commands together and haven't had any luck.

    It appears one of the other fixes I tried has cleared out a lot. My sdcard folder is now empty, and I'm not seeing a /dev/mtd folder anymore.

    My phone doesn't have the flash_eraseall file on it so I'm not able to execute it directly. I was able to find a copy of it, but I'm not able to push and execute it it.

    When trying to push and flash a recovery I got:
    error scanning partitions%

    Arg.
  3. tseven

    tseven Member

    Here are the listings to a few key folders
    root dir:
    [HIGH]
    cache
    data
    default.prop
    dev
    emmc
    etc
    init
    init.rc
    proc
    res
    root
    sbin
    sdcard
    sys
    system
    tmp
    ueventd.goldfish.rc
    ueventd.rc
    [/HIGH]

    /data is empty
    /root is empty
    /system
    [HIGH]
    bin
    lib
    [/HIGH]
    /dev = Pastebin.com


    It seems like something I did wiped out some folders.

    The loop is the same, but I've lost the ability to hold a persistant adb shell connection.

    Anything I push in my 3 second window is deleted by the next reboot.

    I'm at my wits end. Any help would be greatly appreciated.
    Thanks.
  4. Thewraith420

    Thewraith420 Well-Known Member

    Maybe I missed it but can you boot to recovery? (home+volume down+power) even if it's stock recovery that'd be enough to get things rolling
  5. tseven

    tseven Member

    So it turns out my phone is the Optimus Elite and that's why everything I tried failed. Everything makes sense now.

    I've followed tommyjoesanders's guide and have successfully restored the phone.

    I really appreciate the both of you trying to help.

    Thanks again!
Loading...

Share This Page