Boot Loop :( after Flashing a ROM


Last Updated:

  1. urvis03

    urvis03 Member

    I rooted my Desire a few weeks back using Unrevoked 3.32 and it installed ClockWorkMod recovery 2.5.0.7. I had a few issues rooting since Unrevoked stated "triumph" and "done" but the phone wasn't rooted. Anyhow finally I managed to root it and had the Super(Ninja)User in my apps.
    Last night I decided upon flashing a custom ROM and chose Blissmod007 v14 and downloaded it from xda. Didn't check the MD5 sum though :confused:
    I have ROM manager installed but it was of no use so i took the back up of stock ROM from the recovery screen -> backup and restore option.
    I flashed the Radio successfully from 5.11.xx to 5.17.05.23(as was recommended for the ROM).
    I used the CWM recovery to install the .zip from SD card and flashed blissmod007 v14 successfully. After the flash on the first boot though, when i chose rebbot system from the recovery the phone just goes into boot loop and i can see only the green htc logo on white screen constantly. :(:(:(
    The first boot is slow after flashing a ROM so I kept the phone away but even after an hour the phone was still at boot screen!!! Since then I have tried to reboot after wiping Dalvik Cache but it just restarts thrice(as mentioned by the dev for ROM) and gets stuck on the htc logo... :(

    I want to know what is the best option in this case: a) Wipe Data, Wipe Cache Partition, Wipe Dalvik and restore the old stock ROM?
    b) Wipe Data, Cache Partition, Dalvik and try flashing another ROM?
    c) Use fastboot for
    fastboot flash boot boot.img

    History:
    Temp Rooted with Visionary+
    Perm Root FAILED with Visionary+
    Rooted with Unrevoked 3.32 for Windows
    Used Titanium Backup to back up apps
    Flashed Radio Successfully from 5.10.xx to 5.17.05.23
    Couldn't use ROM Manager to back up current ROM(I saw the sticky later)
    Backed up Stock 2.2 Arab build using CWM recovery 2.5.0.7
    Used Minitool Partition Magic for Windows(HADRON- I am going to use Gpart from now) to Partition my 2GB microSD to 1.2 FAT, 512+MB Ext2, 32MB Swap
    Flashed Blissmod007 v14 and got stuck in boot loop :(:(:(


    Bravo PVT3 Ship S-ON
    HBOOT-0.93.0001
    MicroP-051d
    TOUCH PANEL-SYNT0101
    RADIO- 5.17.05.23

    Advertisement
  2. Hadron

    Hadron Well-Known Member Contributor

    Only have a couple of seconds. Don't know BlissMod, but does it require sd-ext of a particular size? Later versions of Sense are too big and some require large partitions.

    Only a guess - as I say, don't know and no chance to investigate right now (likely not today).
  3. urvis03

    urvis03 Member

    There was just a mention of 512+ MB for sd-ext.. which i had.. The was ROM was flashed successfully.. At least the message said so.. but it's not getting booted :(
  4. shauny13

    shauny13 Well-Known Member

    do a full wipe and try flashing the rom again. If you get bootloop again i would use gparted to wipe your partition and recreate it, then try flashing the rom again.
  5. Hadron

    Hadron Well-Known Member Contributor

    Don't try to flash a boot img.

    You don't actually say that you've done a full wipe/factory reset, just wiped dalvik. So a full wipe is the first thing to try.

    The ROM thread says 512+ for both CM7 and stock, so I'd think it should fit in a partition of that size (otherwise it would need a larger partition when using the CM7 hboot). Most of these Sense 3 ROMs suggest a larger partition though. If you remake the partition, go for ext3 rather than ext2 (ext2 is just old and slow), and there's no point in having a swap partition.

    I'd try what shauny suggests, in that order. If neither works, either a bigger card (so you can try a larger partition) or a different ROM.
  6. urvis03

    urvis03 Member

    I did do a full wipe before flashing... I just wiped Dalvik.cache later when the phone went in loop..read about it when I googled that it might interfere with booting if Dalvik is not wiped properly.. apparently some one else also facing the same problem..he has S-Off..Shouldn't I try a different ROM?
  7. shauny13

    shauny13 Well-Known Member

    Yes, try dGB just to see if it works as this doesn't require a partition.
    urvis03 likes this.
  8. urvis03

    urvis03 Member

    dGB by SURoot/Dan?? What are it's requirements?? and will it create a 375MB /Data automatically or should i partition something myself or MTD(something like that) that SURoot suggests..
  9. shauny13

    shauny13 Well-Known Member

    That's the one. It won't give you the 375, you have to s-off and change the partition table yourself, but that's advanced stuff. We're just trying to establish if you can flash a rom.
  10. urvis03

    urvis03 Member

    Good advice Shauny n Hadron :) just flashed dGB n it worked successfully :)
    The phone is working smoothly n what a snappy ROM by Dan.. Superb work n great ROM SURoot!!
    Unfortunately my Wi-Fi isn't working n no data plan activated yet so couldn't install apps from market to check..I will keep this ROM if I had more memory.. what are the next steps that u suggest??
  11. shauny13

    shauny13 Well-Known Member

    yh, dGb doesn't backup your apn's you have to input them manually or restore from a backup.

    As this rom works ok, the problem you had before must be your partition, try doing as i said in post 4 with gparted.
  12. Tyseyh

    Tyseyh Well-Known Member

    Moving to all things root.
    urvis03 likes this.
  13. urvis03

    urvis03 Member

    Thanks Shauny :) Will try that when i get a new card.. i was using the stock 2GB Class 2 that had come with my Nokia!!

    Thanks Ty...

Share This Page