Bootlooping problems


  1. missdandy

    missdandy New Member

    Hello!

    I've been trying to flash a new ROM to my Evo V 4g and this is my first experience with it. However, in the process I somehow got my phone to a state where it bootloops with every single ROM I attempt to flash (including restoring it to the original) and I'm not sure how to get it to stop.

    Here's what I've done/tried so far:

    1. Followed these instructions to unlock with HTCdev and flash the TWRP2 recovery. I also used them to flash a new ROM (the unofficial CM10 for shooter, which I substituted for the SU patch). I did not do S-OFF, which I think is what's causing the problem.

    2. Restarted the phone. The CyanogenMod animation came up and kept playing until the phone's battery died.

    3. I wiped the system, data and cache and flashed the recovery.

    4. Restarted the phone, the Virgin Mobile splash screen came up and stayed, but the phone would not boot.

    5. Attempted to flash Harmonia and Midnight ROMs, which both bootlooped.

    6. Wiped and tried recovery again. Now I do not even see the Virgin Mobile screen. The white htc screen will appear followed by the htc "quietly brilliant" screen, then the phone will turn off and start this again... and again...

    7. Tried to switch to S-OFF with these instructions, but I cannot get into the GUI to enable USB debugging and use the ADB.

    8. Attempted to flash the RUU with these instructions. I tried running the RUU.exe from my computer first and then tried to flash the .zip from my phone, both failed.

    9. Flashed a copy of the stock ROM, obtained here. The phone still bootlooped.

    10. Formatted the SD card (but saved the recovery files first), tried recovery and the RUU again.

    I've read through every forum/guide I can find but nothing seems to fix the problem. I'm running out of ideas... does anyone else have suggestions?

    Advertisement
    :
  2. thIsgUy20

    thIsgUy20 Well-Known Member

    so you not usind 4ext recovery? i herd twrp isnt to good with some roms. as of now are you s-off or s-on?
  3. Prinny

    Prinny Resident Linux Nutcase Guide

    Hiya, missdandy.

    If you are S-On, might I suggest using 4EXT recovery with smartflash enabled?

    Alternatively, the phone is not booting because the kernel isn't changing.

    What you need to do is take the boot.img out of the ROM you are trying to use, and put it into your adb tools folder where adb and fastboot are located.

    Then you need to go into your bootloader by holding power and volume down while the phone is turned off.

    Next step is to flash the boot.img!

    Code (Text):
    1. fastboot flash boot boot.img
    Then you should just reboot the phone, and be set!
    missdandy and Brian706 like this.
  4. Brian706

    Brian706 Moderator Moderator

    Yeah if you are s-on, you should really use 4ext recovery. It has a feature called smart flash for s-on users that will most likely get rid of your flashing problems.

    Your other option is to boot recovery through fastboot while connected to the pc by using fastboot command fastboot boot recovery.img
    Recovery.img being the whatever your recovery image is named (probably recovery.img if you were following the guide).

    But 4ext is a lot easier than needing the pc every time you want to flash a rom.


    Edit: moved to all things root subforum.

    Double edit: prinny looks like you ninja'd me back. We're even :p
    missdandy and Prinny like this.
  5. Brian706

    Brian706 Moderator Moderator

    Prinny is right about the kernel. 4ext smart flash allows you to flash the kernel with the Rom. Also using fastboot boot recovery.img like mentioned above will allow you to flash the kernel with the Rom. Both methods will avoid bootlooping.

    I you want to flash the kernel since you already flashed the rom you can do what prinny said and flash the boot.img. That should allow you to boot up the rom you flashed.
    missdandy likes this.
  6. mrawesome22

    mrawesome22 Well-Known Member

    You will never get cm10 to boot without s-off.

    CM10 requires an hboot lower than 1.57 and the only way to flash a different hboot is with s-off.
  7. missdandy

    missdandy New Member

    Thanks so much for your help, everyone! 4EXT worked great and I can now boot the phone to my heart's content.
Loading...

Share This Page