Bought a Cheap Tab for my lad and can't install "google play services"

Last Updated:

  1. Vk27

    Vk27 Member

    Hey all as above I Bought a Cheap Tab for my lad. He is only young so thought about how long it will lat before he drops it :)

    Anyway it's a Sanei n77 the only reason I bought it for him it because of his love for watching Minecraft videos on Youtube.

    So me knowing Zero about android I went to the google play app "thing" got the youtube app and when I try to open it it says I need"google play services"
    so than I go back to the store leech it and run the installer and it gives me

    Application Not Installed

    And than it say's nothing more.

    Has anyone any ideas?

    also on the off topic
    Some of the "apps" have like a "windows 8 button" background and the others are transparent any idea how I can get them all transparent?


  2. nickdalzell

    nickdalzell Well-Known Member Contributor

    it is possible the cheapie tablet comes with an obsolete copy of Android (either 2.2, 2.1 or rarely, 1.5) which is normally not compatible with Play, or Play Services. 'Application Not Installed' or more commonly, 'there was an error parsing the package' is the installer exiting due to the app normally being incompatible with the hardware or your tablet's version of Android. the old Youtube app is dead or no longer supported and very unlikely the work. they recently updated the Youtube app which has a newer version that does indeed require Play Store or Play Services. it is also possible your cheap tablet did not come with Play installed, as most cheap tablets do not allow Play or Google has not licensed it to run on them (someone chime in here, i'm not sure myself) so the app won't run without that required system service. I was lucky I got around it on Youtube on a cheap D2 Pad, by just installing play services by sideloading the APK found online somewhere
    mikedt likes this.
  3. mikedt

    mikedt 你好 Guide

    You'll probably be able to watch Tudou and Youku OK(Chinese video sites), but not YouTube.

    It's usually because a device is not licensed or approved, basically because Google has nothing much to do with Android in China. Sometimes Chinese Android ROMs have certain components and frameworks missing that are required by Google Play.
    Rxpert83 likes this.
  4. nickdalzell

    nickdalzell Well-Known Member Contributor

    personally outside the app-dependent problem I find Google Play to be a bit overrated. it often has glitches or errors out on installs or downloads fail with some odd code. it takes three clicks to install anything over Play (clicking download, then install, then accept permissions and wait for it to download, oftentimes it will glitch and won't install and you waited for nothing) and is just not user friendly to me personally.

    ever since the first D2 Pad (RIP, 10" shattered screen after a soft landing on the carpet) I fell in love with 1Mobile Market. it is a great alternative to Play, you can install in one click, and if space is a problem, it won't even start a download thus avoiding the wait for nothing. most of the apps found on Play Store will show on it, it only lists free apps (great for those with tight pockets) and is a very nice interface. however I don't expect my views to be shared, especially for those who paid for stuff on Play and like the access. my recommendation is to use the 1Mobile Market and try and side-load the APK for Google Play Services and see if it will work. you won't need the entire store, just that one service if it's like my copy of Youtube on my cheapie

    here are some things I did, including alternatives to Youtube:

    1. GrooveIP--Free calls to and from your tablet with a valid Google Voice account

    2. Youtube downloaders (these will access and play or stream content from Youtube without needing Play) my advice? download and install Amazon Appstore and download and install from there, Freedi Youtube Downloader. it will stream without Play

    3. Many Google Apps work from 1Mobile, including Gmail, Google Earth, Google Voice Search, Google Talk, Google Maps, all found there

    4. Games are all there, including Angry Birds, Cut the Rope, even Brothers in Arms 2

    5. install Text Plus Free. totally unlimited and free two-way texting (yes, even to other mobile phones) from your tablet!

    6. the popular launchers, all free, are there, including Go, Apex, Holo and so on
    Vk27 and mikedt like this.
  5. Vk27

    Vk27 Member

    Thanks for the reply's The play store button is on it and it say's its on android 4.0.4 if that means anything. Also ive got everything to run on it so far (Other than youtube and Chrome)
  6. nickdalzell

    nickdalzell Well-Known Member Contributor

    Chrome should run but in my opinion its slow. I use Dolphin Mini to post to AF. Try a youtube downloader. You wont need to download videos you should be able to stream from the app though
  7. Vk27

    Vk27 Member

    I was after the youtube app so he could log in etc...

    Is there no way around this?

  8. nickdalzell

    nickdalzell Well-Known Member Contributor

    Not without the official app I'm afraid. I was assuming he just wanted to watch videos
  9. Vk27

    Vk27 Member

    Aye hmm

    So going by what you said above there is no way for me to get this to work (other than buying a new tab)

    hmm ok edit =
    I pressed "back" then I got the you need google play services etc..." and there it was the youtube app working!

    But :( when I tryed to log him in I got the msg again.

    Cheer all for the help!
  10. nickdalzell

    nickdalzell Well-Known Member Contributor

    Why would you need to login to just watch videos? install a YouTube downloader and you can watch online without an account heck I never to login to view videos
  11. Vk27

    Vk27 Member

    Subs, playlists, fav's etc...
  12. Quoros

    Quoros Well-Known Member

    I found this app for the polaroid 8". I ran is on both polaroid 8" and d2 pad 7" it installed play store just fine. I did hav to run it 2x on both however it did cause them to lag.

  13. macjay420

    macjay420 Well-Known Member

    did the same thing worked for me
  14. nickdalzell

    nickdalzell Well-Known Member Contributor

    on my D2 it told me i had to install Play Services (not Store) and errored out because there is no Play Store on the device, but that was solved by a simple search for the add-on via 1Mobile Market. Youtube came pre-installed on my Emerson 4.3" ICS device so i got lucky there

Share This Page