1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Bought Nexus S Rooted, Can't Unroot


  1. specialistk

    specialistk New Member

    Hi, i'm new to android phones (am familiar with Honeycomb on my xoom though), just got my pre-owned nexus s in the mail yesterday. It came unlocked and rooted (I think) because when it boots up there is the unlock symbol, and in my apps i do have superuser. I don't see a clockworkmod app though. My problem is I wanna unroot it back to stock, then re-root it again so i can install custom roms such as ICS. So whenever i go into the bootloader, select recovery, i get the exclimation point in the triangle error. i press vol up and power and get some options, but only wipe data / reset ect. nothing like what i've seen in the youtube vids. my guess is that the previous owner updated to gingerbread 2.3.6 and may have replaced some files??? i don't know. Any tips on how i can unroot without any recovery files? thanks!

    Advertisement
    :
  2. B2L

    B2L Well-Known Member

    It sounds like the device is rooted, you are just missing the recovery image. Instead of unrooting, and rerooting, it should be much easier to flash a custom recovery image. If you have rom manager (If not just download it from the market) just open it and download and install clockworkmod recovery. If you would prefer not to do it the easy way, you can also flash a custom recovery image by doing this process.

    Source:
    http://theunlockr.com/2010/12/17/how-to-root-the-samsung-nexus-s/
  3. specialistk

    specialistk New Member

    Thanks for the info! only problem i have with the first option is when i try and download clockworkmod recovery, it downloads but imediatly after it gives me and error "An error occurred while attempting to run privileged commands!" Not sure why i get this if i am rooted. going to try the 2nd option.
  4. B2L

    B2L Well-Known Member

    Did the window popup asking for Superuser access? That error typically only happens when the app wasn't granted Superuser permissions.
  5. specialistk

    specialistk New Member

    That didn't come up, even though it is install. I tryed both methods (along with a few youtube walkthroughs), but still continue to get errors and files within clockworkmod continue to get overwritten when i boot up. ive pretty much given up on playing around with roms. I'll just wait till ICS is released and then no worries. Thanks for the help though. :)
  6. razvan06

    razvan06 Well-Known Member

    Are you still having problems with it ?
  7. Somedudesomedu

    Somedudesomedu New Member

    Hey I had somewhat similar situation except possibly even bigger noob. I got a used phone and noticed it had Superuser app but didn't know what it was and didn't think it was rooted. Then when I tried to install android firmware update from 2.3.4 to next one it didnt happen and took me a few times to notice that triangle exclamation error was not normal. I eventually figured out it was Clockworkmod and read up on rooting and ROMS. So ROMS dont seem a bad idea and I'd like to try out CM7.

    But most tutorials I have seen go from rooting to clockworkmod to ROM manager and installing what you want. Terms like SDK and such above and in other posts I havn't seen before. Maybe they are more advance way of doing it?, because the tutorials didnt indicate anything about command lines and stuff, ROM Manager could do it all.

    Anyhow my two concerns are that the phone already has an older version of Clockworkmod, so should i get ROM Manager and just install the latest version and it will overwrite my version or I have to uninstall it or something?
    I am also not certain on the relationship between android versions and ROMs. As in the latest Android update my phone keeps bugging me about 2.3.6. From what some sites suggest the ROMs replace this (operating system?) so they exist for each version and so if I say get latest CM7 for gingerbread, it will have all the updates official 2.3.6 has plus its own enhancements? Basically i dont want to miss out on the official stuff they added from 2.3.4 to 2.3.6 and had initially thought I would have to first update to that latest version somehow and then do any custom stuff after that. Also, could I just go to 2.3.6 (the latest official version it prompts me for) without a custom ROM? I can't do this now because clockwork screws it up each time.

    Thanks for any help and patience with noob (I've tried going though the rooting guides here but I just don't feel I really understand everything).
  8. razvan06

    razvan06 Well-Known Member

    You can install/buy ROM Mamager and flash the latest recovery from there [the ROM Manager developer ,develops the recoveries too :) ,no worries] and then go to DOWNLOAD menu in ROM Manager and search for [I really recommend this one !] CyberGR MOD [CM7 mod : modified CM7 latest [2.3.7] stable v7.1.0.1 with BLN : ON and other stuff ,very good !!] download it [only premium !!] and install it !
Loading...

Share This Page