Brand new rooted S2 - can't install apps. FRUSTRATING, Help!


  1. Eperrine

    Eperrine Member

    Phone: Samsung Galaxy S2, Rooted, 16GB, No SD card.
    Available space: 11GB
    Issue: When i download apps from the app store, it'll finish downloading, and when it tries to install, it says THIS: "Application cannot be installed in the default installation location".
    What i've tried: Clearing date, cache, updates of Market, rebooting phone.
    Apps that do this: I CAN STILL DOWNLOAD SOME APPS, but frustratingly enough, the ones i need are the ones i can't have! These include: Tapatalk Forums, Taskos, Google+, XDA developers, Colorized Widgets, HD Iphone Go Launcher Theme. (Just a few examples).
    Observations: This issue began occurring after the root, and also after i used 'Root explorer' to move some bloatware from my phone, to the Root Explorer file 'sd card' (even though i don't have one.. i know, weird right?), and also after playing with permissions.
    Weirdly enough: After weeks of this issue happening to "Bakery Story" app, yesterday, it successfully installed. I don't think i did anything out of the blue to my phone? It was fixed! It's as if this issue is a randomoccurrence! But this continues to happen to apps i REALLY want. SOMEONE PLEASE, END THIS MISERY FOR ME!

    Advertisement
    :
  2. Shotgun84

    Shotgun84 Well-Known Member

    Move to sd card will be your internal sd card not an external one. The only thing I can think of is to wipe data, cache and dalvik and then root again. Maybe hang on a bit though as someone may have a better solution.
  3. Shotgun84

    Shotgun84 Well-Known Member

    Or maybe flash a firmware update.
  4. Slug

    Slug Check six! Moderator

    Neither of those will have helped. ;)

    As you're rooted I assume you have ClockworkMod Recovery? Boot into recovery, select "Advanced" and then "Fix permissions". Wait for it to complete then reboot and try installing one of the problem apps again.
  5. Shotgun84

    Shotgun84 Well-Known Member

    Yeah, wasn't going to very my life those would work. Just a couple of generic things that sorted out most of my problems. Although I really should of got the fix permissions, I've had to do that a couple of times and the clue was in the post.
  6. Slug

    Slug Check six! Moderator

    Hopefully it's as simple as a "fix permissions" but if not then your suggestion may well be required. I've had to reflash from a full wipe myself more than once.... I still occasionally get over-enthusiastic and forget to nandroid. :eek:
  7. jordonmallen

    jordonmallen New Member

    I was having the same problem and then I came across this thread. I fixed it by trying to install the app with my pc on google play directly from my browser...and I got the error the last time. Then I removed the terminal app. Then I tried installing the app from my android device (Huawei Ascend Y, gingerbread, rooted) and the app installed just fine. Maybe I just got lucky? I think the terminal app screws with things.

    The error first occurred after rooting and then installing the terminal app along with super user. I tried using super user before I ran terminal and the super user app disappeared but was still running. So I uninstalled super user before terminal.
Loading...

Share This Page