"brcm bluetooth services" can I get rid of it?

Last Updated:

  1. fv1620

    fv1620 Member

    Original battery lasted just over 2 years, but started going flat halfway through the day. Got what seems to be a genuine HTC replacement that was only slightly better, supplier has sent me another. But that is no better.

    Installed TrustGo anti-virus that has a System Manager & shows battery level & what is using it. I find that BrcmBluetoothServices is drawing 6.9mAh, all the time.

    I never use BlueTooth & it is turned off. How can I turn off this brcm thing?

    When I press on the display the option to Force Stop or Uninstall are blanked over, so I can do nothing.

    Is brcm already installed on the phone or something I inadvertently picked up?

    A few days ago I had some instability problems with reading the SD card. I did a factory reset & fitted another card & it is nice & stable now. The only app I downloaded was TrustGo, is it not so trustworthy?

    If I remove it though I don't know how to monitor precisely what is taking the power.

    I have googled around but found no answers.

    Hate to say it but is time for another phone, if I can't get rid of this? I don't mind never having a bluetooth option.

    Any guidance appreciated please.

  2. Hadron

    Hadron Well-Known Member Contributor

    "brcm" may refer to Broadcom, who make communications equipment including BT chipsets. I suspect that this is something that should be there (I haven't had a Sense ROM for 2 years, so can't recall exactly what is in there, but the name is vaguely familiar from somewhere).

    You can try killing the process, but I don't know whether that will achieve anything. It shouldn't be drawing significant power if BT is off, so this does seem a bit strange. What does the system tell you the main power drains are (or is that a GB only feature?).
  3. fv1620

    fv1620 Member

    Thank you for coming back. When I turn BT on I can go into the battery monitor & see brcmbluetoothservices still drawing the same power about 7mAh as when it is not on.

    When I press on that display the force stop is now highlighted in white. When I press that it turns off BT, the option to force stop goes.

    I find the BT option in now turned off on the wireless & networks panel. But I am still back where I was with brcmbluetoothservices drawing 7mAh although it is apparently not running.

    I was wondering whether to link it to the PC & explore it so I could zap something that way.

    Even if I permanently lose the BT facility it is better than losing the use of the whole phone & getting a new one.

    It has all worked fine for over 2 years then suddenly a week ago the batteries keep running down & even on long standby I can feel the battery is warm.

    Many thanks

    PS 99% of power is being drawn by brcmbluetoothservices all the time
  4. fv1620

    fv1620 Member

    I turned the phone off as it had gone flat on me. Put it on charge then after a while went back to see how the power drain was.

    "brcmbluetoothservices" has gone but in its place came "VPN Services" consuming exactly the same power & behaving the same. I haven't set up a VPN.

    Anyway I turned it off, then I thought I would take a screen shot of it turned it back on again. But now it has been replaced by "Upgrade Setup" behaving in the same way as the earlier intrusions.

    In the 2+ years I have had it there have been I think at least a couple of system upgrades. So as I put it to factory reset yesterday I thought it might need upgrading. I went to get it to check for an upgrade but it says everything is up to date, which was a bit odd.

    In fact its all rather odd & very annoying :(
  5. Hadron

    Hadron Well-Known Member Contributor

    Try a different monitoring tool - it's odd if the same drain is coming from a different service each time.
    fv1620 likes this.
  6. fv1620

    fv1620 Member

    Thank you yes that makes sense. It was only by chance that I found this one. I looked at all the battery monitors but didn't know which would give the detail of actual current. Any ideas which?

    Many thanks
  7. fv1620

    fv1620 Member

    I now have Network Location as the main consumer of power but this with VPN Services & BrcmBluetoothServices are all components of the Android system I think.

    So when I ask TrustGo what is consuming the power? It seemsd to just pick on one representative from the Android system & this has made me think there was just one individual component that was exclusively using up the power.

    I suppose I got even more misled as the power consumption report is cumulative since switch on rather than telling me what is happening exactly at the time I check.

    I now have Advanced Task Killer to cut out weather, wifi etc when I'm not actually using them. Although I still don't understand why for over 2 years I could run these sort of things & still have a usable charge by late evening. But now even with a new HTC battery it is being discharged more readily by the end of the afternoon.
  8. Hadron

    Hadron Well-Known Member Contributor

    I'd honestly recommend losing the task killer. Those things tend to reduce battery life: they kill processes which will just restart, which is a waste of power. The "android things to know" sticky over in Android Lounge links an article on why you shouldn't use them.

    If the power monitor is just assigning a name to the overall android services then 7mA for that overall doesn't sound crazy (I can be better using a custom ROM and undervolted kernel, but only by a couple of mA).

    My most used system utility is Quick System Info. That gives a shortcut into the detailed battery stats (under "battery -> battery history" IIRC), where checking "partial wake usage" is usually a good way of spotting if any process is using more power than it should - this shows what processes are keeping the phone from sleeping, which is generally a good indicator.
    fv1620 likes this.
  9. fv1620

    fv1620 Member

    Ok thank you. Been in the lounge that makes interesting reading. I've got rid of the task killer now.

    I've installed Quick System Info Pro (not sure what the difference is between the pro & non-pro version)

    I can see under "Partial Wake Usage" that Android is the main consumer it has a blue bar less than 1mm thick & beneath it Media which is much thinner still. But don't know how to interpret most of the info.

    I was fully charged at switch on. I've used the wifi for 10 mins & read a pdf for 10 mins now battery is 82% charged. This is on an uptime of 2 hrs 45 mins & awake time of 45 mins.

    Many thanks
  10. Hadron

    Hadron Well-Known Member Contributor

    What's screen on time? That's usually the biggest factor
  11. fv1620

    fv1620 Member

    Since boot this morning

    Screen on 12.2%
    Running 15.7 %
    Phone on 0.2%
    Wifi on 3.1%
    Wifi running 3.1%

    Battery is 46% having been on for 12 hours. Although usually this means I only have a couple of hours before a yellow battery.

    Today I have decided to only deliberately turn on Wifi when I need to send an email/look at a forum, rather than have it on all the time to catch any emails. Although until last week I could have wifi on all day & be at about this level of charge at this time of day.

    Many thanks
  12. Hadron

    Hadron Well-Known Member Contributor

    Hmm, 12% of 12 hours means about 1.5 hours screen on for a bit over 50% power usage. That's not outrageously bad, though it should be able to do a bit better (though if your brightness is up high maybe not).

    From your earlier post it doesn't sound like there's a lot of partial wake.

    So not sure why lifetime should be down.
    fv1620 likes this.
  13. fv1620

    fv1620 Member

    Well I've just gone into yellow battery after 14 hours. This was about normal before the crisis that started last week. So I can cope with that.

    Just trying to think back what might have changed. There are some apps that I downloaded that are missing now which might have been using up the juice silently?

    I don't know whether they went because I did a factory reset or whether they were on the SD card.

    I had to change the SD card as it was displaying something like "Read only" & in fact trying it in the PC it was unreadable. So I don't know whether trouble on the card was causing something to be running more than it should have been?

    Thanks to your help I'm much better off now. I can live with leaving wifi off until I really need to turn it on. Although out of curiosity I might leave it on tomorrow & see if it can cope just left on like it used to be.

    The trouble is now I find I cannot connect data via 3G. All the settings seem to be right & match the settings on my Wildfire. Although that is on a different network. But I have now tried 3 quite different locations in a 20 mile radius where I have previously operated data on 3G but can't get in at any location.

    Anyway thanks again.
  14. Hadron

    Hadron Well-Known Member Contributor

    If the Wildfire is on a different network then the settings should not be the same. It's the APN settings that are key for 3G data - prob. best to check what they should be for your network online (can probably find them with a search, and should be on the operator's site somewhere).
    fv1620 likes this.
  15. fv1620

    fv1620 Member

    Ah APN now been exploring that & reset it to default so seem to be back on.

    Thank you for your help & perseverance with this all. Without such help I would have had to give up & do something drastic like buy a Galaxy 2.

Share This Page