1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

bricked galaxy pop


  1. sahilg009

    sahilg009 Active Member

    i think it is due to rom manager it is just not even 1 month old and it is bricked it wont even turn on somebody please help me to unbrick it

    Advertisement
    :
  2. Sargun

    Sargun Active Member

    what was you trying to do with rom manager means taking backup of rom or installing clockworldmod when it bricked your phone?
  3. sahilg009

    sahilg009 Active Member

    installed clockworldmod of huwai mini thinking it to be galaxy mini
  4. androidralph18

    androidralph18 New Member

    have the same problem dude.. i think we should go to our retailer, hahahah i can't even find solution for this bricked galaxy pop because like what you've said it doesn't start anymore, like mine though hahahah goodluck to our precoius phones..
  5. ramkumarn

    ramkumarn Member

    I too bricked my galalxy pop when updating firmware from DDKA7 to KC1 through Kies. During the update process, the progress stuck at 50% and it didn't complete even after hours..I had to disconnect the cable and tried to update again...unfortunately my phone bricked and did not start at all showing "pc-!-mobile" screen.

    Then I googled a lot and found a way to recover my phone. Recover mode was not working in my phone, but download mode was still working...thank god.

    what I did exactly is entering into download mode: By pressing volume down + power button + home (middle button).

    Go to samfirmware and get the firmware files. link is Login - www.SamFirmware.com

    we need to register first then download OPS file and firmware file. I chose KC2 update for europe because that seemed like up-to-date firmware.

    Then downloaded S5570_Odin Multi Downloader v4.38.exe.

    Now connected the phone in download mode to pc's USB port then launched Odin.

    Odin detects device and one COM port on the top left corner turned yellow. Now browse for the OPS file downloaded and respective firmware files like PDA, CSC, PHONE, MODEM etc. Click start.. within 10 minutes it shows up a PASS message turning into green color. During the flashing process mobile restarts and now the phone is up and working perfectly. I noticed slightly better performance than my previous firmware.

    The only thing I disappointed is I lost indian firmware Galaxy Pop and by installing european version my mobile turned into Galaxy Mini as it is the international name for S5570. Later I found that it is the ROM made for Red Bull mobile, though working fine with my Airtel 3G.

    When my phone bricked I thought that my phone became a permanent brick, but later came to know that its partially bricked. Anyhow, I got my phone back to working condition. From the information I have gone through on the net.. there is no solution to recover a hardware bricked phone...the only way is to replace some part of the motherboard chip..I think an expert technician can do that and bring back the phone alive.

    Hope you too can recover your phone if your download mode is working.

    There is a lot of information on internet to recover bricked android phones...I thank everybody who is contributing their knowledge and giving information and instructions to help others.

    Wish you good luck.
  6. sahilg009

    sahilg009 Active Member

    nope it was not a hardware fault it was due to clockwork mod but anyway my mobile was still in warranty and i send it to Samsung service center there they repaired my mobile in 10 days and it got back in its full working condition :):):):) was very happy
    by the way my mobile did boot into download mod that time so i became very sad well anyway thanks for your help:cool:
  7. venicejw

    venicejw Active Member

    my mobile also is dead now..i used rom manager..i tryed to backup current rom..but that time it was dead.. i tried to go into download mode by press and holding 3 buttons.. but nothing happens..i dont know why.. now its in service center..they told me that the board has to be replaced.. why it happens..?and how to make avail the download mode? plz anyone help..
Loading...

Share This Page