Bricked htc evo view 4g (htc flyer)

Last Updated:

  1. Medkid

    Medkid New Member

    I'm stuck in this situation with my htc evo view 4g device. I think it's a kind of soft brick, It still boots in to fastboot mode,and I could see that it's s-on, hboot is 1.13.

    everytime I try to reboot, or enter recovery, or factory reset it just hangs at this screen:

    I try to flash this stock rom
    (via both RUU on my pc and goldcard with, it was flashed flawlessly, but when finished it hangs in that "htc" screen.
    I tried to s-off by revolutionary but I can not access the android working screen so that can not enable usb debugging mode, on the pc it just shows
    I tried to unlock the bootloader via htcdev (I know my view 4g isn't in the supported list yet, but at least fastboot should read its info, but I was wrong). At step 8, it shows:

    Can some one please help me with this ? :(
    Thanks a lot,

  2. Maine Coon

    Maine Coon Well-Known Member

    Is there a chance you flashed Flyer ROM instead of View ROM?
    Where did you get this ROM?
    Is it under warranty?

Share This Page