Bricked...no wait I figured it out. But now, no mobile data connectivity.Support


  1. divinebovine

    divinebovine Well-Known Member Contributor

    This morning I woke up, unplugged the charge cable, noticed it was powered off, powered it on. Appeared to be booting up normally. A few minutes later I noticed it was off again.

    Then it wouldn't turn on. Tried removing battery for 5 minutes (while unplugged of course), no luck.

    Trying to power it on:
    • On battery: No response.
    • On USB power with battery installed: Battery charging indicator shows on screen for a couple seconds when I try to power it on.
    • On USB power with battery removed: Backlight flashes on and off for a couple seconds at a time.

    It wouldn't boot to recovery either.

    Tried a battery from a spare Venture, it booted right up with that battery while plugged in. Tried bad battery in spare Venture, that one booted when plugged in. Let spare Venture charge the battery all day, works fine on that battery.

    So, FYI, if your Venture has symptoms like this, it may just be battery-related.

    However, mobile data doesn't work. I have a full 6-bar signal (I can see the tower through my window from where I'm sitting). Usually I have a good 3G connection here. Also tried on the highway and at work...no data connection.

    How do I even begin troubleshooting no mobile data connectivity? :(

    Advertisement
    :
  2. divinebovine

    divinebovine Well-Known Member Contributor

    Nevermind, figured it out...I'm a dumbass, that was the problem. Mobile data was disabled in the settings. Must have been automatically disabled when the battery started to fail or something.
  3. varenHjames

    varenHjames Well-Known Member

    pfft !!! lol
    cheers mate!
Loading...

Share This Page